LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-04-2010, 02:20 PM   #1
mik3ca
LQ Newbie
 
Registered: Jul 2010
Posts: 5

Rep: Reputation: 0
slackware 13 can't play some audio??


I recently upgraded to slackware 13, and I discovered that the only things I can do audio wise is play audio CD's and adjust mixer volumes. I have a DELL C600 with a Maestro 3i soundcard. I am able to use the laptops advanced volume controls and I even played with the builtin KDE4 mixer over and over again. I have also unloaded and reloaded drivers.

Is there a step I am missing?

I even tried to test a wave file with "aplay", and that program locks up until I hit ctrl+c.
 
Old 07-04-2010, 07:07 PM   #2
hoodooman
Member
 
Registered: Oct 2006
Location: Stirling in Scotland
Distribution: Slackware 13.37 64 bit
Posts: 297

Rep: Reputation: 42
Have you tried opening a terminal and typing alsamixer.Some channels may be muted.unmute them by highlighting them end pressing m.Become root and type alsactl store.This then saves any changes.You move through the channels using the left/right direction arrows and increase/decrease volume using the up/down direction arrows.
 
Old 07-05-2010, 12:37 AM   #3
mik3ca
LQ Newbie
 
Registered: Jul 2010
Posts: 5

Original Poster
Rep: Reputation: 0
yes I tried going through alsamixer from the terminal box as well.

It seems that the moment I deleted....

everything from the /lib folder and files and folders within that folder
everything from the /usr folder and files and folders within that folder

and the moment I did a complete install of the old Slackware 12 (keeping everything else intact), everything works again. It makes me think that some part of the sound system in slackware 13 is buggy.

for now I will keep slackware 12.
 
Old 07-05-2010, 04:56 AM   #4
Dinithion
Member
 
Registered: Oct 2007
Location: Norway
Distribution: Slackware 14.1
Posts: 446

Rep: Reputation: 59
You don't give complete version number, but are you trying to upgrade directly from 12.0 to 13.0?

I usually do complete installs when a new distro is released, but the times I have upgraded, I haven't experienced any problems. But remember that there has been two versions in between. So there might be issues upgrading from 12.0 (avoiding 12.1 and 12.2) directly to 13.0 (or 13.1 for that matter).

Last edited by Dinithion; 07-06-2010 at 04:21 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't play audio CD in slackware ceashton Slackware 21 10-26-2011 06:01 PM
Cannot play audio CD on Slackware 13.0 KDE 4.2.4 traveller1212 Slackware 13 03-01-2010 03:21 PM
how to play audio cd in slackware 10.1? anindyanuri Slackware 13 06-26-2005 01:06 AM
Audio CD Doesn't Play - Slackware mijenks Slackware 9 07-22-2004 11:44 PM


All times are GMT -5. The time now is 02:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration