LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-26-2009, 05:12 PM   #1
DirkDD
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Rep: Reputation: 0
Slackware 12.2 -- Dell e1405 Wifi "Broadcom BCM4311"


Hey guys, I am very new to linux and this is my first question so far...
I have installed Slackware 12.2 to my Dell Inspiron e1405
Most everything works great so far, there are few issues i would like to resolve one being the wifi card doesnt activate.

i have tried several things including

'ifconfig wlan0 up'
SIOCSIFFLAGS: No such file or directory

if i currently run lspci -k for the wifi card i get
0c:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
Kernel driver in use: b43-pci-bridge
Kernel modules: ssb

I have tried to download the updated linux drivers from broadcom and follow the README file to compile the driver and install it...
but it seems that even after i do this after running lspci -k that the same drivers are still loaded for the card...

The readme file tells me to rmmod ssb b44 and a few others but this causes my eth0 adapter to quit as well:

02:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
Kernel driver in use: b44
Kernel modules: b44


I dont want to lood you guys with too much info... any ideas?

I was trying to avoid ndiswrapper... but will do it if i have to,,
 
Old 03-26-2009, 05:27 PM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,785
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Welcome to LQ!

Since you have a 4311, you should be using the 32 bit Broadcom driver from here. If this is the one you have been trying to use, could you fill in some details about what seems to be going wrong. I've been using this driver with Slackware 12.2 on a Dell Mini, so I know it does work.


Quote:
The readme file tells me to rmmod ssb b44 and a few others but this causes my eth0 adapter to quit as well:

02:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
Kernel driver in use: b44
Kernel modules: b44
I'm guess that the readme file is telling you to rmmod the b43 driver, not b44. The b43 driver is the reverse-engineered wireless driver for many Broadcom wireless chipsets, but for the 4311, the official driver I linked to above is almost certain to work better. The b44 driver should not interfere with any of the wireless drivers, so you don't have to remove it.
 
Old 03-26-2009, 05:58 PM   #3
DirkDD
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Ok, i downloaded the driver, followed instructions
insmod <path>/wl.ko .. received no errors or response...

The readme file does say to rmmod ssb..
but when i do so i get:
ERROR: Module ssb is in use by b43,b44
and it looks like
0c:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
Kernel driver in use: b43-pci-bridge
Kernel modules: ssb
its still using the other driver.. i tried to rmmod b43-pci-bridge but
ERROR: Module b43_pci_bridge does not exist in /proc/modules

I will try and blacklist the ssb and b43-pci-bridge next... to see what happens...
also i did a little reading on the boot..
b43-phy0 is the device is it states when it detects the adapter.. but not sure what that means...
 
Old 03-26-2009, 06:09 PM   #4
DirkDD
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Original Poster
Rep: Reputation: 0
hmm even though i blacklisted b43-pci-bridge and ssb they are still loading...
 
Old 03-26-2009, 06:59 PM   #5
DirkDD
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Original Poster
Rep: Reputation: 0
GOT IT!
I had to Install the Firmware to get it to finally click... dmesg | grep b43 showed me that the driver was having trouble finding the firmware..

Thanks for the help..
 
Old 03-27-2009, 07:26 AM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,785
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Um. OK. I'm glad you solved it. Just be aware that you're using the b43 driver and not the Broadcom wl driver. Just be sure that both b43 and wl aren't loading, that would cause a conflict. However, it really doesn't matter which driver you use as long as it works.

Oh, as far as insmod not returning anything, that is normal when a kernel module loads. The modules tools tend to respond only when errors occur.

Last edited by Hangdog42; 03-27-2009 at 07:28 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Slackware Essentials" or "Slackware Linux Basics" ? alMubarmij Slackware 3 03-14-2009 07:51 PM
Getting wireless to work with Broadcom bcm4311 (rev 02) BCarey Slackware 1 01-04-2009 04:08 PM
Broadcom bcm4311 driver issues conway.federico Linux - Wireless Networking 1 10-07-2008 07:31 AM
Broadcom bcm43xx (also dell 1390) wifi device Garda Linux - Hardware 3 02-22-2007 06:40 AM
"multiboot utility" and "dell utility partition" on dell i5150 xround Linux - Laptop and Netbook 5 04-21-2005 09:19 AM


All times are GMT -5. The time now is 04:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration