LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-26-2006, 07:57 PM   #1
noonmid27
Member
 
Registered: Sep 2006
Posts: 79

Rep: Reputation: 15
Slackware 11


I am having some trouble with setting up the internet connection in Slackware version 11. i've doen the netconfig in terminal but still no luck. I was asked to give a client name, i assumed you can give it anyname so i called it slack. then i was asked for a domain name i put in www.sympatico.ca thats my ISP provider. then i selected the option for DHCP. i then hit ok twice. I got a prompt saying the setup was complete i then tried to connect to the internet but i get no connection. what can i go to solve this problem. i am the second computer connected to the internet throught a 4 port dlink wired router. the main computer has the DSL modem.
 
Old 10-26-2006, 08:07 PM   #2
Penguin of Wonder
Senior Member
 
Registered: Sep 2005
Location: West Virginia
Distribution: Gentoo
Posts: 1,249

Rep: Reputation: 45
Your domainname and such should be configured through your router. Check your router's config to see what all the names are. I had this problem as well when setting up one of my Gentoo boxes.

Last edited by Penguin of Wonder; 10-26-2006 at 08:11 PM.
 
Old 10-26-2006, 11:08 PM   #3
Frank Rizz0
LQ Newbie
 
Registered: Jul 2006
Posts: 4

Rep: Reputation: 0
Yeah I'm having the same problem, but I have set my domain name as wp.shawcable.net, which is what my router is. I'm a new Slack user, and have not had any problems setting up my internet with any other distro ( Debian, Xandros, Mandrake, Suse, Mepis, FreeBSD and Gentoo ), so I assumed that my internet would be quite simple. I have the huge kernel ( 2.6.17.13 ), and also tried with 2.6.18 kernel, which I plan to switch back to. My router is a Linksys WRT54G, not sure if this would be the problem, but FreeBSD was the OS I was using previously, and the Internet worked flawlessly. I'm hoping someone has an answer because this is one DAMN nice OS. Thanks in advance!!!
 
Old 10-27-2006, 03:23 AM   #4
koyi
Member
 
Registered: Jul 2003
Location: Osaka, Japan
Distribution: Arch, Ubuntu
Posts: 421

Rep: Reputation: 31
If another computer that is connected to the same router, with linux/FreeBSD/other unixes running on it, and have its Internet connection running well, you can check its settings to determine what parameters to use on this Slack box.

However, I often set my domain name to something unreal, i.e. "mywonderland" or basically anything I like. Since you are using DHCP I suppose the domain wont be a problem... correct me if I am wrong, though.
 
Old 10-27-2006, 08:10 AM   #5
Frank Rizz0
LQ Newbie
 
Registered: Jul 2006
Posts: 4

Rep: Reputation: 0
Yeah, I have other Linux / Unix systems working well behind my router. Not sure how ( or what ) you mean by "determine what parameters to use."
 
Old 10-27-2006, 10:15 AM   #6
Penguin of Wonder
Senior Member
 
Registered: Sep 2005
Location: West Virginia
Distribution: Gentoo
Posts: 1,249

Rep: Reputation: 45
Just look at the connection settings for the other Linux box and copy those to your Slackware's configuration. Your domianname, hostname, etc.
 
Old 10-27-2006, 11:19 AM   #7
noonmid27
Member
 
Registered: Sep 2006
Posts: 79

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Penguin of Wonder
Just look at the connection settings for the other Linux box and copy those to your Slackware's configuration. Your domianname, hostname, etc.

hey i figured out how to setup the connection now. the username is just localhost the domain name is localdomain. select DHCP then hit enter twice. you will get another filed asking for the CC------A account number provided by ISP just hit enter, then reboot the computer and you should be able to connect.
 
Old 10-28-2006, 09:09 AM   #8
Frank Rizz0
LQ Newbie
 
Registered: Jul 2006
Posts: 4

Rep: Reputation: 0
I', mot exactly sure where you are talking about. I tried that in control center, did not work.only other place I can think of which you're talking about is back at the initial install.
 
Old 10-28-2006, 09:54 AM   #9
Frank Rizz0
LQ Newbie
 
Registered: Jul 2006
Posts: 4

Rep: Reputation: 0
I've just re-installed with 2.6.18 kernel, I've changed /etc/hosts to what my FreeBSD box is ( this is what was on it before, and I'm still using another box with FreeBSD ), still no luck. When I open control center, the first screen that pops up in network settings is "Your Platform Is Not Supported" and asks me to choose a supported platform. Now I have changed it previously, but not on this install, because it has not worked. Any advice???
 
Old 10-28-2006, 10:34 AM   #10
noonmid27
Member
 
Registered: Sep 2006
Posts: 79

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Frank Rizz0
I've just re-installed with 2.6.18 kernel, I've changed /etc/hosts to what my FreeBSD box is ( this is what was on it before, and I'm still using another box with FreeBSD ), still no luck. When I open control center, the first screen that pops up in network settings is "Your Platform Is Not Supported" and asks me to choose a supported platform. Now I have changed it previously, but not on this install, because it has not worked. Any advice???
open the terminal and type netconfig. then you can put in localhost, localdomain, select DHCP hit enter twice and you will be connected. you must be root user as well when you open the terminal. so you have to see the # sign which makes you root user then you can configure the internet.
 
Old 10-28-2006, 11:39 AM   #11
Penguin of Wonder
Senior Member
 
Registered: Sep 2005
Location: West Virginia
Distribution: Gentoo
Posts: 1,249

Rep: Reputation: 45
To find the settings on your router you have to goto the routers control panel. Not your computers. Open firefox and type in the address of the router. Even if you can't get to internet, as long as your plugged into the router, you can get to it. After you type its address in the address bar you should prompted for your name and password. Then you can changed and review everything you want.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
About Slackware 9.1 boot disk?? ftp://ftp.kpn.be/pub/linux/slackware/slackware-9.1-is AL3OMDAH Slackware 4 04-18-2007 10:54 AM


All times are GMT -5. The time now is 11:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration