LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Slackware 10: Failed Dependencies (http://www.linuxquestions.org/questions/linux-newbie-8/slackware-10-failed-dependencies-205568/)

Russb 07-15-2004 06:46 PM

Slackware 10: Failed Dependencies
 
Alright, this isn't the first time I have had problems with this. I just installed Slackware 10 from the iso images and installed the kernel source as well... At least as far as I know (Is there a way to check that I did it right?). I try to install java with the rpm and get this:

Code:

root@slackware:/home/seeded# rpm -iv j2re-1_4_2_05-linux-i586.rpm
error: Failed dependencies:
        glibc >= 2.1.2-11 is needed by j2re-1.4.2_05-fcs
        sh-utils >= 2.0-1 is needed by j2re-1.4.2_05-fcs
        fileutils >= 4.0-8 is needed by j2re-1.4.2_05-fcs
        gawk >= 3.0.4-1 is needed by j2re-1.4.2_05-fcs
        textutils >= 2.0-2 is needed by j2re-1.4.2_05-fcs
        /bin/sh is needed by j2re-1.4.2_05-fcs
root@slackware:/home/seeded#

I got an even bigger list when I tried to install my ATI drivers. What are these all about? I was looking at the Slackware 10 package and it should have all of these and even some updated ones. Any guidance would be appreciated! :confused: :study:

Russb 07-15-2004 06:49 PM

Just thought I'd add this for more information on the problem of dependencies. Thsi is what I got back when I tried to install my ATI drivers. The "workaround" was converting it using rpm2tgz... Although I don't think that completely solved the problem.

Code:

root@slackware:/home/seeded# rpm -i --force fglrx-4.3.0-3.9.0.i386.rpm
error: Failed dependencies:
        /bin/sh is needed by fglrx-4.3.0-3.9.0
        ld-linux.so.2 is needed by fglrx-4.3.0-3.9.0
        libX11.so.6 is needed by fglrx-4.3.0-3.9.0
        libXext.so.6 is needed by fglrx-4.3.0-3.9.0
        libc.so.6 is needed by fglrx-4.3.0-3.9.0
        libdl.so.2 is needed by fglrx-4.3.0-3.9.0
        libm.so.6 is needed by fglrx-4.3.0-3.9.0
        libpthread.so.0 is needed by fglrx-4.3.0-3.9.0
        libc.so.6(GLIBC_2.0) is needed by fglrx-4.3.0-3.9.0
        libc.so.6(GLIBC_2.1) is needed by fglrx-4.3.0-3.9.0
        libc.so.6(GLIBC_2.1.3) is needed by fglrx-4.3.0-3.9.0
        libm.so.6(GLIBC_2.0) is needed by fglrx-4.3.0-3.9.0
        libpthread.so.0(GLIBC_2.0) is needed by fglrx-4.3.0-3.9.0
root@slackware:/home/seeded#

Thanks! :scratch:

Tinkster 07-15-2004 06:50 PM

Slackware isn't rpm-based, it doesn't create or
maintain an rpm database for you.

You should try to AVOID rpms in Slack.

The only thing you can do (if something isn't available
in a sensible package format) is manually check whether
the requirements are met, and then use --force on the
rpm installation.



Cheers,
Tink

Russb 07-15-2004 07:38 PM

So even though Slackware 10 has these it's not in a RPM database? That is why I get these errors? That makes sense if it's true. So my options are to --force the install and what about rpm2tgz? Is this command there for this reason? That Slackware does not maintain rpm databases?

I'm loving Linux everyday I use. It's more fun configuring it to your personal standards than playing games in M$ I think! :p I'm learning and I appreciate the help! I will soon be developing in C++ here other than Windoze. Maybe eventually uninstall Windoze too! :cool:

Tinkster 07-15-2004 08:10 PM

Quote:

Originally posted by Russb
So even though Slackware 10 has these it's not in a RPM database? That is why I get these errors? That makes sense if it's true.
/me greps his gray cells ...

Yep, all say that Slack and RPM's don't really mix ;)
Of all major distro's slack is the only one with a packaging
system that DOESN'T check dependencies!

Quote:

So my options are to --force the install and what about rpm2tgz? Is this command there for this reason? That Slackware does not maintain rpm databases?
Yep, yep and yep ...

Quote:

I'm loving Linux everyday I use. It's more fun configuring it to your personal standards than playing games in M$ I think! :p I'm learning and I appreciate the help! I will soon be developing in C++ here other than Windoze. Maybe eventually uninstall Windoze too!
Good on yah, and good luck! :)


Cheers,
Tink

Russb 07-15-2004 08:52 PM

Tink, You are great help, thanks!

I found a .bin for the java installer and used sh on it. Installed perfectly! Now, I think I messed up the link and can't for the life of me fix it. Unless of course I am linking the wrong thing. Here it is:

Code:

ln -s /usr/java/j2re1.4.2_05/plugin/i386/ns610-gcc32/libjavaplugin_oji.so
Atleast that's what the java page said to do. Firefox now closes as soon as java tries to load. :confused: Well.... I'm almost there! :p

Tinkster 07-15-2004 09:46 PM

My apologies for not spotting that earlier ... why don't
you just install the JDK that came with Slack 10, and
install the moz-plugins as well? :)

Worked out of the box here ...


Cheers,
Tink

Russb 07-16-2004 07:47 AM

Well.. I could. But I came this far already. All I got to do is figure out this damn link problem. I am sure I will find something out. I don't know. :scratch:

Tinkster 07-16-2004 09:03 PM

In this case the question is
"Where were you when you issued the ln?" :)

The plugin is the right one.


Cheers,
Tink

Russb 07-16-2004 09:35 PM

Got it figured out! I had my links backwards! Silly me! Thanks Tink!


All times are GMT -5. The time now is 05:49 AM.