LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-17-2005, 08:01 AM   #1
PastorFrederick
LQ Newbie
 
Registered: Oct 2005
Location: Newfoundland
Distribution: Slackware 10.2
Posts: 12

Rep: Reputation: 0
Question Slackware 10.2: How do I change default font for shell?


when installing slackware I decided to use a different font than the default, however, I accidently changed it to the wrong font, and now keys like "/" "\" and their respective shift counterparts (along with others) show up in shell as a "e" or "a" with " ' " over them.

How can I change the font back to one that includes all the keys?

Thanks is advance.
 
Old 10-17-2005, 09:40 AM   #2
b0nd
Senior Member
 
Registered: Jan 2005
Distribution: Slackware, BackTrack, Windows XP
Posts: 1,020

Rep: Reputation: 45
Hello,
go to start menu......then to "Settings" -> control Centre........
there are options for icons/Desktop etc..
try making that default
see whether it works for u ..

regards
 
Old 10-17-2005, 11:27 AM   #3
PastorFrederick
LQ Newbie
 
Registered: Oct 2005
Location: Newfoundland
Distribution: Slackware 10.2
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks for the tip.

However, the xkde fonts aren't the problem, its the shell and konsole fonts. I've tried changing all the fonts in each default or other wise, and it doesn't seem to work. But I'll try again.
 
Old 10-17-2005, 12:13 PM   #4
apolinsky
Member
 
Registered: Oct 2004
Location: Brooklyn
Distribution: Slackware 14.1, 14.2; Debian Jessie; Centos 6; FreeBSD 9 & 10
Posts: 272

Rep: Reputation: 35
In lilo, there are a series of commands such as vga=791 etc. All are commented out. They refer to using a framebuffer at various resolutions, and all are commented. Uncomment the one you want and run lilo again to wrtie the change to the mbr. If the number you chose is not supported by your video card, you will get an error.
 
Old 10-17-2005, 01:19 PM   #5
imitheos
Member
 
Registered: May 2005
Location: Greece
Posts: 415

Rep: Reputation: 86
Quote:
Originally posted by PastorFrederick
Thanks for the tip.

However, the xkde fonts aren't the problem, its the shell and konsole fonts. I've tried changing all the fonts in each default or other wise, and it doesn't seem to work. But I'll try again.
If you want to change the console fonts then edit /etc/rc.d/rc.font
it will probably have something like "setfont -v foo-font"
or run "/usr/bin/setconsolefont" to get the same dialog based questions you got during the installation.
 
Old 10-17-2005, 04:41 PM   #6
apolinsky
Member
 
Registered: Oct 2004
Location: Brooklyn
Distribution: Slackware 14.1, 14.2; Debian Jessie; Centos 6; FreeBSD 9 & 10
Posts: 272

Rep: Reputation: 35
I am home right now. I rarely use the 'X' environment. There is a comment in /etc/lilo.conf that says #VESA framebuffer console @ 800x600x256
the following line says vga = 771. There is no # (comment) in front of the line. That means my login (I am normally at the command line) will be output at 800x600 with 256 colors. There are many alternatives from which you can try. Only uncomment out one of the options. This means you remove the # from one of the lines. Finally type lilo to make sure the changes are copied to the mbr.
 
Old 10-17-2005, 11:10 PM   #7
jrdioko
Member
 
Registered: Oct 2002
Distribution: Debian 6.0.2 (squeeze)
Posts: 944

Rep: Reputation: 30
http://www.slackbook.org/html/instal...p.html#AEN1100

You can always go to the font section of setup in pkgtool, like you do when you install Slack in the first place.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change default MLTERM font ? Bonch Debian 1 10-30-2004 04:44 AM
how to change the default font used by xpdf? parv Linux - Newbie 1 07-29-2004 10:17 PM
How can I find/change default X font? cold Linux - General 1 06-21-2004 03:58 PM
How to change default font setting? boeckmann Linux - General 2 06-11-2004 06:38 PM
How do I change my default font...? htimst Linux - General 5 10-10-2002 11:41 AM


All times are GMT -5. The time now is 11:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration