LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-21-2005, 04:54 PM   #1
conner19
LQ Newbie
 
Registered: Sep 2005
Posts: 13

Rep: Reputation: 0
Slackware 10.1 startup issues


Hello everyone. I am very new to linux, and have installed Slackware 10.1 on a new system and I'm having a lot of difficulty starting KDE. when I type startkde I get a lot of the following.

xsetroot: unable to open display
xset: unable to open display
xset: unable to open display
xset: unable to open display
xsetroot: unable to open display
startkde: starting up
startkde: running kpersonalizer
kwin: cannot connect to x server
kpersonalizer: cannot connect to x server

and that last line continues to repeat.

What am I doing wrong here?

I am logged in as root and slackware is installed on /dev/hda1.
 
Old 09-21-2005, 05:00 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 469Reputation: 469Reputation: 469Reputation: 469Reputation: 469
Firstly, don't login as root - create a normal user account and log in as that. You may mess up your system if you do something accidental and wrong as root.

To get KDE running: first run "xwmconfig" as your normal user (minus the quotes) and select KDE as your window manager. Then run "startx" (again, as the user and without the quotes).

Welcome to LQ
 
Old 09-22-2005, 02:48 PM   #3
conner19
LQ Newbie
 
Registered: Sep 2005
Posts: 13

Original Poster
Rep: Reputation: 0
ok, I did that, and when I type in startx I get the following.

fatal server error:
no screens found

XIO: fatal IO Error 104 (Connection reset by peer) on x server ":0.0"
after 0 requests with 0 events pending.

and then it takes me back to the prompt. what did I do wrong?
 
Old 09-22-2005, 03:22 PM   #4
freakyg
Member
 
Registered: Apr 2005
Distribution: LFS 5.0 and 6.1
Posts: 705

Rep: Reputation: 30
did you configure X properly??
Code:
 xorgconfig
 
Old 09-22-2005, 03:56 PM   #5
conner19
LQ Newbie
 
Registered: Sep 2005
Posts: 13

Original Poster
Rep: Reputation: 0
ok, I did that, and went through all of the prompts, all of this while logged in a new user not root, and it saved the file and then I typed startx and it gave me the same fatal error.
 
Old 09-22-2005, 04:47 PM   #6
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Rep: Reputation: 32
Quote:
Originally posted by conner19
ok, I did that, and went through all of the prompts, all of this while logged in a new user not root, and it saved the file and then I typed startx and it gave me the same fatal error.
Where did you save the file ? The file has to be saved as /etc/X11/xorg.conf
A non-root user cannot write to the /etc directory.

You ran the command xorgconfig as a non-root user, right !
Then in the end it would have asked you where to save the file and by what name. By default (if you were non-root) it would have saved the file in the current directory as xorg.conf


You have two options at hand :

1) run xorgconfig as a root user and save the file as /etc/X11/xorg.conf or,

2) run xorgconfig as a non-root user, save the file as xorg.conf in your current directory. Then as root replace the original /etc/X11/xorg.conf by the one you just created.

Try any of these and post back whatever you find.

Hope this helps.
 
Old 09-22-2005, 05:27 PM   #7
conner19
LQ Newbie
 
Registered: Sep 2005
Posts: 13

Original Poster
Rep: Reputation: 0
ok, ran the xorgconfig as root, and did everything according to the prompts, and it saved the file in /etc/x11

logged off and logged back into the system as the non-root user. Ran startx and got the same error message.
 
Old 09-22-2005, 06:02 PM   #8
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Rep: Reputation: 32
Okay ! Post the complete error message. Use the
Code:
 <error messages here>
tags for this.

Also, I would like to point out that the file has to be saved as /etc/X11/xorg.conf and not /etc/x11/xorg.conf ( I think that was a typo )
Linux is case sensitive !
 
Old 09-22-2005, 08:20 PM   #9
conner19
LQ Newbie
 
Registered: Sep 2005
Posts: 13

Original Poster
Rep: Reputation: 0
yes you are correct it is case sensitive and it was X11, my bad.

I will post the error message in a few minutes.
 
Old 09-22-2005, 08:37 PM   #10
conner19
LQ Newbie
 
Registered: Sep 2005
Posts: 13

Original Poster
Rep: Reputation: 0
ok, here it is when I type startx at the prompt.

Code:
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/Linux:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X Window System Version 6.8.1
Release Date: 17 September 2004
X Protocol Version 11, Revision 0, Release 6.8.1
Build Operating System: Linux 2.4.29 i686 [ELF]
Current Operating System: Linux Linux 2.4.29 #6 Thu Jan 20 16:30:37 PST 2005 i686
Build Date: 23 January 2005
        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Sep 22 20:35:59 2005
(==) Using config file: "/etc/X11/xorg.conf"
(EE) VGA(0): Driver can't support depth 24
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
         at http://wiki.X.Org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.
I don't understand. I choose just a generic VGA compatible adapter with the lowest settings and it still doesn't work.
 
Old 09-23-2005, 08:35 AM   #11
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Rep: Reputation: 32
Quote:
Originally posted by conner19
ok, here it is when I type startx at the prompt.

Code:
_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/Linux:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

X Window System Version 6.8.1
Release Date: 17 September 2004
X Protocol Version 11, Revision 0, Release 6.8.1
Build Operating System: Linux 2.4.29 i686 [ELF]
Current Operating System: Linux Linux 2.4.29 #6 Thu Jan 20 16:30:37 PST 2005 i686
Build Date: 23 January 2005
        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Sep 22 20:35:59 2005
(==) Using config file: "/etc/X11/xorg.conf"
(EE) VGA(0): Driver can't support depth 24
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
         at http://wiki.X.Org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.

Hey Conner19,

the problem is coz somehow your graphics card doesn't like the default depth of 24
Reduce the default depth to some lower no. like 16. Here do this :

Open up your xorg.conf file.
Go to the monitor section
Change the default depth there, i.e reduce it to some lower value. Note that, the value that is uncommented (without # sign), is the one that is being used. Save the file and startx again.
Try this with different depths. Tell us what happened.

Some examples of this are :
Code:
#   DefaultDepth 8
   DefaultDepth 16
#   DefaultDepth 24
#   DefaultDepth 32

Here depth of 16 is being used
To use depth of, say 8
Code:
   DefaultDepth 8
#   DefaultDepth 16
#  DefaultDepth 24
#   DefaultDepth 32

Here depth of 8 is in use

Also take a look at this thread. It also deals with a similar problem.

Post back whatever you find.
 
Old 09-23-2005, 04:30 PM   #12
conner19
LQ Newbie
 
Registered: Sep 2005
Posts: 13

Original Poster
Rep: Reputation: 0
Ok, something you'll have to understand about me. I'm a complete Windows guy, who is learning linux. I have a Linux + study book to help me, but I still do not completely know how to do these things. I checked the file and it's saying

Code:
 Section "Screen"
    Identifier  "Screen 1"
    Device      "diamond stealth"
    Monitor     "dell828fs"
    DefaultDepth 24
now how do I change that in the xorg.conf file?
 
Old 09-23-2005, 05:11 PM   #13
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Rep: Reputation: 32
No problems at all. We're all here to help and be helped

Also, everybody was a n00b sometime or the other

Do this :

Code:
 Section "Screen"
    Identifier  "Screen 1"
    Device      "diamond stealth"
    Monitor     "dell828fs"
    DefaultDepth 16

This will make your default depth as 16. If this doesn't work try with depth 8 i.e.


Code:
 Section "Screen"
    Identifier  "Screen 1"
    Device      "diamond stealth"
    Monitor     "dell828fs"
    DefaultDepth 8

One thing I would like to mention here :

In linux much information is stored in configuration files. In these files usually '#' is used to indicate a comment. like // or /* */ in C/C++


Suppose, you wanted to state what changes you made to get your X running. You could add a comment like :


Code:
 Section "Screen"
    Identifier  "Screen 1"
    Device      "diamond stealth"
    Monitor     "dell828fs"
    
# Changed the default depth to 16 and it worked !

    DefaultDepth 16
The whole point is that commented lines i.e. lines beginning with a # sign are ignored by whatever program, that reads that particular file. Therefore, when a program encounters this :


Code:
 Section "Screen"
    Identifier  "Screen 1"
    Device      "diamond stealth"
    Monitor     "dell828fs"
    

#  DefaultDepth 8
    DefaultDepth 16
#  DefaultDepth 24
It completely ignores the lines beginning with # and so takes the DefaultDepth to be 16

Hope this helps !

Last edited by koodoo; 09-23-2005 at 05:17 PM.
 
Old 09-24-2005, 11:42 AM   #14
conner19
LQ Newbie
 
Registered: Sep 2005
Posts: 13

Original Poster
Rep: Reputation: 0
ok, I understand that I need to edit the 24 to 16, but how do I actually do that from the command line? I know how to display the contents of the file, but how do I edit it? do I have to go through xorgconfig again? and if so, at what point to I set it to default on 16?
 
Old 09-24-2005, 12:54 PM   #15
weimond
LQ Newbie
 
Registered: Sep 2005
Location: uk
Distribution: slackware 10.2, win xp
Posts: 17

Rep: Reputation: 0
use a text editor like vi

type "vi /etc/X11/xorg.conf" and vi should load up the configuration file. vi works either in command mode or insert mode. press esc for command mode and type i for insert mode. the bottom right of the screen should tell you what mode youre in. then just go down to the monitor section and edit the file. then go back to command mode and type ":wq" and press enter. this writes the file and quits vi.

hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Startup Issues !! darkmagic Linux - Newbie 12 08-26-2005 01:59 AM
Slack uninstall and startup issues Aphex_Twin2 Slackware 9 05-07-2005 12:43 PM
Startup Issues LinuxLoverMeg Mandriva 3 09-24-2004 01:18 AM
FC2 startup issues msie02 Fedora 0 09-19-2004 11:44 AM
VncServer - Startup issues TrueSword Linux - General 1 12-06-2002 06:13 PM


All times are GMT -5. The time now is 07:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration