LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-23-2005, 07:51 PM   #1
d2490n
Member
 
Registered: Jul 2005
Location: San Diego, CA
Distribution: RHEL, Debian, Gentoo when I'm brave.
Posts: 47

Rep: Reputation: 15
skype not working after one call.


ok slack 10.2
skype 1.2.0.18

i start skype and make a call, than i hang up and get "/dev/dsp-1: Device or resource busy"in the term.
than when i try to make another call skype says "problem with sound device" and term repeats the same "/dev/dsp-1: Device or resource busy" msg. the only way sofar to fix this is to restart skype.

this happens with skypeout calls (calls to a regular phone) and with short regular calls, it semes to not happen if i have a regular call for more than 3 min.

thanx for any help you can give me at all.
 
Old 12-23-2005, 08:11 PM   #2
Kirmonkey
Member
 
Registered: Jan 2004
Location: UK
Distribution: Debian
Posts: 194

Rep: Reputation: 30
Me too.

Ubuntu Breezy
Skype 1.2.0.18_API

I only get the message if the call has connected. and then I try a second call.

hope someone has an idea.
 
Old 12-26-2005, 02:27 PM   #3
d2490n
Member
 
Registered: Jul 2005
Location: San Diego, CA
Distribution: RHEL, Debian, Gentoo when I'm brave.
Posts: 47

Original Poster
Rep: Reputation: 15
*bump

nobody has any ideas?
well i guess ill keep trying any input is still appriciated.
 
Old 12-26-2005, 07:40 PM   #4
Lotharster
Member
 
Registered: Nov 2005
Posts: 144

Rep: Reputation: 18
This is a well-known bug in Skype. Unfortunately, the Skype guys chose not to fix it in the new releases. But there is a workaround. Just google for "Skype dsp hijacker" and install the newest version (0.6). That worked for me.

Lotharster
 
Old 12-27-2005, 02:43 PM   #5
d2490n
Member
 
Registered: Jul 2005
Location: San Diego, CA
Distribution: RHEL, Debian, Gentoo when I'm brave.
Posts: 47

Original Poster
Rep: Reputation: 15
assume, thanx man, only problem naw is that the sound is fading in and out, like somebodies messing with a volume knob.
know anything about that?
 
Old 01-25-2006, 10:43 AM   #6
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
sound fading, vaguely remember something like that in the skype forum.
Sorry not very helpfull.
Does it do it with echo123 ?
 
Old 02-16-2006, 03:36 PM   #7
arsham
Member
 
Registered: Mar 2004
Location: London
Distribution: Arch Linux, Debian
Posts: 184

Rep: Reputation: 30
do you have /dev/dsp-1 ?
or maybe other programms uses dsp-1 ?
try to change to /dev/dsp in options
try :
# lsof | grep dsp
see if other programs use this resource , and kill it , then try skype
 
Old 02-21-2006, 11:13 AM   #8
caio80
LQ Newbie
 
Registered: Oct 2003
Location: Italia
Distribution: Gentoo
Posts: 4

Rep: Reputation: 0
Solved

I posted my solution on the skype forums, i quote it (can't put http links 'til i get 5 posts overall)



As I thought,

just go in the sound directory, remove the hangup.wav file, and skype will stop from overlapping the hangup.wav sound over the conversation sound, causing problems in most systems, where dsp can't treat multiple streams at once.

Hope this works for everybody, I'm almost sure this is definitely the problem you guys all have.

In that case, just say "Grazie!"




Regards

caio80
 
Old 02-21-2006, 03:03 PM   #9
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
caio80, this is most helpfull, many thanks. It does work indeed.
mv /usr/share/skype/sound/hangup.wav /usr/share/skype/sound/hangup.wav.disabled
Now that skype is working, will have to learn linphone or something else
 
Old 02-22-2006, 03:19 AM   #10
arsham
Member
 
Registered: Mar 2004
Location: London
Distribution: Arch Linux, Debian
Posts: 184

Rep: Reputation: 30
Quote:
Originally Posted by caio80
I posted my solution on the skype forums, i quote it (can't put http links 'til i get 5 posts overall)



As I thought,

just go in the sound directory, remove the hangup.wav file, and skype will stop from overlapping the hangup.wav sound over the conversation sound, causing problems in most systems, where dsp can't treat multiple streams at once.

Hope this works for everybody, I'm almost sure this is definitely the problem you guys all have.

In that case, just say "Grazie!"




Regards

caio80
in control center > Sound & multimedia > Sound system , set the Auto-suspend if idle after to 1 seccond , and bring back your wav file to original posision
may helps

regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't get microphone working on krec or skype shengchieh Linux - Newbie 7 11-07-2009 02:00 PM
Call of Duty 2 Cronjob Not working zend Linux - Software 3 11-15-2005 10:52 AM
IP Cop - Skype Fuel Linux - Security 4 03-13-2005 03:28 AM
What do you call your remote control? I call mine... RHLinuxGUY General 19 10-18-2004 06:23 AM
new system call not working.... mmars Programming 2 10-23-2003 05:41 PM


All times are GMT -5. The time now is 11:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration