LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-09-2009, 05:01 PM   #1
ceantuco
Member
 
Registered: Mar 2008
Location: New Jersey
Distribution: CentOS, Debian, Kali
Posts: 579

Rep: Reputation: 37
Question Skype error


Hi guys,

I just installed Skype for openSuse... RPM installation went fine however when I tried running the program I get the following error message:
skype: symbol lookup error: /usr/lib/libQtNetwork.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv

any help is greatly appreciate it! :=)
 
Old 03-10-2009, 03:06 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Check which version of Qt the RPM expects, and which version you have
installed - there's obviously a problem with the shared library.
 
Old 03-11-2009, 03:43 PM   #3
ceantuco
Member
 
Registered: Mar 2008
Location: New Jersey
Distribution: CentOS, Debian, Kali
Posts: 579

Original Poster
Rep: Reputation: 37
hi guys,

I was missing the QT4 library on my system. I installed it from my DVD installation and it worked! thanks for your responses! :=)
 
Old 03-17-2009, 03:46 PM   #4
ceantuco
Member
 
Registered: Mar 2008
Location: New Jersey
Distribution: CentOS, Debian, Kali
Posts: 579

Original Poster
Rep: Reputation: 37
ok, after skype worked for a few days it stopped working again! :@ I get the same error:

# skype
skype: symbol lookup error: /usr/lib/libQtNetwork.so.4: undefined symbol: _ZN14QObjectPrivate15checkWindowRoleEv


I googled this error message and I found on a Ubuntu forum that by removing duplicate records on ld.so.conf it fixed the issue for many except for me. this is what my file looks like:

# cat ld.so.conf
/usr/X11R6/lib/Xaw3d
/usr/X11R6/lib
/usr/lib/Xaw3d
/usr/i386-suse-linux/lib
/usr/local/lib
/opt/kde3/lib
/opt/nessus/lib
include /etc/ld.so.conf.d/*.conf


is there something I could do to resolve this issue? I need Skype working and I REFUSE TO W$NDOWS.

Thanks in advance.
 
Old 03-19-2009, 12:07 PM   #5
ceantuco
Member
 
Registered: Mar 2008
Location: New Jersey
Distribution: CentOS, Debian, Kali
Posts: 579

Original Poster
Rep: Reputation: 37
it seems like none has any advice for me! I will have to give up and use SKYPE with W$ndows.. at least I tried.
 
Old 03-19-2009, 01:19 PM   #6
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
I'm running skype with no problems on my debian box. I've got libqt4-network version 4.4.3-2 package installed. Which version do you have? Also it seems google-earth uses its own version of libQtNetwork.so.4 so much sure that is not mixing up skype.
cheers,
jdk
 
Old 03-19-2009, 01:41 PM   #7
ceantuco
Member
 
Registered: Mar 2008
Location: New Jersey
Distribution: CentOS, Debian, Kali
Posts: 579

Original Poster
Rep: Reputation: 37
hi,

im running ver 4.4.0
 
Old 03-19-2009, 07:41 PM   #8
JaksoDebr
Member
 
Registered: Mar 2009
Distribution: Fedora, Slackware
Posts: 104

Rep: Reputation: 21
Skype also has downloads for a static version of Skype - that one should not have any external dependencies, though application size will be larger. You should also note that Skype doesn't put too much ambition into keeping distro-specific packages up-to-date - most of these are quite outdated.

Linux Archive

Last edited by JaksoDebr; 04-02-2009 at 06:14 AM.
 
Old 03-20-2009, 02:05 AM   #9
ceantuco
Member
 
Registered: Mar 2008
Location: New Jersey
Distribution: CentOS, Debian, Kali
Posts: 579

Original Poster
Rep: Reputation: 37
ok, I found a "temporary solution" to my issue. After I got my SKYPE working the first time I wasn't able to run Nessus so I copied /nessus/lib to /lib and that solved my Nessus issue but damaged my Skype. After trying many things such as re-installing libQtNetwork.so.4 I decided to erase the /nessus/lib files that I copied to /lib, that solved my Skype issue however I can't run Nessus.
I added /nessus/lib to ld.so.conf, rebooted my machine and now Nessus works but SKYPE doesnt! grrrr well hopefully I will be able to find a permanent solution.
At least I'm glad I won't have to use M$crosoft to run Skype! lol
Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
skype error tamilm Linux - Newbie 1 12-02-2008 09:30 PM
Skype runtime error: libstdc++.so.6: no version information billion Linux - Software 1 01-21-2008 12:43 PM
Skype carlosinfl General 10 11-12-2006 11:31 AM
Skype permafrost91 Linux - Software 1 05-24-2005 10:51 PM
Skype starting error !!! hitesh_linux Linux - Software 7 01-16-2005 09:18 AM


All times are GMT -5. The time now is 04:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration