LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-15-2004, 07:25 AM   #16
SoliTear
Member
 
Registered: Jan 2004
Location: Ohio
Distribution: Debian Wheezy with updated kernel
Posts: 41

Original Poster
Rep: Reputation: 15

rootyard: you've forgotten what it is to be a complete beginner and not know what is important and what is not important.

i haven't got it to work, as far as i know. i plan to take a step back and try and understand more about the linux environment. i am going to update the other parts that i can from the www.gnu.org site. like autoconf, make, binutils and such. i am wondering if Mandrake has stuff configured in a funny way that is alittle out of the norm and maybe that is what is going wrong. i also tried the latest development build. My next step is to study X86Free environment and see if that needs some updating or change in its configuration. on my system the .desktop file seems to be the one that determins which desktop startx uses. i don't have the .xinitrc in my home. i am going to see if that is one of the base reasons the think won't compile. i just don't understand why the errors are in the following functions:

fluxbox.cc: In member function `void Fluxbox::save_rc()':
fluxbox.cc:1976: error: `B_EuropeanDate' undeclared
fluxbox.cc: In member function `void Fluxbox::load_rc(BScreen*)':
fluxbox.cc:2324: error: `B_AmericanDate' undeclared
make[3]: *** [fluxbox.o] Error 1
make[3]: Leaving directory `/home/solitear/fluxbox-0.1.14/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/solitear/fluxbox-0.1.14/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/solitear/fluxbox-0.1.14'
make: *** [all] Error 2

i updated my autoconf to the latest version and i plan to update my make utility as well and the binary utilities. then i'll try to delete all the directories that fluxbox config and make made and start again, one i look at XF86Free.

i even tried the 1.12 version that someone else got working. so that is why i wonder if maybe some files are missing or the system is configured funny, at least for Fluxbox install.
 
Old 03-15-2004, 08:12 AM   #17
atnan
LQ Newbie
 
Registered: Jan 2004
Location: sydney.au
Distribution: Gentoo
Posts: 23

Rep: Reputation: 15
Did you even read my post? I said to compile from CVS for a reason. B_EuropeanDate and B_AmericanDate can't be used, because no libs have been included that declare those variables. It's a KNOWN problem with that version of the source. If you don't believe me, ask on #fluxbox (which I also recommended).
 
Old 03-15-2004, 08:39 AM   #18
SoliTear
Member
 
Registered: Jan 2004
Location: Ohio
Distribution: Debian Wheezy with updated kernel
Posts: 41

Original Poster
Rep: Reputation: 15
atnan,

Yes. I did. I got some sort of error when I did that. I do appreciate the help. I've just reached a frustration point is all. I need to step back. When I did the commands, (I copied and pasted them) my computer was looking for a .cvspass file in my home directory which wasn't there and honestly i'd have to read a bunch of stuff to figure out what that file does and how to get it created.

i really appreciate your response and i tried it 3-5 times and in different ways and couldn't get it to work. i guess i am almost hopeless.

once again, sorry if i offended, but i tried with my meager skills to accomplish your instructions, but i failed. also, i had to update to autoconf 2.59 because at first it stopped because it needed 2.52 at a minimum.

and yes, i do believe you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Source Code for a simple ftp server and client koodoo Programming 17 07-05-2013 11:48 AM
RPM vs compiling from Source Code ceci2 Linux - Enterprise 4 03-15-2005 03:58 PM
Compiling Kernel and other source code davegermiquet Conectiva 2 01-26-2005 06:01 PM
error in compiling simple code Tinku Programming 6 09-17-2004 01:38 AM
G++ - why am i getting errors compiling this simple code leroy27336 Programming 4 11-18-2003 08:32 PM


All times are GMT -5. The time now is 11:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration