LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-20-2011, 01:18 PM   #1
linuxandtsm
Member
 
Registered: May 2011
Posts: 194

Rep: Reputation: Disabled
Signal out of range when booted to runlevel 5


HI all,

Not able to boot into runlevel 5 and monitor stucks with "input sigal out of range Please change to 1440X600 @ 60Hz" message. I am able to boot into failsafe mode but everything mounted as readonly mode. This is a SuSe linux 10.3 system. Help me to resolve this issue. Thanks!

Last edited by linuxandtsm; 12-20-2011 at 01:20 PM.
 
Old 12-20-2011, 02:17 PM   #2
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

Hi linuxandtsm,

You can boot into run level three and then following are the commands you can try:

1. sax2 (This should launch the utility to change your screen resolution)

After making the changes as per your requirement run the following command:

2. rcxdm restart

And then try to get into run level 5.

Make sure you run the above command as root.
 
Old 12-20-2011, 03:01 PM   #3
linuxandtsm
Member
 
Registered: May 2011
Posts: 194

Original Poster
Rep: Reputation: Disabled
Hi T3RM1NVT0R,

I am able to login to failsafe mode and when i run "sax2" command, it throws bunch of error messages like below
Code:
/usr/sbin/sax.sh: line 482 : /var/log/SaX.log: Read-only file system
SO everything mounted as read only so i am not able to change anything and read-write mount using "mount -o rw,remount /" complains that it is already mounted or busy

when i type init 3 to login to runlevel 3, it gives me below prompt and when enter root as login, throws bunch of messages and says login incorrect.

Code:
(none) login:

Last edited by linuxandtsm; 12-20-2011 at 03:21 PM.
 
Old 12-20-2011, 03:13 PM   #4
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

Alright. Login in failsafe mode and try to mount the file system as read/write using the following command:

mount -o remount,rw /

and then run the commands that I mentioned in my previous post.
 
Old 12-20-2011, 03:19 PM   #5
linuxandtsm
Member
 
Registered: May 2011
Posts: 194

Original Poster
Rep: Reputation: Disabled
Tried
"mount -o remount,rw /" but it complains that / is already mounted or busy
 
Old 12-20-2011, 03:25 PM   #6
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

But after typing this command did you check if it shows that the file system has now been mounted as read/write or not. You can check that using the following command:

Code:
mount
Let me know the output of the above command as well as the following command:

Code:
df -h
 
Old 12-20-2011, 03:46 PM   #7
linuxandtsm
Member
 
Registered: May 2011
Posts: 194

Original Poster
Rep: Reputation: Disabled
"mount" command shows that
Code:
/dev/mapper/system-rootlv on / type jfs (rw)
and "df -h" shows

Code:
/dev/mapper/system-rootlv 140G 24G 117G 17% /
eventhough it says it mounted / as rw, not able modify any file (for example /etc/inittab etc: it says read-only filesystem)

Last edited by linuxandtsm; 12-20-2011 at 03:50 PM.
 
Old 12-20-2011, 03:47 PM   #8
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

/dev/mapper/system-rootlv on / type jfs (rw) shows that the filesystem is mounted as read/write. Did you try running the commands mentioned in my first post.
 
Old 12-20-2011, 03:57 PM   #9
linuxandtsm
Member
 
Registered: May 2011
Posts: 194

Original Poster
Rep: Reputation: Disabled
yes,

tried "sax2" and got same error messages as earlier

/usr/sbin/sax.sh: line 482 : /var/log/SaX.log: Read-only file system
 
Old 12-20-2011, 04:07 PM   #10
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

What happens if you try to boot the system in normal mode instead of failsafe? Does it hang or show you resolution error or does not boot at all? Not sure why failsafe is acting like that because if we can't make any changes then there is no point booting in failsafe.
 
Old 12-20-2011, 04:10 PM   #11
linuxandtsm
Member
 
Registered: May 2011
Posts: 194

Original Poster
Rep: Reputation: Disabled
when i boot into normal mode, the screen goes blank with "input signal out of range....." message and stays there forever
 
Old 12-20-2011, 05:25 PM   #12
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

The only fix that I can think for this issue now is to repair the system using your SuSE 10.03 DVD. Make sure you do not touch existing partitions.
 
Old 12-21-2011, 10:16 AM   #13
linuxandtsm
Member
 
Registered: May 2011
Posts: 194

Original Poster
Rep: Reputation: Disabled
Hi T3RM1NVT0R,

Could you please tell me how (and what) to repair with DVD ?
thanks in advance!
 
Old 12-21-2011, 01:08 PM   #14
T3RM1NVT0R
Senior Member
 
Registered: Dec 2010
Location: Internet
Distribution: Linux Mint, SLES, CentOS, Red Hat
Posts: 2,385

Rep: Reputation: 476Reputation: 476Reputation: 476Reputation: 476Reputation: 476
@ Reply

Here is the pdf that will help you: http://www.google.co.in/url?sa=t&rct...Thtofgr_fZnkOw
 
Old 01-19-2012, 10:26 AM   #15
Cloud9
LQ Newbie
 
Registered: Jan 2012
Posts: 13

Rep: Reputation: Disabled
Did you try using ctrl, alt and f1/2/3?! That should bring you to the CLI
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
signal frequency out of range please change signal timing ifranklin Linux - Hardware 6 11-05-2010 03:18 AM
Can the font color be changed when booted in runlevel 3 lali.p Slackware 5 05-14-2007 02:29 PM
Signal frequency out of range / please change signal timing starrynite Linux - Hardware 1 01-06-2007 12:18 PM
Changing ipv4's ports range in runlevel tuanito Linux - Networking 2 08-07-2006 08:45 AM
got a new monitor now 'signal out of range' mrtokyo Linux - Software 5 06-30-2004 02:42 PM


All times are GMT -5. The time now is 10:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration