LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Shutdown not shutting down completely (http://www.linuxquestions.org/questions/linux-newbie-8/shutdown-not-shutting-down-completely-65850/)

jrdioko 06-15-2003 11:00 PM

Shutdown not shutting down completely
 
A very strange thing has been happening since I started reinstalling everything. I first noticed it when I was running programs like Partition Magic and booting from a DOS boot disk. Usually, you only have to quickly press and release the power button to turn off the computer. This time, however, when I did this, the hard drives spooled down, as far as I could tell everything shut down and stopped making noise, but the CPU fan kept on running, and I needed to hold down the power button for 4 seconds or however long it is to turn off the CPU fan. Now, when I go into Linux, "shutdown -h now" does the same thing. I tried going into Windows and shutting down that way, and everything turned off as normal. What could be happening here?

Thanks,
JMagi

awdoyle 06-15-2003 11:25 PM

I think you need to go into your BIOS and reset the way your computer powers down.

jrdioko 06-15-2003 11:41 PM

Where would this be in BIOS. I looked around and disabled anything that had anything to do with powering down or power saving or suspending and it still didn't work.

I just got off the phone with our Tech. coordinator from school and he told me that it is normal for some motherboards when quickly pressing and releasing the power button in BIOS or before booting up all the way to put the computer into suspend mode (i.e. hard drives seem to power down, CD drives still remain active [i just checked and mine do], but CPU fan stays on). He said that since it is working fine in Windows and (as far as we can tell) functioning normally in BIOS, there is some setting that I need to change in Linux that will tell the computer to Shut Down all the way rather than just Suspend. Any ideas as to what this might be?

Two things I forgot to mention in my first post:
1. I have tried shutting down with "shutdown -h now," "init 0," and "halt". None work.
2. When I type either of the above, the normal messages appear, then "Shut down." appears as the last line and everything stays on the screen while everything seems to power down. Then I am left with a running CPU fan and messages still on the screen.

Any ideas?
JMagi

awdoyle 06-16-2003 12:49 AM

Quote:

Where would this be in BIOS. I looked around and disabled anything that had anything to do with powering down or power saving or suspending and it still didn't work. --JMagi
In my AwardBIOS, I go to Power > PWR Button. Here's the description in all its glorious grammar:
Quote:

When push power button less 4 seconds, system can enter 'soft off' or 'suspend' mode by selecting this field. Push power button more than 4 seconds always soft off.

jrdioko 06-16-2003 01:28 PM

I have AMIBIOS Version 1.21.12. Here are all my options (none says "Power"):

Standard CMOS Setup
Advanced Setup
Power Management Setup
PCI/Plug and Play Setup
Load Optimal Settings
Load best Performance Settings
Features Setup
CPU PnP Setup
Hardware Monitor
Change Password
Exit

I've gone through and looked for anything like what you posted and I can't find it. Can't we assume that since Windows shuts down properly, there is some setting in Linux that can tell it to shut down rather than suspend? Or is there still some hidden setting in BIOS?

Thanks again,
JMagi

awdoyle 06-16-2003 01:46 PM

Might help to make sure this line appears in your /etc/rc.d/rc.modules:
modprobe apm

jrdioko 06-16-2003 02:13 PM

I've looked around some more and found the following at another site:

Shutdown/Standby/Hibernate Problems

Several people have contact me about problems with halting the system. When halting the system, the computer does not shut off automatically. For this problem, there is a work-around and a real solution. The work-around is to hold down the power button for about 4 seconds, then the computer shuts off. Several people e-mailed me with the real solution. I would like to thank Troy Schultz, Jim Duke, Grégoire Pailler, Markus Hoffelner, and Gunnar Wagenknecht for sending information about the solution. The real solution involves ACPI. Since this computer is designed for Windows XP, the BIOS does not support APM, only ACPI. All power management is by the operating system, which is why we need to ACPI. First, you will need to download (URL: http://sourceforge.net/projects/acpi/) a kernel patch for ACPI, apply the patch, and recompile the kernel. You will need to use kernel 2.4.17, 2.4.18, or later. ACPI will also help you with standby/hibernate issues.

I looked in my BIOS and the line in /etc/rc.d/rc.modules is commented out:
#/sbin/modprob apm

In my BIOS Power Management Setup Menu, there is an option called "ACPI Aware O/S" which is set to "Yes." I tried setting it to "No" and back to "Yes," and nothing changed.

I am starting to understand why it is doing this, but I am not sure which fix I need to use. Do I download that ACPI patch? (If so, which do I download and what steps do I need to follow to install it?) Or do I uncomment that line in my rc.modules file? (If so, what do I need to do after uncommenting it?) Either way, do I keep the BIOS setting at "Yes" or change it to "No"?

I appreciate all your help,
JMagi

jrdioko 06-16-2003 02:21 PM

One more thought...

When I was going through and reinstalling Slackware, I read in a README file somewhere that the Slack 9.0 ISO no longer includes an updated Kernel because there was no more room on the CD. I assumed from the start that I would need to recompile my Kernel when I got Slack up and running, since the installed Kernel was bare.i. However, after I installed it, everything seemed to work so I decided not to recompile since there was no need. Would I save myself some effort now (and later) if I recompile now to 2.4.19 (I believe this is the number of the one I downloaded and have now on CD).

-JMagi

bongski55 06-17-2003 11:39 PM

You don't need to recompile the kernel-it is already compiled with 2.4.20. which is the latest stable kernel. To recompile with 2.4.19 is not realy a good idea. You also misread the README in that it is the kernel SOURCE that is not included. But like me you can download the kernel source from the k directory in the ftp site and installpkg the kernel source.(download kernel-source-2.4.20-noarch.tgz).

jrdioko 06-18-2003 02:43 PM

Thanks for clearing that up. Now everything makes a little more sense :). (By the way, it was 2.4.20 that I had, not 2.4.19.) I have a few more questions about the kernel:

1. If I want to patch from 2.4.20 to 2.4.21, do I need the kernel source?

2. If I do download that K package, will 'make menuconfig' contain the current configuration setup that came with Slackware (e.g. support for vfat/msdos and ppp)?

3. If I download the source, patch it, and then later want to change something in the configuration, can I just go into the /usr/src/linux directory and make menuconfig, make dep, make modules, make modules_install, make bzImage as usual without messing up the patch?

Anyway, back to my original question, does anyone know how I would go about setting up ACPI using that patch?

Thanks,
JMagi

lectraplayer 06-18-2003 07:54 PM

What does it do when you hit "poweroff"? On my laptop it goes to Power Down, then I have to pull out the battery. This is a Pentium 90, Linux may not support it right or something. :)

bongski55 06-19-2003 01:57 AM

See my post/question:
http://www.linuxquestions.org/questi...threadid=66172

It worked for me,hope it does for you!

jrdioko 06-19-2003 07:43 PM

I will try uncommenting that line. However, my BIOS only has the option "ACPI O/S?" and doesn't mention anything about APM, I'm not sure if its APM compatible. I will give it a try and let you know what happens.

-JMagi

renjith 08-09-2003 09:20 AM

APM : RH9 shutdowns but without unmounting
 
I compiled both apm and acpi as modules into the kernel. When I press the power off button on my pc, RedHat shuts down, but fast. And when I reboot, it runs fsck, saying that linux was improperly unmounted and has to be error-checked. Can anyone pls help ?

bongski55 08-10-2003 05:46 AM

Re: APM : RH9 shutdowns but without unmounting
 
Quote:

Originally posted by renjith
I compiled both apm and acpi as modules into the kernel. When I press the power off button on my pc, RedHat shuts down, but fast. And when I reboot, it runs fsck, saying that linux was improperly unmounted and has to be error-checked. Can anyone pls help ?
The use of the power off button of the pc is not a good idea. This is specially true for an installation into a ext2 or ext3 partition. You might be safer if you use reiser which is more immune to power failure but still it would be better to do a proper shutdown- 'halt' or 'shutdown' are the cli versions or from the gui.


All times are GMT -5. The time now is 11:07 AM.