LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-11-2012, 09:05 AM   #1
harryg123
LQ Newbie
 
Registered: Apr 2012
Posts: 3

Rep: Reputation: Disabled
Show .hidden .files on Open... and Browse... dialogs in xubuntu/xfce


I am running xubuntu 11.10, fully updated, on an Acer 250 netbook (1GB ram, 1.8 GHz clock, single core Atom processor, if you can believe it). Runs pretty well, I think. So much so that I have decided to migrate from Windows to Linux.

My first question to the forum is this: I have set the Thunar file explorer to show hidden files. However, hidden files still don't show up on various File Open or Browse... dialogs.

How can I set up xfce or xubuntu to always display .hiddenfiles in Open... or Browse... dialogs?

Problem comes up when I want to edit some .config file or run the alacarte Main Menu editor and have to specify some long path to an executable in a hidden directory (as in wine). I have to enter the file name manually, which gets to be a problem for my thumb-fingered typing.

Last edited by harryg123; 04-11-2012 at 09:07 AM.
 
Old 04-11-2012, 09:55 AM   #2
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,090

Rep: Reputation: 483Reputation: 483Reputation: 483Reputation: 483Reputation: 483
Been wondering the same thing myself. Found this doc on my system
Quote:
/usr/doc/xfce-4.6.2/Thunar-1.0.2/README.thunarrc
There is a parameter you can set in ~/config/Thunar/thunarrc called
Quote:
LastShowHidden (FALSE/TRUE)

Determines whether hidden files should be shown by default in newly
opened Thunar windows.
I set it to TRUE, and starting thunar does show hidded files and directories.

Hope this helps.
 
1 members found this post helpful.
Old 04-11-2012, 11:07 PM   #3
harryg123
LQ Newbie
 
Registered: Apr 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
hidden files/directories in Browse... and Open... dialogs

Thank you, Cliff. However, that value gets set to TRUE/FALSE when one clicks View > Show hidden files or types ^H.

I figured out the answer to my original question: one has to click the pencil icon on the left of the tree, then type "." to see the list of hidden items.

This is what frustrates me most about Linux, all flavours: it's written by a bunch of people, who, as children, loved playing computer games such as rogue, where one has to try this and try that and "figure it out." They get a lot of pleasure out of figuring out how things work. However, old Windows fuddy-duddies like me are more interested in getting the job done, whatever it is. For this I click Help or F1, then read the manual. But there are few manuals in Linux, because the kids (now mostly grown-up, but still playful) love to tweak things--and doen't see any problem with stopping to figure things out. (In fact when you complain in a forum, they call you names like newfag.)

Ah well.

Last edited by harryg123; 04-11-2012 at 11:15 PM. Reason: expand my answser and clean up typos
 
Old 04-12-2012, 09:26 AM   #4
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,090

Rep: Reputation: 483Reputation: 483Reputation: 483Reputation: 483Reputation: 483
I understand your frustration. My view is a little different. I feel Xfce is a little less mature than some other desktops. The documentation leaves a lot to be desired. However, it is like most other software that is free. You get it as is, with no guarantee implied.

I worked in the industry for over 30 years, I've seen linux grow over the years. Most things have improved over time. I believe I get a lot more than I paid for, however there is room for improvement as you have pointed out.

Best of luck.
 
Old 04-13-2012, 05:22 PM   #5
toothandnail
Member
 
Registered: Apr 2007
Location: Oxfordshire, UK
Distribution: Arch, Sparky, Salix64
Posts: 85

Rep: Reputation: 7
Quote:
Originally Posted by harryg123 View Post
Thank you, Cliff. However, that value gets set to TRUE/FALSE when one clicks View > Show hidden files or types ^H.

I figured out the answer to my original question: one has to click the pencil icon on the left of the tree, then type "." to see the list of hidden items.
You do like doing things the hard way....

Quote:
This is what frustrates me most about Linux, all flavours: it's written by a bunch of people, who, as children, loved playing computer games such as rogue, where one has to try this and try that and "figure it out." They get a lot of pleasure out of figuring out how things work. However, old Windows fuddy-duddies like me are more interested in getting the job done, whatever it is. For this I click Help or F1, then read the manual. But there are few manuals in Linux, because the kids (now mostly grown-up, but still playful) love to tweak things--and doen't see any problem with stopping to figure things out. (In fact when you complain in a forum, they call you names like newfag.)

Ah well.
Hmm. In Windows (don't use it much, haven't for years, so details may be off), to make explorer show paths, and (gasp) file extentions, you have to go to properties and go through a fairly extensive dialog box. I can't remember whether its even possible to make it show hidden files? In Thunar, showing hidden files is as simple as pressing CTRL-H. Its a toggle, so pressing it again will go back to not showing hidden files. Seems pretty simple to me.

Paul.
 
Old 04-12-2015, 03:58 PM   #6
villandra
LQ Newbie
 
Registered: Mar 2013
Posts: 4

Rep: Reputation: Disabled
Ctrl-H works if you do it several times. I guess it has to toggle through all the possibilities of what that might mean, some of which one would never have thought to want.

View Show hidden files doesn't show hidden folders.

The instructions above don't say whether to leave the word TRUE in brackets, so kind of useless. It also isn't clear whether it will set the value to TRUE or to the last value you viewed files in that folder with. "LastShowHidden" does not logically mean the same thing at all as "ShowHidden". All of this needed to be clarified.

So, the answer to the question that was asked is not here, and the only answer that was provided is as clear as mud. But I guess the only ratings you want on helpfulness are to click yes if you found the answer helpful? Put in an actual rating system, and you'll not find critiques of how helpful the posts were in the discussion. That is just plain aggravating, and inspires me to tell you how helpful I really found the posts.

Last edited by villandra; 04-12-2015 at 04:04 PM.
 
Old 04-12-2015, 05:16 PM   #7
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,090

Rep: Reputation: 483Reputation: 483Reputation: 483Reputation: 483Reputation: 483
This is the information directly from the documentation.

Quote:
* LastShowHidden (FALSE/TRUE)
100
101 Determines whether hidden files should be shown by default in newly
102 opened Thunar windows.
If you look at the configuration file, it will say LastShowHidden = True or LastShowHidden = False. Set it the way you want it. This parameter affects only new opened windows.

If you always want hidden files shown, there is a check box under the view drop down, check it.

Not sure why you are posting on a 3 year old thread, if you have an issue, it is better to open a new thread, provide information for your problem, and then we can help. You need to include info such as the exact version of the application, what you have done to resolve the problem before we can give you good advice. Comments like
Quote:
the only answer that was provided is as clear as mud.
don't help one bit. We can't read your mind, only the words you post.
 
Old 04-13-2015, 02:28 PM   #8
DJ Shaji
Member
 
Registered: Dec 2004
Distribution: Fedora 22 (Twenty Two!), ArchLinux
Posts: 506
Blog Entries: 15

Rep: Reputation: 106Reputation: 106
I use Fedora 21, and Ctrl+H works for me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Show Hidden Files mnardone Programming 5 09-20-2009 01:37 AM
show hidden files in shell lion_heart_300 Slackware 4 06-29-2006 08:28 AM
ls -->don show hidden files alaios Linux - General 2 07-25-2005 03:19 PM
show hidden files on Redhat 9.0 dflorence Linux - Newbie 3 11-05-2003 12:11 PM


All times are GMT -5. The time now is 04:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration