LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-06-2008, 12:55 PM   #1
mccartjd
Member
 
Registered: Apr 2008
Posts: 108

Rep: Reputation: 15
Smile Should I use TMOUT for inactive sesssions


I would like for users to be logged out of the RHEL 4 WS if they walk away for more than 10 minutes. If I use the TMOUT utility is this a good idea, has anyone used the TMOUT utility in LINUX? My passwords don't work with screensaver so I'm forced to find someway to secure my terminals.

Is the TMOUT function profile dependent?

I was told if I edit the /etc/profile" and add the following line somewhere after the line that read
"HISTFILESIZE="
TMOUT=3600
The value we enter for the variable "TMOUT=" is in second and represent 1 hours (60 * 60 =
3600 seconds). If you put this line in your "/etc/profile" file, then the automatic logout after one hour of inactivity will apply for all users on the system. You can set this variable in user's individual ".bashrc " file to automatically logout them after a certain time.
After this parameter has been set on your system, you must logout and login again (as root) for the change to take effect.

Thanks
John
 
Old 05-06-2008, 01:48 PM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 18,318

Rep: Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880
It does work for me, but I'd put it in each users profile, not the system-wide profile. If you have to log in as anybody, say from the console, and run a LONG job (file restore or something similar), it'll time out and kill your session in mid-job. Not a good thing.

This way you can have users that have the timeout set, along with users that don't.

This works for me on terminal/bash sessions. Or are you asking about a way to kill an X session after a certain amount of time? KDE's screensavers will auto-lock after a given amount of time...what screensaver are you using?
 
Old 05-06-2008, 01:59 PM   #3
mccartjd
Member
 
Registered: Apr 2008
Posts: 108

Original Poster
Rep: Reputation: 15
Screen Saver Password not Functioning

All screen savers do not accept passwords. I'm using the correct password, if I select Cntrl, Alt and F1 and type the username and password it works. The manpage on .xscreensaver talks about the PAM and how it could be an issue.

Earlier today I posted comments about it.
 
Old 05-06-2008, 03:58 PM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 18,318

Rep: Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880Reputation: 3880
Quote:
Originally Posted by mccartjd View Post
All screen savers do not accept passwords. I'm using the correct password, if I select Cntrl, Alt and F1 and type the username and password it works. The manpage on .xscreensaver talks about the PAM and how it could be an issue.

Earlier today I posted comments about it.
I didn't say all screensavers did...but the ones in KDE do. Xscreensaver has its own quirks, and I never had good luck with it locking a session. I wound up having to go to the KDE/Gnome built-ins, to make locking work the way it should.

I'm sure there's a way around it, but it was more trouble than it was worth, since I had a 'ready made' solution with the KDE/Gnome built-ins, so I just disabled Xscreensaver.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
IntelliMouse 1.1A PS/2 is Inactive srfpala Fedora 0 12-06-2006 08:53 PM
How to log terminal sesssions in gnome? greennick Linux - Software 1 11-04-2005 12:52 PM
inactive servers LLS Linux - General 2 02-27-2005 06:48 PM
eth0 is inactive nethunter Linux - Hardware 2 02-09-2005 10:40 AM
Crontab inactive? sirenz10 Linux - General 1 10-02-2001 03:32 PM


All times are GMT -5. The time now is 12:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration