LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-07-2013, 01:34 PM   #1
nicnicman
LQ Newbie
 
Registered: Feb 2013
Posts: 8

Rep: Reputation: Disabled
Shell prompt changed to >


Hello everyone,

Accidentally, I typed ls -l " at the prompt and suddenly the prompt changed to >.

I'm using a stripped back version of Ubuntu that only includes a command prompt on an Oracle VirtualBox. Unfortunately, I can't get the specific version since the prompt isn't working properly. Of course, I could restart and it would go back to normal, but I would rather do it without restarting.

Thanks.
 
Old 02-07-2013, 01:40 PM   #2
ntubski
Senior Member
 
Registered: Nov 2005
Distribution: Arch
Posts: 3,013

Rep: Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225
You can enter the closing ", or just hit Ctrl+C.
 
1 members found this post helpful.
Old 02-07-2013, 01:41 PM   #3
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
You have opened a quote with typing " and the shell is waiting for you to close it, so just type " again and press Enter.
Alternatively just press Ctrl+c to abort the command.
 
2 members found this post helpful.
Old 02-07-2013, 01:44 PM   #4
shivaa
Senior Member
 
Registered: Jul 2012
Location: Grenoble, Fr.
Distribution: Sun Solaris, RHEL, Ubuntu, Debian 6.0
Posts: 1,800
Blog Entries: 4

Rep: Reputation: 286Reputation: 286Reputation: 286
Or you can use exit and login again. It will solve the pb.
 
Old 02-07-2013, 01:58 PM   #5
nicnicman
LQ Newbie
 
Registered: Feb 2013
Posts: 8

Original Poster
Rep: Reputation: Disabled
Thanks everyone!
 
Old 02-07-2013, 02:09 PM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,130
Blog Entries: 2

Rep: Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825Reputation: 4825
Quote:
Originally Posted by shivaa View Post
Or you can use exit and login again. It will solve the pb.
This will not work. The exit command will not be executed as long as the quote is not closed (if it is executed at all, in case of the OP it would not be executed even with a closed quote).
 
1 members found this post helpful.
Old 02-07-2013, 02:19 PM   #7
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,258

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
As described above, this happens when the shell is waiting for you to finish your command. You'll run into this if you try to execute a command with a lonely quote (single or double), a trailing backslash, or any number of other "incomplete" commands. All you have to do to fix it is close out whatever operation you were running (close the quote, or give the trailing backslash something to delimit, like a space), or just press Ctrl+C to cancel.
 
1 members found this post helpful.
Old 02-07-2013, 03:26 PM   #8
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Nobody mentioned that it is called secondary prompt and its value is stored in the PS2 environment variable and you can customize it at your pleasure.
 
1 members found this post helpful.
Old 02-07-2013, 05:04 PM   #9
nicnicman
LQ Newbie
 
Registered: Feb 2013
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TobiSGD View Post
This will not work. The exit command will not be executed as long as the quote is not closed (if it is executed at all, in case of the OP it would not be executed even with a closed quote).
Yeah, this was the first thing I tried...didn't work.
 
Old 02-07-2013, 05:12 PM   #10
nicnicman
LQ Newbie
 
Registered: Feb 2013
Posts: 8

Original Poster
Rep: Reputation: Disabled
Thanks for the additional information, suicidaleggroll and colucix.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
debian shell prompt does not reflect changed hostname Luminaro Linux - Newbie 5 10-28-2012 05:25 AM
passing parameters from a unix shell prompt into a windows cmd.exe prompt nano2 Programming 1 09-01-2009 12:26 PM
Command line prompt has changed une Linux - Newbie 3 09-19-2006 11:51 PM
Root Prompt Changed baabakb Linux - Newbie 6 09-09-2006 04:55 AM
Hostname was changed on the command prompt pretty.tulip Linux - Newbie 1 04-03-2006 12:21 AM


All times are GMT -5. The time now is 12:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration