LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-25-2005, 01:44 PM   #1
CaptainRegular
Member
 
Registered: Aug 2004
Location: Virginia Tech
Distribution: Xandros 3.01
Posts: 30

Rep: Reputation: 15
Shared printer being a bandwidth hog?


Ok, I'm using Xandros 3.01 (Debian-based, so there should be SOME situations similar to mine) as a server. It's running on a rather modest Pentium 3 with 128 megs of RDRAM. And a 100 gig hard drive.

As a file server, it's BEAUTIFUL. Marvelously fast and insanely easy to set up. As an OS, it's also pretty quick to surf the net or use the GUI, even on the old P3 hardware.

However, as a PRINT server, while supremely simple to set up and it WORKS, it has some quirks that have recently become more of an issue.

1. On every Windows computer it's shared to, it can't print multiple copies. If you hit "Print" and change the quantity to ANY number over one, it will still only print ONE. You have to hit "print" as many times as as many copies you want. Even if you hit print before a first of 10 copies finishes, as long as you hit it 10 times, it will print 10. It does this on at least 2 Windows XP machines.

2. It SEEMS to be taking MUCH more bandwidth than the other 2 Linux distros I've used and been able to get to print from Windows (Mandrake 10 and Fedora Core 1). This is fine for my Windows machine, which is hard-wired into the network. But my fiancees laptop, which is 802.11B wireless (which printed just FINE under MDK10 and FC1) now takes significantly longer to print, and changing options (color/B&W or page layout or margins) in the setup of the printer is painfully slow, almost to the point of locking her machine up. This happened both before and after a format of her laptop, so I'm pretty sure it's the server. And whenever she has ANY printer interaction, her little wireless bandwidth usage indicator just flies off the handle.

Also, I've noticed this: On both Windows machines, when I actually open the printer from the menu, either by browsing the network or from "Printers and Faxes" it reads "Access denied, unable to connect." I feel this may be an indicator of my problem, but don't have any more details. Despite this message, both machines ARE able to print, they just have those quirks.

Oh, the printer is an HP DeskJet 812C on a parallel connection.
 
Old 06-26-2005, 12:41 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,536

Rep: Reputation: 148Reputation: 148
How does printing work from the machine itself?
 
Old 06-26-2005, 12:52 PM   #3
CaptainRegular
Member
 
Registered: Aug 2004
Location: Virginia Tech
Distribution: Xandros 3.01
Posts: 30

Original Poster
Rep: Reputation: 15
Printing directly from the linux machine is a quick and painless affair, and it does multiple copies just fine.

I also did change the smb.conf file to have the line "use client driver = yes" although all this succeeded in doing what getting rid of the "Access denied, unable to connect" message. The symptoms (no multiple copies, appears to use a TON of bandwidth over the network, making it a pain to use from a wireless machine) are all still quite present.
 
Old 07-08-2005, 05:30 PM   #4
CaptainRegular
Member
 
Registered: Aug 2004
Location: Virginia Tech
Distribution: Xandros 3.01
Posts: 30

Original Poster
Rep: Reputation: 15
I've also confirmed that more than one WIRELESS computer also has a speed issue, this one's running Windows 2000 Pro. Normal network access, including music from the shared drive hosted on that very linux box, is perfect. So I've pretty much confirmed that the problem is with the linux server itself, and that I'm not crazy.
 
Old 07-08-2005, 05:38 PM   #5
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,536

Rep: Reputation: 148Reputation: 148
Have you browsed Samba logs? It's usually /var/log/samba. There may be error messages etc.
 
Old 07-09-2005, 01:35 PM   #6
CaptainRegular
Member
 
Registered: Aug 2004
Location: Virginia Tech
Distribution: Xandros 3.01
Posts: 30

Original Poster
Rep: Reputation: 15
Ok, I just told it to print 2 documents and only got one, and there IS an error present in the corresponding log file. It's named log.aluminum (aluminum is the name of my wired machine). I saw the same error in the log from my girlfriends laptop, but didn't know when she printed and couldn't match it up to those events. Now I think I can. The text surrounding the error is as follows:

[2005/07/09 03:07:46, 0] lib/util_sock.c:read_socket_data(384)
read_socket_data: recv failure for 4. Error = No route to host
[2005/07/09 03:07:46, 1] smbd/service.c:close_cnum(836)
aluminum (192.168.1.11) closed connection to service tunes$
[2005/07/09 03:07:46, 1] smbd/service.c:close_cnum(836)
aluminum (192.168.1.11) closed connection to service public


That's everything from the time I first accessed any resource on the linux machine today to the end of the log. "tunes$" is a hidden share that I have mapped as a network drive, and it's also shared under another name, but only tunes$ is writeable. It's hidden so that I can rename and delete and organize music, but any public access can only listen to it. "public" is a typical anybody can view it, anybody can read AND write to it share.
 
Old 07-17-2005, 07:18 PM   #7
CaptainRegular
Member
 
Registered: Aug 2004
Location: Virginia Tech
Distribution: Xandros 3.01
Posts: 30

Original Poster
Rep: Reputation: 15
Edit and bump. I've been looking up that error message from the previous post, and have found nothing in English except others that have had the same or similar problems and no resolutions. Indeed, the third result I did get was this very thread! I'm wondering if perhaps I should simply do a format and reinstallation of another distro on my linux box. I've been thinking about trying "pure" Debian or the more popular Ubuntu. But if this thread belongs in another forum, can I relocate it myself, or does a mod have to do that? I'm beginning to feel that this problem isn't a "newbie"-level problem at all.
 
Old 07-19-2005, 04:30 PM   #8
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,536

Rep: Reputation: 148Reputation: 148
That's an error that took me some time to fix on my own config. In /etc/smb.conf try to add something like
interfaces = eth0
Replace eth0 with corrent interface in your config.
 
Old 07-20-2005, 06:19 PM   #9
CaptainRegular
Member
 
Registered: Aug 2004
Location: Virginia Tech
Distribution: Xandros 3.01
Posts: 30

Original Poster
Rep: Reputation: 15
Unfortunately, that last suggestion, while very much appreciated, didn't do anything to change the issue. I think I'm going to give Ubuntu a shot. At least I'm getting to try different distros! Thank you for your help.
 
Old 07-22-2005, 05:29 PM   #10
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,536

Rep: Reputation: 148Reputation: 148
First try deleting two files from /var/cache/samba/printing: lp.tdb and printers.tdb. They get messed sometimes and it causes problems. When you delete them, restart samba.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help printer from a samba shared printer from linux (using cups) epod69 Linux - Networking 3 12-04-2005 10:44 PM
CUPS and Shared Printer cthomas Linux - Networking 1 09-17-2005 05:22 PM
howto see xp shared printer Mr_C Linux - Networking 9 04-30-2005 09:08 PM
Shared printer problem AmdMhz Linux - Networking 17 10-13-2004 12:40 PM
Has anybody shared a PRINTER to Mac OS X webvandals Linux - Hardware 7 05-03-2004 08:35 PM


All times are GMT -5. The time now is 06:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration