LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-31-2007, 06:19 PM   #1
linux_craptops
LQ Newbie
 
Registered: Jul 2006
Location: brooklyn, nyc
Distribution: ubuntu 6.06, debian sarge
Posts: 6

Rep: Reputation: 0
Shared FAT32 partition


HI,

I am running debian etch 2.6.18-5 on a thinkbook and I have it set to dualboot between debian and windows xp. To make things easier I added a 12 gig fat32 partition that is accessible to both OSs. For some reason when i am in debian I can only write files to this partition as root. How come I cant write to it using my regular user account? I have tried to chown -R all of the folders to the user but still it doesnt let me write new files.

Thanks!
- j
 
Old 08-31-2007, 06:43 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Windows' file-systems have no means to store Linux permissions
or ownerships .... read man mount and man fstab, namely the parts
about uid and umask.


Cheers,
Tink
 
Old 08-31-2007, 07:45 PM   #3
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
You need to mount with at least these options: defaults,umask=0000,uid=(user uid),gid=(user gid)
 
Old 09-02-2007, 06:50 AM   #4
dark_angel
Member
 
Registered: Oct 2006
Location: Bacolod, Philippines
Distribution: Slackware 12
Posts: 62

Rep: Reputation: 15
change "defaults" to "auto,users,umask=000,rw" in fstab.
 
Old 09-02-2007, 08:29 AM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Off-topic, but i solved this by putting all data on ext3 partitions, and then using the ext2fsd driver for Windows to allow me to read/write to those partitions. I almost never boot into Windows anymore, but--when I do--it works great.
 
Old 09-03-2007, 12:18 AM   #6
linux_craptops
LQ Newbie
 
Registered: Jul 2006
Location: brooklyn, nyc
Distribution: ubuntu 6.06, debian sarge
Posts: 6

Original Poster
Rep: Reputation: 0
thanks for the all the suggestions. trying ' auto,users,umask=000,rw ' ... next up: getting those darn nvidia drivers to work...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with shared FAT32 partition Heithgaldr Linux - General 4 02-26-2007 09:31 PM
DISCUSSION: Creating shared FAT32 Partition mcd LinuxAnswers Discussion 23 01-07-2007 06:39 AM
vfat or fat32 for shared partition? daTerminehtor Linux - Newbie 11 01-12-2006 07:13 PM
problem with FAT32 shared partition dping Linux - Newbie 5 01-12-2006 02:33 PM
Error creating shared FAT32 partition robalo Linux - Newbie 1 07-13-2004 07:42 PM


All times are GMT -5. The time now is 02:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration