LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-10-2012, 12:31 AM   #1
skp
LQ Newbie
 
Registered: Aug 2012
Posts: 10

Rep: Reputation: Disabled
sftp


I tried to put a directory tree to the remote server but it is not getting transfered to the remote server. says ' the dir is not a regualr file' I guess it is not possible to transfer a directory using sftp. Can anyone please inform me the best way to put a directory tree through sftp or any method. As the ssh is blocked for user i am trying go through ftp
 
Old 11-10-2012, 04:23 AM   #2
Turbocapitalist
Senior Member
 
Registered: Apr 2005
Distribution: Ubuntu, Devuan, OpenBSD
Posts: 2,087
Blog Entries: 3

Rep: Reputation: 926Reputation: 926Reputation: 926Reputation: 926Reputation: 926Reputation: 926Reputation: 926Reputation: 926
put -r

You could try 'put -r' instead of plain 'put'. It does not work in all cases, but might work for yours. Sometimes you will have to create the target directory first before trying the transfer.

Last edited by Turbocapitalist; 11-10-2012 at 04:31 AM.
 
Old 11-10-2012, 09:18 AM   #3
skp
LQ Newbie
 
Registered: Aug 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
Thanks for your reply but put -r doesnt work. I tried. Is there any way of putting the directory tree in any FTP client?
I tried using ncftp but couldn't work more on that...Please let me know if you have any other best solution
 
Old 11-10-2012, 09:27 AM   #4
Turbocapitalist
Senior Member
 
Registered: Apr 2005
Distribution: Ubuntu, Devuan, OpenBSD
Posts: 2,087
Blog Entries: 3

Rep: Reputation: 926Reputation: 926Reputation: 926Reputation: 926Reputation: 926Reputation: 926Reputation: 926Reputation: 926
put -r won't work by itself. The top directory being copied must already exist on the target machine. You can do that in sftp or out of it with mkdir.
 
Old 11-26-2012, 10:22 PM   #5
skp
LQ Newbie
 
Registered: Aug 2012
Posts: 10

Original Poster
Rep: Reputation: Disabled
Thanks for your reply. It worked when i use lftp along with sftp. Now i can copy multiple directory trees using sftp.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SFTP logging for Chroot on CentOS 6.2 with openssh-5.3 not working (internal-sftp) RatherBFishin Linux - Server 1 08-30-2012 06:45 PM
LXer: Restricting Users To SFTP Plus Setting Up Chrooted SSH/SFTP (Debian Squeeze) LXer Syndicated Linux News 0 09-06-2011 07:10 AM
How do I use sftp to upload my web site? (no sftp tar command) johnMG Linux - Networking 6 06-21-2005 09:14 PM
Files truncated by sftp/sftp-server at 65kb gato Linux - Networking 1 12-18-2003 10:29 AM


All times are GMT -5. The time now is 08:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration