LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-15-2009, 10:11 PM   #1
Silver565
Member
 
Registered: Jul 2007
Distribution: Ubuntu, Windows, Freenas
Posts: 96

Rep: Reputation: 15
Setup static ip-address in kubuntu?


I know how to do this in ubuntu, but i can't seem to find the settings/manager to change an ipaddress per connection under kubuntu.

I would like it so that eth1 is configured via dhcp, and eth0 has a static ipaddress of 192.168.0.1

Where is the network manager like the one in ubuntu?

Any help would be appreciated

Cheers
 
Old 08-15-2009, 10:26 PM   #2
micxz
Senior Member
 
Registered: Oct 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
On my system in /etc/sysconfig/network/ifcfg-eth0 is the network setting for device eth0. I know redhat/centOS uses a similar setup but with the network folder called "network-scripts". I don't run kubuntu but it must be similar. Maybe /etc/network/interface

Last edited by micxz; 08-15-2009 at 10:28 PM.
 
Old 08-16-2009, 12:23 AM   #3
Silver565
Member
 
Registered: Jul 2007
Distribution: Ubuntu, Windows, Freenas
Posts: 96

Original Poster
Rep: Reputation: 15
Hmmm thats the problem..

I've set it up like

auto eth0
iface eth0 inet static
address 192.168.0.1
netmask 255.255.255.0
broadcast 192.168.0.254
gateway 192.168.0.10
and it says "failed to initialize eth0" (or something like that)
 
Old 08-16-2009, 12:59 AM   #4
micxz
Senior Member
 
Registered: Oct 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
I would try:

address 192.168.0.2

It looks like your gateway is the same IP as your interface'
 
Old 08-16-2009, 01:08 AM   #5
micxz
Senior Member
 
Registered: Oct 2002
Location: CA
Distribution: openSuSE, Cent OS, Slackware
Posts: 1,131

Rep: Reputation: 75
Quote:
Originally Posted by Silver565 View Post
it says "failed to initialize eth0" (or something like that)
Sorry I missed this info. Please post what is says and what the log saying. "something like that" usually does not cut when trying to debug error messages.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
setting a static IP in Kubuntu 8.10.... Basslord1124 Ubuntu 16 10-28-2009 01:34 PM
Set IP address to static from DHCP assigned address jborn Linux - Networking 4 02-02-2007 09:38 PM
[SOLVED] Converting static IP-address to dynamic IP-address Blue_Ice Linux - Networking 3 07-20-2006 04:35 AM
setup the static ip address hansi umayangan SUSE / openSUSE 1 04-04-2005 03:54 AM
Verizon aDSL setup with static IP address RH9 server costasm Linux - Networking 1 10-16-2003 03:19 PM


All times are GMT -5. The time now is 04:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration