LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-16-2009, 12:19 AM   #1
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,461
Blog Entries: 6

Rep: Reputation: 51
Setup a samba ?


I have just installed a new Fedora 6 on my system.I just want to share a folder with my remote Windows Machine.
I tried :
Code:
mount -t cifs //IN-012/isd/ /mnt/window123/ -o username=peterk/ultratest%<password>,uid=peterk

It is reporting :
Code:
bad user name "peterk"
I have already been running on one of ubuntu system and its working there.
Do I need to configure samba for this.
 
Old 02-16-2009, 12:27 AM   #2
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Where did you type this command? On Fedora machine? If you already are running Ubuntu with samba then I think you know how to configure it. And yes you will need to configure it on Fedora as well to let windows machines access your F6 shares.
Just a thought. Why are you using F6 which is too old and out of support and updates?
 
Old 02-16-2009, 12:29 AM   #3
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,461
Blog Entries: 6

Original Poster
Rep: Reputation: 51
I too tried making entry in /etc/fstab:
Code:
//IN-012/isd/  /mnt/window123/               mount.cifs    defaults,credentials=/etc/samba/credential.txt 0 0
And all I run:
Code:
[root@localhost ~]# mount -a
mount: unknown filesystem type 'mount.cifs'
Can I know how gonna I make it happen?
 
Old 02-16-2009, 12:33 AM   #4
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
But why are you making entries in linux machine and mount the drives in Linux if you need to share it with windows? What are you trying to do?
 
Old 02-16-2009, 12:49 AM   #5
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,461
Blog Entries: 6

Original Poster
Rep: Reputation: 51
Let me explain in detail.
I have a Fedora Machine on which SVN Server is running.I have written a script called svn-fullbackup which includes:
Code:
#vi /etc/cron.daily/svn-fullbackup
#!/bin/bash
mount -t cifs //IN-F012/isd/ /mnt/window123/ -o username=peterk/ultratest%<password>,uid=peterk

svnadmin dump  --incremental /home/peterk/svn | gzip -c > /mnt/window123/dumped123.gz
Now I need to take a backup of this Repo to the Remote Windows under ultratest Domain.
So I provided a ultratest Domain username/password.

Now There are two ways I can mount: through command line or through /etc/fstab.But I prefer going through command line.
And that too through Samba.

When I run the script it says:
Code:
[root@localhost cron.daily]# ./svn-fullbackup
bad user name "peterk"
* Dumped revision 0.
* Dumped revision 1.
* Dumped revision 2.
* Dumped revision 3.
* Dumped revision 4.
* Dumped revision 5.
* Dumped revision 6.
* Dumped revision 7.
* Dumped revision 8.
* Dumped revision 9.
* Dumped revision 10.
* Dumped revision 11.
* Dumped revision 12.
* Dumped revision 13.
* Dumped revision 14.
* Dumped revision 15.
* Dumped revision 16.
* Dumped revision 17.
* Dumped revision 18.
* Dumped revision 19.
* Dumped revision 20.
* Dumped revision 21.
* Dumped revision 22.
* Dumped revision 23.
* Dumped revision 24.
* Dumped revision 25.
* Dumped revision 26.
* Dumped revision 27.
* Dumped revision 28.
* Dumped revision 29.
* Dumped revision 30.
* Dumped revision 31.
* Dumped revision 32.
* Dumped revision 33.
* Dumped revision 34.
* Dumped revision 35.
* Dumped revision 36.
* Dumped revision 37.
* Dumped revision 38.
* Dumped revision 39.
* Dumped revision 40.
* Dumped revision 41.
* Dumped revision 42.
* Dumped revision 43.
* Dumped revision 44.
* Dumped revision 45.
* Dumped revision 46.
* Dumped revision 47.
* Dumped revision 48.
* Dumped revision 49.
* Dumped revision 50.
* Dumped revision 51.
* Dumped revision 52.
* Dumped revision 53.
* Dumped revision 54.
* Dumped revision 55.
* Dumped revision 56.
* Dumped revision 57.
* Dumped revision 58.
* Dumped revision 59.
* Dumped revision 60.
* Dumped revision 61.
* Dumped revision 62.
* Dumped revision 63.
* Dumped revision 64.
* Dumped revision 65.
* Dumped revision 66.
* Dumped revision 67.
* Dumped revision 68.
* Dumped revision 69.
* Dumped revision 70.
* Dumped revision 71.
* Dumped revision 72.
* Dumped revision 73.
* Dumped revision 74.
* Dumped revision 75.
* Dumped revision 76.
* Dumped revision 77.
* Dumped revision 78.
* Dumped revision 79.
* Dumped revision 80.
* Dumped revision 81.
* Dumped revision 82.
* Dumped revision 83.
* Dumped revision 84.
* Dumped revision 85.
* Dumped revision 86.
* Dumped revision 87.
* Dumped revision 88.
* Dumped revision 89.
* Dumped revision 90.
* Dumped revision 91.
* Dumped revision 92.
* Dumped revision 93.
* Dumped revision 94.
* Dumped revision 95.
* Dumped revision 96.
* Dumped revision 97.
* Dumped revision 98.
* Dumped revision 99.
* Dumped revision 100.
* Dumped revision 101.
* Dumped revision 102.
* Dumped revision 103.
* Dumped revision 104.
* Dumped revision 105.
* Dumped revision 106.
* Dumped revision 107.
* Dumped revision 108.
* Dumped revision 109.
* Dumped revision 110.
* Dumped revision 111.
* Dumped revision 112.
* Dumped revision 113.
* Dumped revision 114.
* Dumped revision 115.
* Dumped revision 116.
* Dumped revision 117.
* Dumped revision 118.
* Dumped revision 119.
* Dumped revision 120.
* Dumped revision 121.
* Dumped revision 122.
* Dumped revision 123.
* Dumped revision 124.
* Dumped revision 125.
* Dumped revision 126.
* Dumped revision 127.
* Dumped revision 128.
* Dumped revision 129.
* Dumped revision 130.
* Dumped revision 131.
* Dumped revision 132.
* Dumped revision 133.
* Dumped revision 134.
* Dumped revision 135.
* Dumped revision 136.
* Dumped revision 137.
* Dumped revision 138.


Now Just to inform you, I setup the same on one of the Ubuntu Machine and that was working .

Last edited by your_shadow03; 02-16-2009 at 12:51 AM.
 
Old 02-16-2009, 01:11 AM   #6
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Now if you are wanting to mount windows shares in Linux you do not need samba configured.
 
Old 02-16-2009, 01:20 AM   #7
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,461
Blog Entries: 6

Original Poster
Rep: Reputation: 51
Then whats the right solution?
 
Old 02-16-2009, 01:26 AM   #8
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Quote:
Originally Posted by your_shadow03 View Post
I too tried making entry in /etc/fstab:
Code:
//IN-012/isd/  /mnt/window123/               mount.cifs    defaults,credentials=/etc/samba/credential.txt 0 0
And all I run:
Code:
[root@localhost ~]# mount -a
mount: unknown filesystem type 'mount.cifs'
Can I know how gonna I make it happen?
have you tried changing the fs type from mount.cifs to just cifs?
 
Old 02-16-2009, 01:32 AM   #9
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,461
Blog Entries: 6

Original Poster
Rep: Reputation: 51
Code:
[root@localhost ~]# mount -a
mount error 13 = Permission denied
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
[root@localhost ~]#
Any idea what its talking about?
Why its asking for mount.cifs
 
Old 02-16-2009, 01:52 AM   #10
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Do you have smbfs installed?
 
Old 02-16-2009, 01:54 AM   #11
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,461
Blog Entries: 6

Original Poster
Rep: Reputation: 51
Its Done.
I followed http://www.linuxquestions.org/questi...-sucks-463271/ and make it done.

Solution:
Code:
mount -t cifs //IN-F012/isd/ /mnt/window123/ -o username=ultratest, password=<password>
Thanks chaitanya for the concern
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba Setup loadedk Linux - Networking 3 12-12-2007 05:24 PM
Samba Setup neocontrol Linux - Software 4 07-12-2005 12:06 AM
samba setup paschim Linux - Newbie 3 10-07-2004 04:57 PM
I need the content from thegoldenear.org/toolbox/unices/samba/samba-setup.html rtg2001 Linux - Networking 1 08-05-2004 06:54 PM
Samba setup help wenberg Slackware 18 02-13-2004 02:40 PM


All times are GMT -5. The time now is 10:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration