LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-01-2014, 10:48 PM   #1
lesley_raven
LQ Newbie
 
Registered: Jan 2014
Posts: 2

Rep: Reputation: Disabled
Setting variables exported from submission host with SLURM


Hi, Im a qsub/PBS user who is converting to SLURM and I need help running parallel/multithread jobs.
Specifically I need to know how to set variables. The following does not work...

PHP Code:
sbatch --export=="type=animal,VAR2=valueB" script.sh

sbatch
errorThis does not look like a batch script.  The first
sbatch
errorline must start with #! followed by the path to an interpreter.
sbatcherror: For instance#!/bin/sh 
I am trying to do this...
PHP Code:
qsub -v type=animalrun=4 script.sh 
I would appreciate any help.
Cheers, Lel
 
Old 01-14-2014, 03:58 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387
Thread is marked as being [SOLVED] and no solution is present.

@OP: Can you provide the solution so that others can also benefit from it?

Taken off the zero-reply list.
 
1 members found this post helpful.
Old 01-14-2014, 04:13 PM   #3
lesley_raven
LQ Newbie
 
Registered: Jan 2014
Posts: 2

Original Poster
Rep: Reputation: Disabled
Red face

The export command was fine... The error was that script.sh must begin with a shebang line.. oops

PHP Code:
#!/bin/bash 
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slurm AbidDhanaiser Linux - General 3 11-02-2013 11:22 PM
SSH without root environment variables exported on CentOS 5.8 + SELinux ecataranciuc Linux - Server 4 07-31-2012 08:12 AM
[SOLVED] using ssh cant access applications off of host, problem with environment variables josip76 Programming 15 10-22-2010 01:31 AM
Need help setting environment variables. cottonmouth Linux - Newbie 3 12-09-2004 05:54 PM
Setting Environment Variables farzan Linux - Newbie 2 08-07-2004 10:13 AM


All times are GMT -5. The time now is 05:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration