LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-17-2011, 08:58 AM   #1
vintage2010
Member
 
Registered: Nov 2010
Location: Ohio
Distribution: RHEL 5
Posts: 52

Rep: Reputation: 0
Setting up YUM local repository using Apache


Before posting I viewed the similiar threads but didn't find my problem --

so here goes...

I am setting up a local YUM repository in which I will have one computer accessing the RHN network and the clients will pull the updates from that server.

I have seven linux computers that I need to have access this repo server via apache.

I called Red Hat support and this what they told me to do....

On the YUM Repo Server -
> go to /etc/httpd/conf
> copy original to something else (you name, just save the original)
>edit the httpd.conf file
> add in ServerAdmin root@10.24.79.195
>add in ServerName 10.24.79.195 (ip of repo server)
> keep DocumentRoot "/var/www/html"
> save and close

> service httpd restart
>cd /var/www/html/yum/rhel5
> run the createrepo .
> run the yum clean all

On RHEL client
> create a ".repo file" -- EX: my.repo
> file @ /etc/yum.repos.d/my.repo
> Contents of "my.repo
[rhel5-server]
name=RHEL 5.5 Server Repository
baseurl=http://10.24.79.195/var/www/htmlyum/rhel5
enabled=1
gpgcheck=0

> save and close
> run the yum list command.

My issues --
When I run the yum list command on the client side -- it retrieves packages
but what do I do after that??

When I run the yum update -- I get this

Loaded plugins: rhnplugin, security
Bad id for repo: rhel 5 , byte = 4
This system is not registered with RHN.
RHN support will be disabled.
Setting up Update Process
No Packages marked for Update

Another issue --- I have no idea how to configure apache -- when I was on the phone with Red Hat we went so fast that I couldn't write down everything.

Any helpful solutions?
 
Old 02-18-2011, 08:57 AM   #2
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,184

Rep: Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584
Well, it sounds like it is working, and your system is up to date.

If you'd like to test to see that yum is in fact able to pull something from your repo, then try:

Code:
yum install screen
which will install the "screen" program

then, since this is a test, if you do not want that package,

Code:
yum erase screen
 
Old 02-21-2011, 10:56 AM   #3
vintage2010
Member
 
Registered: Nov 2010
Location: Ohio
Distribution: RHEL 5
Posts: 52

Original Poster
Rep: Reputation: 0
Another update --- then I will close.

I had spaces in my config files and had the wrong IP address. I haven't been able to test yet but I have opened a case with Red Hat.
I'm just not getting it -- the YUM repository setup.

I will close this post -- Thank you for the information "szboardstretcher"
 
Old 02-21-2011, 11:02 AM   #4
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,184

Rep: Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584Reputation: 1584
Quote:
Originally Posted by vintage2010 View Post
Another update --- then I will close.

I had spaces in my config files and had the wrong IP address. I haven't been able to test yet but I have opened a case with Red Hat.
I'm just not getting it -- the YUM repository setup.

I will close this post -- Thank you for the information "szboardstretcher"
Good luck.

If you could update this when you find an answer, I'd be interested to find out what the issue was.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with YUM setup with local repository codenjanod Linux - Software 2 03-05-2010 03:09 AM
yum local repository rames2075 Linux - Enterprise 2 10-25-2008 08:16 AM
local yum repository tombolio Linux - Newbie 4 09-11-2008 07:28 PM
Setting Local DVDROM as yum Repository Mustafa^Qasim Linux - Newbie 1 05-03-2008 09:01 PM
how can i add a local Folder on local Hard Disk as Yum Repository ?? vahid_p Fedora 4 02-22-2007 10:43 AM


All times are GMT -5. The time now is 05:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration