LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-07-2003, 07:50 AM   #1
drzeyd
LQ Newbie
 
Registered: Dec 2003
Location: Mauritius
Distribution: RH9, Knoppix, Fedora--?switching to SuSE
Posts: 5

Rep: Reputation: 0
Setting up xDSL Connection with Fedora Core 1


I was using RH9.0 and able to make an ASDL connection to eth0. After doing a clean install of Fedora Core 1, I used the same "internet connection wizard" to set up the xDSL connection with the same parameters as with RH9. Even though the ASDL ppp0 connection can be "activated," I am unable to connect to any internet site (using Mozilla and/or Opera).

Any advice?
 
Old 12-07-2003, 11:33 AM   #2
dkaplowitz
Member
 
Registered: Oct 2002
Location: Havertown PA
Distribution: Ubuntu/RHEL/Fedora
Posts: 253

Rep: Reputation: 31
What is the output of the command "ifconfig -a", run as root?
 
Old 12-07-2003, 12:38 PM   #3
drzeyd
LQ Newbie
 
Registered: Dec 2003
Location: Mauritius
Distribution: RH9, Knoppix, Fedora--?switching to SuSE
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for your response. I have Fedora Core 1 on 2 other computers but get the same error: The ASDL connection appears to be activated, an IP address appears to assigned by the internet provider but none of my browsers (Opera 7.23, Mozilla 1.5, or Konqueror) are able to connect to any site.

Please note that there is no proxy server so each browser is configured as a direct connection to the Internet. Also, there is no problem connecting with Knoppix 3.0--Nov 2003 release nor with WinXP Professional.

This is the output of ifconfig -a:

[root@localhost root]# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:550:49:C4:1B
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:11 errors:0 dropped:0 overruns:0 frame:0
TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:716 (716.0 b) TX bytes:2742 (2.6 Kb)
Interrupt:10 Base address:0xfc00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:5708 errors:0 dropped:0 overruns:0 frame:0
TX packets:5708 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4682634 (4.4 Mb) TX bytes:4682634 (4.4 Mb)

ppp0 Link encap:Point-to-Point Protocol
inet addr:202.123.20.197 P-t-P:202.123.20.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:94 (94.0 b) TX bytes:122 (122.0 b)

wlan0 Link encap:Ethernet HWaddr 00:0C:41:0D:6A:0E
BROADCAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

[root@localhost root]#
 
Old 12-07-2003, 01:11 PM   #4
dkaplowitz
Member
 
Registered: Oct 2002
Location: Havertown PA
Distribution: Ubuntu/RHEL/Fedora
Posts: 253

Rep: Reputation: 31
Quote:
Originally posted by drzeyd


[root@localhost root]# ifconfig -a
ppp0 Link encap:Point-to-Point Protocol
inet addr:202.123.20.197 P-t-P:202.123.20.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:94 (94.0 b) TX bytes:122 (122.0 b)

[root@localhost root]#
I can ping your IP address...so something's active. Is that the box you are using to post this?

Let me ask you some more questions, what does your /etc/resolv.conf say?

I think you are having a DNS problem. You need to configure the DNS servers your ISP gives you.

PS if you put your code output between the [code] tags, the smileys won't show up in it.

Last edited by dkaplowitz; 12-07-2003 at 01:15 PM.
 
Old 12-07-2003, 01:13 PM   #5
dkaplowitz
Member
 
Registered: Oct 2002
Location: Havertown PA
Distribution: Ubuntu/RHEL/Fedora
Posts: 253

Rep: Reputation: 31
I am assuming that what I'm pinging is your windows box. If that's the case, then do an "ipconfig /all" from a command prompt (or winipcfg if it's 9x or ME) and write all the parameters down --- esp. what it says for DNS servers. You can use that in the Linux config.

Also, I'd close up some of those ports you have open, or you might be looking at some trouble from crackers. (unless you've made sure you're those ports are running securely).

Last edited by dkaplowitz; 12-07-2003 at 01:16 PM.
 
Old 12-07-2003, 01:50 PM   #6
drzeyd
LQ Newbie
 
Registered: Dec 2003
Location: Mauritius
Distribution: RH9, Knoppix, Fedora--?switching to SuSE
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for your assistance and prompt reply.

The /etc/resolv.conf file is EMPTY.
 
Old 12-07-2003, 01:53 PM   #7
drzeyd
LQ Newbie
 
Registered: Dec 2003
Location: Mauritius
Distribution: RH9, Knoppix, Fedora--?switching to SuSE
Posts: 5

Original Poster
Rep: Reputation: 0
I am connecting using WinXP Professional. I will try fixing the DNS servers as indicated by the ipconfig/all command and get back to you.

Thanks again.
 
Old 12-07-2003, 02:17 PM   #8
drzeyd
LQ Newbie
 
Registered: Dec 2003
Location: Mauritius
Distribution: RH9, Knoppix, Fedora--?switching to SuSE
Posts: 5

Original Poster
Rep: Reputation: 0
Thank you very much: It finally worked when I entered the DNS settings from ipconfig/all. I don't understand why I had to enter these settings for Fedora but not for RH 8 or RH9 or for Knoppix Linux.
 
Old 12-07-2003, 02:35 PM   #9
dkaplowitz
Member
 
Registered: Oct 2002
Location: Havertown PA
Distribution: Ubuntu/RHEL/Fedora
Posts: 253

Rep: Reputation: 31
Quote:
Originally posted by drzeyd
Thank you very much: It finally worked when I entered the DNS settings from ipconfig/all. I don't understand why I had to enter these settings for Fedora but not for RH 8 or RH9 or for Knoppix Linux.
It's possible that these were given to the previous versions by DHCP...which is how it usually works. I don't know why Fedora didn't pick them up...but I haven't done much with Fedora.

Glad it's working for you now.

Dave
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up connection with IPW 2200BG in Fedora Core 4 jan@fjb.nu Linux - Wireless Networking 13 09-09-2005 04:57 PM
Fedora Core 2 - Setting up a Belkin Wireless Connection TKDHokie Linux - Wireless Networking 0 09-27-2004 10:22 PM
Setting up wireless connection on Fedora 2 pitimespi Linux - Wireless Networking 2 08-01-2004 04:11 PM
setting up a domain in fedora core Gatekeeper785 Linux - Networking 0 04-10-2004 09:48 PM
xDSL/Router Network Connection o0k|ey Slackware 2 07-12-2003 08:51 PM


All times are GMT -5. The time now is 04:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration