LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-08-2005, 02:13 AM   #1
zodman
LQ Newbie
 
Registered: May 2005
Posts: 12

Rep: Reputation: 0
setting up USB modem in Slackware 10.1 (with 2.4.29 kernel)


Hello guys, could really use you help on this,

I've try to install on my fresh copy of Slack 10.1 a USB modem driver for BIPAC-7000 (which I downloaded from here: http://www.billion.com/support/download/fd/fd1.htm)

I extracted it, and follow the readme instruction below:

'First, uncompressing the packaged: USBNET_E2_LINUX_062802_REL1.7.tar.gz
#tar zxvpf USBNET_E2_LINUX_062802_REL1.7.tar.gz
A directory named e2 will be created under current directory.

Second, Changing directory to the "e2" directory.
#cd e2

Third, compiling the source code.
#make

At last, copy the firmware file "CnxE2Fw.bin" to directory "/etc".
#cp CnxE2Fw.bin /etc/CnxE2Fw.bin


Now, you can install the driver by the command below under current directory:
#insmod e2.o'

now this is where trouble begin, the next step readme told me to do was to issue a command 'ifconfig hsb0 up' which I did and got error saying that no such device exist.

here the readme text :

'If the network doesn't up automatically, you must run the following commands to activate the net adapter.
#ifconfig hsb0 up
#dhcpcd -n hsb0'

what did I do wrong? sorry if this seems very newbie to you all but I'm really new to this(I fact, this is the first time I successfully complies a program using 'make' command)

Thanks in advance guy.
 
Old 05-08-2005, 02:28 AM   #2
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
not sure if this will work on not, but worth a shot:

first make a backup of the file we will be modifying (as root):
Code:
cp /etc/rc.d/rc.inet1.conf /etc/rc.d/rc.inet1.conf.bak
if you need your original back, delete /etc/rc.d/rc.inet1.conf and rename .conf.bak to .conf again

as root, open up /etc/rc.d/rc.inet1.conf in a text editor.

add the following:

Code:
# Config information for hsb0
IPADDR[4]=""
NETMASK[4]""
USE_DHCP[4]="yes"
DHCP_HOSTNAME[4]=""
if your isp requires a hostname to login put it in the DHCP_HOSTNAME field above.

Last edited by __J; 05-08-2005 at 02:32 AM.
 
Old 05-08-2005, 05:25 AM   #3
zodman
LQ Newbie
 
Registered: May 2005
Posts: 12

Original Poster
Rep: Reputation: 0
Thankyou __J! I've edited rc.inet1.conf file as you advise. Although it still display the same error when I run ifconfig hsb0 up, at least now adsl-setup use hsb0 as my default device.

But I noticed something strange: if I issue a command 'insmod e2.o' and then run ifconfig, instate of telling me that such device cannot be found, it display this error message instate:

SIOCSIFFLAGS: Resource temporarily unavailable

when I restart linux and run ifconfig again (without run insmod first) it display the old error message(...such device cannot be found), If I run insmod and then ifconfig then I got the 'resouce unavailable' error message.

what does this mean? also when I run insmod e2.o I got the message saying this module that I'm load will 'tainted' the kernel, at first I ignore this thinking it was just a warning but does it have anything to do with this?
 
Old 05-08-2005, 05:35 AM   #4
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
http://www.vidarholen.net/contents/linuxtips/

try this and see if it helps
 
Old 05-08-2005, 11:30 AM   #5
zodman
LQ Newbie
 
Registered: May 2005
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks again __J , I check you link, It tells me to turn off Plug&Play option in bios, which I did. I then try to set ifconfig again, but to my horror it display the same error message, well at least I know it wasn't the bios setup.
 
Old 05-14-2005, 10:54 AM   #6
Borvorn
LQ Newbie
 
Registered: May 2005
Posts: 1

Rep: Reputation: 0
after you use "insmod e2.o" command
unplug usb port of the modem and plug it
wait until adsl light is stop blink then use "ifconfig hsb0 up"

sorry for my poor english
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
need help setting up usb cable modem 9,1 personal joel b SUSE / openSUSE 3 02-20-2005 07:36 AM
Setting up UM9800 USB-modem pawitp Linux - Newbie 0 01-06-2005 10:01 PM
Setting up modem on slackware? Kensai Slackware 21 08-16-2004 04:45 PM
Setting Up Dlink Usb Cable Modem nos_1350 Linux - Networking 2 03-24-2004 02:15 PM
Setting up USB Cable Modem Tickled_Pink Linux - Networking 6 07-31-2003 09:18 AM


All times are GMT -5. The time now is 06:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration