LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-28-2001, 02:52 PM   #1
Lowell
LQ Newbie
 
Registered: Mar 2001
Posts: 4

Rep: Reputation: 0

Im trying to set up telnet on Turbolinux 6.0 (2.2.14). After getting "connection refused", I finally figured out that telnetd was by default disabled in /etc/inetd.conf.
Now, I get "connected to <hostname>. Escape character is '^]'. " and thats all, then it times out in a few seconds with "connection closed". How do I get a login?
 
Old 03-28-2001, 03:07 PM   #2
Jasper33
LQ Newbie
 
Registered: Mar 2001
Location: Wyoming
Distribution: mandrake 7.1
Posts: 21

Rep: Reputation: 15
it's working either your connection isn't or the shell you are telneting into is down
 
Old 03-29-2001, 09:03 AM   #3
nedo
Member
 
Registered: Mar 2001
Location: Northern Poland
Posts: 34

Rep: Reputation: 15
ekhm...
did you actually install the telnetd ?
I had similar problem and figuread out that I forgot tyo install the telnet daemon :]
 
Old 03-29-2001, 12:58 PM   #4
Lowell
LQ Newbie
 
Registered: Mar 2001
Posts: 4

Original Poster
Rep: Reputation: 0
Looking in the man pages for telnet, I found that it has a debug mode. When I type "in.telnetd -debug" on the host console, I am able to telnet in for a single session from my client. It gives me a login this way. So can I assume that telnet is present and my connection and shell are working? Why won't it run from inetd?
 
Old 03-29-2001, 02:06 PM   #5
jeremy
root
 
Registered: Jun 2000
Distribution: Debian, Red Hat, Slackware, Fedora, Ubuntu
Posts: 12,226

Rep: Reputation: 3179Reputation: 3179Reputation: 3179Reputation: 3179Reputation: 3179Reputation: 3179Reputation: 3179Reputation: 3179Reputation: 3179Reputation: 3179Reputation: 3179
Do you have anything in /etc/hosts.deny or /etc/hosts.allow?
 
Old 03-29-2001, 04:19 PM   #6
Lowell
LQ Newbie
 
Registered: Mar 2001
Posts: 4

Original Poster
Rep: Reputation: 0
That was it! I tried putting ALL:ALL in /etc/hosts.allow for a test and it worked. Thanks everyone!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up telnet server in mandrake meteoric Linux - Networking 4 08-27-2005 10:32 PM
setting up telnet host leroy27336 Linux - Networking 2 11-12-2003 03:13 PM
Setting up incoming telnet sessions jasonhbishop Linux - Networking 6 10-23-2003 03:56 PM
how to setting up a telnet server wincrk Linux - Networking 17 07-30-2003 05:11 PM
Setting up telnet on rh? Thom_Redhat Linux - General 5 05-16-2003 04:59 PM


All times are GMT -5. The time now is 07:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration