LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-27-2006, 10:15 AM   #1
chanwcom
LQ Newbie
 
Registered: Mar 2006
Posts: 3

Rep: Reputation: 0
Setting Up NFS server with VMWare


Hi,

I'm a novice LINUX user. I installed Fedora 4 LINUX using VMWare.

The following shows my current configuration:

Host OS: Windows XP Professional
Guest OS: Fedora 4
VMWare Version: VMWare Workstation 5.5
Network Configuration: NAT.

I wanted to set up NFS and SSH severs using the above configuration. For the SSH server, I used port forwarding, and it seemed to be successful. (I forwarded TCP port 22)

But I could not make the NFS server work. I tried it by forwarding 2049 TCP/UDP, and 111 TCP ports, but it did not work.

So, could you tell me how I can resolve this problem with the NFS server? Or do you have any similar experiences?

Thanks very much!

Last edited by chanwcom; 03-27-2006 at 12:09 PM.
 
Old 03-27-2006, 10:23 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
I really really wouldn't recommend natting within vmware. if you're not actually natting to reach the net, don't do nat at all, give it a local network address.
 
Old 05-02-2006, 09:02 AM   #3
pschaff
LQ Newbie
 
Registered: May 2006
Posts: 4

Rep: Reputation: 0
Quote:
Originally Posted by acid_kewpie
I really really wouldn't recommend natting within vmware. if you're not actually natting to reach the net, don't do nat at all, give it a local network address.
However, if you do need to use NAT (as in my case where I must pay a monthly fee for each IP address, but NAT is free) NFS can be made to work. The trick that worked for me was to get the server to allow the "insecure" ports that the VMware NAT wants to use by putting the correct entry in /etc/exports on the NFS server. Couldn't find the answer on the VMware site, but Petr Vandrovec (of vmware.any.any patch fame) gave a procedure elsewhere. (Can't post the URL as I'm too new a member. )

Example (for RedHat style distros) follows:

Let the NFS server name be "realserv", the filesystem to share be "/share", the VMware host machine be "realhost1", and the VMware virtual machine be "vm1". The physical machines have fixed addresses and both have entries in /etc/hosts on each machine - DNS resolvable names or numeric IP addresses/subnets should also work.

On realserv, /etc/exports contains:

/share realhost1(rw,async,insecure)

Run "exportfs -r" after modifying /etc/exports (assuming the nfs service was already running).

Or, showing a few more options:

/share realhost1(rw,no_root_squash,async,insecure) realhost2(rw,async,insecure) nonnat.my.net(rw,no_root_squash,async) 192.168.3.0/24(rw,async)

The no_root_squash parameter allows root access to the NFS share, otherwise root maps to nobody.nogroup. realhost1 and it's VM NATs have root access. realhost2 and its NATs do not. nonnat.my.net has root access but no NAT access. Machines on subnet 192.168.3.0/24 have normal user access but no NAT access.

Any firewall on realserv must be set up to allow access from all clients.

On realhost1 VMware guest vm1 is set up for NAT networking and can mount the share as follows:

# mkdir /share
# mount realserv:/share /share

Assuming success, can make it permanent by using the entry found in /etc/mtab to make a new entry in /etc/fstab, or set up autofs for automounts.

According to info on the VMware site, it should also be possible to fix the problem on the host machine in the NAT config by forcing the use of ports in the range 512-1023 that will make the server happy without the "insecure" parameter; howerver, the details were lacking and I have not yet been able to get that approach to work.

Phil
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NFS client = Linux, NFS server = Mac OS X Tiger --> Hell of a problem make Linux - Networking 9 03-10-2006 06:16 AM
LXer: VMware Introduces Free VMware Server LXer Syndicated Linux News 0 02-07-2006 09:46 AM
Setting up the NFS server on Solaris Box suresheva31 Linux - Networking 1 04-01-2005 01:51 PM
trouble in setting up NFS server in Sun Solaris soumyadeep Solaris / OpenSolaris 7 03-03-2005 03:47 AM
setting up the nfs server in debian stable. graham Debian 1 02-15-2004 05:16 AM


All times are GMT -5. The time now is 04:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration