LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-24-2015, 12:46 AM   #1
batabuntu
LQ Newbie
 
Registered: May 2010
Posts: 17

Rep: Reputation: 0
Setting LXDM as default display manager for Ubuntu 15.04


Hello

I'm trying to set lxdm as default display manager for Ubuntu 15.04 running unity. Lightdm eats way too many resources in Unity.

So I thought the solution was to use much lighter display manager like lightdm. I'm currently running XFCE environment and lightdm doesn't seem to resource hogging but in Unity it did a lot. Like just having Wunderlist website opened, the lightdm jump up in resource usage. Combine it with Compiz, I'm seeing like 60-70 percent usage just having a website being opened!

I tried enable lxdm via alt+cntrl+f1 but the service fails to start. I did it from dpkg-reconfigure gdm as well but the the bugs.

I made a more detailed post there:-

http://askubuntu.com/questions/65174...d-ubuntu-15-04

Is it even possible to run lxdm on Unity? If so, will there be any drop in resource usage?
 
Old 07-24-2015, 06:03 PM   #2
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Linux Mint, Ubuntu
Posts: 1,504

Rep: Reputation: 325Reputation: 325Reputation: 325Reputation: 325
Not sure why lightdm (or any dm) would use much in the way of resources once you've started your DE. Not sure how it works currently in Ubuntu with systemd, but in Fedora, it's easy enough to forego the display manager and start an X session from the command line.
 
Old 07-25-2015, 01:34 PM   #3
batabuntu
LQ Newbie
 
Registered: May 2010
Posts: 17

Original Poster
Rep: Reputation: 0
Oh I see. So it has something to do with systemd? Been using XFCE for a while and it's running really smooth and slick. The only thing is I feel like I'm using really 'old' UI when things like Windows 8.1, Unity are so are ahead in UI experience.

Although XFCE does get the job done and it's awesome how fast it runs, really want to use Unity though. It's like using XP or 7 when there is Windows 8.1 and soon 10.
 
Old 07-25-2015, 06:08 PM   #4
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Linux Mint, Ubuntu
Posts: 1,504

Rep: Reputation: 325Reputation: 325Reputation: 325Reputation: 325
I took a quick look at my Ubuntu 15.10 (development) installation; didn't see the hooks I see in Fedora for the graphical start-up. However, the rc2.d, rc3.d, rc4.d, and rc5.d directories in /etc all have links to /etc/init.d/lightdm, which starts lightdm. You should just be able to swap lightdm for another display manager and have it just work; I probably wouldn't remove lightdm until I had the new dm actually working.
 
1 members found this post helpful.
Old 07-26-2015, 03:14 AM   #5
batabuntu
LQ Newbie
 
Registered: May 2010
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by RockDoctor View Post
I took a quick look at my Ubuntu 15.10 (development) installation; didn't see the hooks I see in Fedora for the graphical start-up. However, the rc2.d, rc3.d, rc4.d, and rc5.d directories in /etc all have links to /etc/init.d/lightdm, which starts lightdm. You should just be able to swap lightdm for another display manager and have it just work; I probably wouldn't remove lightdm until I had the new dm actually working.
Alright, but is there a way to temporarily run the LXDM? The methods I tried isn't really working which is at the login screen to alt-cntrl-f1 and type
Code:
service lightdm stop
service lxdm start
I get an error saying
Code:
lxdm.service
can't be started
 
Old 07-26-2015, 09:33 AM   #6
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Linux Mint, Ubuntu
Posts: 1,504

Rep: Reputation: 325Reputation: 325Reputation: 325Reputation: 325
Did lightdm really stop, or did it just respawn (and, hence, block lxdm)?

The more I look, the more I see that things are not as they were, and the functional equivalents of the old files are not where they were pre-systemd. What if you change one of the runlevels to start lxdm instead of lightdm, then boot into that runlevel (hit the tab key when the grub menu shows up and append the runlevel number to the kernel line)?

If that didn't work, now I would nuke lightdm
 
Old 07-26-2015, 07:20 PM   #7
Doug G
Member
 
Registered: Jul 2013
Posts: 594

Rep: Reputation: Disabled
I just went through switching display managers with systemd
Quote:
systemctl disable lightdm
systemctl enable lxdm
This is where I rebooted.
 
Old 07-27-2015, 11:01 AM   #8
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Linux Mint, Ubuntu
Posts: 1,504

Rep: Reputation: 325Reputation: 325Reputation: 325Reputation: 325
I was looking at the Mate forum when I came across a reference to /etc/X11/default-display-manager. Checking my various distros, I see that Fedora doesn't use it, but Ubuntu and Linux Mint both appear to.
 
Old 07-27-2015, 11:11 AM   #9
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 5,993

Rep: Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611
I have to admit I am very confused by this thread. As I understand it the display manager just starts the Desktop Environment, or Window Manager, then gets out of the way?
I can't see changing the display manager making any difference at all -- surely you're just seeing that Unity is a resource hog? In which case there's possibly very little you can do to change that.
 
Old 07-27-2015, 06:49 PM   #10
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Linux Mint, Ubuntu
Posts: 1,504

Rep: Reputation: 325Reputation: 325Reputation: 325Reputation: 325
Quote:
Originally Posted by 273 View Post
As I understand it the display manager just starts the Desktop Environment, or Window Manager, then gets out of the way?
That's what's supposed to happen, and is exactly what's happens on all of my installations on my desktop PC (lightdm is currently using 0.4% of my 4G of RAM as I run My Mate desktop on Ubuntu 15.10 dev). However, if for some reason OP is having problems with lightdm, switching to lxdm might resolve those problems.
 
Old 07-29-2015, 06:52 AM   #11
batabuntu
LQ Newbie
 
Registered: May 2010
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by RockDoctor View Post
That's what's supposed to happen, and is exactly what's happens on all of my installations on my desktop PC (lightdm is currently using 0.4% of my 4G of RAM as I run My Mate desktop on Ubuntu 15.10 dev). However, if for some reason OP is having problems with lightdm, switching to lxdm might resolve those problems.
I don't have issues when running lightdm on xfce environment but I do on Unity. The CPU resource is very high. Like I mentioned in the first post, having Wunderlist website open jacks up the cpu to 50 -> just lightdm. Blank tab, drops to like 2cpu. I want to run LXDM DM on Unity to see if I get any improvements.

I ran this

Code:
systemctl disable lightdm
systemctl enable lxdm
I get the following error shown in the picture. I don't know why am I getting "Authentication Failed" when there is only one account which is admin.
Attached Thumbnails
Click image for larger version

Name:	IMG_20150729_151406.jpg
Views:	12
Size:	262.0 KB
ID:	19032   Click image for larger version

Name:	IMG_20150729_151423.jpg
Views:	10
Size:	264.0 KB
ID:	19033  
 
Old 07-29-2015, 02:08 PM   #12
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 5,993

Rep: Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611Reputation: 1611
Quote:
Originally Posted by batabuntu View Post
I don't have issues when running lightdm on xfce environment but I do on Unity. The CPU resource is very high. Like I mentioned in the first post, having Wunderlist website open jacks up the cpu to 50 -> just lightdm. Blank tab, drops to like 2cpu. I want to run LXDM DM on Unity to see if I get any improvements.

I ran this

Code:
systemctl disable lightdm
systemctl enable lxdm
I get the following error shown in the picture. I don't know why am I getting "Authentication Failed" when there is only one account which is admin.
You need to run both those commands as root, if you are not already, so preface them with sudo if necessary.
As to lightdm using more than 50% of your CPU, how are you seeing that? I'm extremely puzzled why lightdm would use any more of your CPU (and it ought to be using virtually 0% while you are in a desktop session) when you open programs.
Are you sure you are not confusing window managers with display managers?
https://en.wikipedia.org/wiki/Window_manager
https://en.wikipedia.org/wiki/X_disp...rogram_type%29
If you are then as far as I know you cannot change the window manager used by Unity as Canonical has created its own which is tightly bound to Unity.
 
Old 07-30-2015, 04:26 AM   #13
batabuntu
LQ Newbie
 
Registered: May 2010
Posts: 17

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by 273 View Post
You need to run both those commands as root, if you are not already, so preface them with sudo if necessary.
As to lightdm using more than 50% of your CPU, how are you seeing that? I'm extremely puzzled why lightdm would use any more of your CPU (and it ought to be using virtually 0% while you are in a desktop session) when you open programs.
Are you sure you are not confusing window managers with display managers?
https://en.wikipedia.org/wiki/Window_manager
https://en.wikipedia.org/wiki/X_disp...rogram_type%29
If you are then as far as I know you cannot change the window manager used by Unity as Canonical has created its own which is tightly bound to Unity.
It is this

Code:
/usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch -background none
My thinking is if I change from lightdm to LXDM, the cpu resource might drop down.

I guess what I want to change is the window manager from lightdm to LXDM which not be possible on Unity.
 
Old 07-31-2015, 02:40 PM   #14
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Linux Mint, Ubuntu
Posts: 1,504

Rep: Reputation: 325Reputation: 325Reputation: 325Reputation: 325
I'll bet it's a window manager problem. XFCE's window manager, xfwm, has never given me problems, even when enabling compositing. Compiz, which I believe is Unity's window manager, places high demands on my CPU because I've got an ancient graphics system (onboard Geforce 9100) with no modern GPU onto which the graphics calculations can be offloaded. I've run compiz with LXDE and XFCE; the problem remains. However, even in compositing mode, marco (Mate's window manager) typically uses less than 1 of the CPU. I don't know if Unity can run with a different window manager.
 
Old 08-01-2015, 04:19 AM   #15
batabuntu
LQ Newbie
 
Registered: May 2010
Posts: 17

Original Poster
Rep: Reputation: 0
I ran this to to know if the problem was with compiz or
Code:
/usr/bin/X :0 -auth /var/run/lightdm/root/:0
Code:
➜  ~  /usr/lib/nux/unity_support_test -p
OpenGL vendor string:   nouveau
OpenGL renderer string: Gallium 0.4 on NV94
OpenGL version string:  3.0 Mesa 10.5.2

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes
When moving the window around, that /bin/X lightdm takes up 20cpu with compiz 20cpu as well. This issues only occurs when running Unity. But when I change the DE environment to XFCE, I don't have this issue.

I guess only way to fix this issue is by leaving unity and going for alternate. XFCE is very snappy and will look into Ubuntu Mate.

If I install Xubuntu or Lubuntu, will they use their own display manager? What I have in mind is to intall Lubuntu and install XFCE on top of it. From what I been reading online, LXDM is much lighter. I like the interface of XFCE so I want to run LXDM on XFCE, is it possible or will it break the system?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] switching default display manager newbiesforever Linux - General 5 08-21-2011 10:29 PM
Default Display Manager experiment, do you think it would work? QueenZ Linux - Newbie 5 03-20-2010 03:00 PM
How to change the default Display Manager? QueenZ Linux - Newbie 4 03-09-2009 09:44 AM
Setting KDE as Default Window Manager rufius Linux - Software 2 04-28-2003 01:18 AM
Setting default Window Manager DiZASTiX Linux - General 1 03-18-2003 05:31 PM


All times are GMT -5. The time now is 02:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration