LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-17-2012, 04:25 AM   #1
LukasH
Member
 
Registered: Jul 2012
Posts: 31

Rep: Reputation: Disabled
Setting keyboard layout to german


Hello everyone,

I am using a Ubuntu 12.04 server edition and I experience the problem of having they keyboard layout in some US style, not in german style as I would like to have it.

So, what google told me was ofcourse the following:

Code:
sudo dpkg-reconfigure console-data
That allows me to change the layout to a layout of my choice, but the changes do not remain permanent, after a reboot, it all switches back.

So, next, I found out that within

Code:
/etc/default/keyboard
one can define the layout - but I can't find out the exact values to switch my keyboard layout to german. Can anyone help?

Content of the keyboard file:

Code:
XKBMODEL="pc105"
XKBLAYOUT="de" // I replaced "us" with "de" already, hope it's right
XKBVARIANT="alt-intl"
XKBOPTIONS=""
 
Old 12-18-2012, 02:14 PM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
I have no experience with Ubuntu, but it seems that you have changed the settings for the console but not for X11.

You should search for a directory /etc/X11/xorg.conf.d/ there should be a file which changes the keyboard in X11. In Slackware it is 90-keyboard-layout.conf and it's content is
Code:
...
Section "InputClass"
	Identifier "keyboard-all"
	MatchIsKeyboard "on"
	MatchDevicePath "/dev/input/event*"
	Driver "evdev"
	Option "XkbLayout" "de"
	Option "XkbVariant" "nodeadkeys"
	Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
...
you should search if there is a similar file on your system and then change us to de

This link seems promising: http://wiki.ubuntuusers.de/Spracheinstellungen

Markus

Last edited by markush; 12-18-2012 at 02:22 PM.
 
Old 12-19-2012, 04:06 AM   #3
LukasH
Member
 
Registered: Jul 2012
Posts: 31

Original Poster
Rep: Reputation: Disabled
Hey Markus,

not at all, because the Ubuntu Server is terminal-only. There is no GUI / any form of window system available, I am working completely from bash.
 
Old 12-19-2012, 04:43 AM   #4
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Well, you can load the keyboard
Code:
loadkeys /usr/share/kbd/keymaps/i386/qwertz/de-latin-nodeadkeys.gz
or similar path. Put the code into a file which is always executed while booting.

There should be a variable LANG which you can set to de_DE.UTF8 in order to use UTF-8.

Here's our Slackdocs localizationpage: http://docs.slackware.com/slackware:localization it is generic enough in order to help even with Ubuntu.

Markus
 
1 members found this post helpful.
Old 12-19-2012, 04:44 AM   #5
LukasH
Member
 
Registered: Jul 2012
Posts: 31

Original Poster
Rep: Reputation: Disabled
Okay, that helped a lot! Thank you!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
After Upgrade to 13.37 the german keyboard-layout can't be saved wingevil Slackware 6 06-06-2011 07:13 AM
[SOLVED] gdm (gnome) doesn't start with german keyboard-layout markush Linux - Desktop 2 10-15-2010 07:00 PM
German keyboard layout makowka Linux - Desktop 8 12-22-2009 01:25 PM
German keyboard layout not working with Eterm rangalo Debian 2 12-21-2006 07:25 AM
Keyboard layout (German) medo Linux - Laptop and Netbook 1 07-18-2005 08:52 AM


All times are GMT -5. The time now is 04:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration