LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-01-2008, 08:59 AM   #1
Labman
Member
 
Registered: Apr 2004
Location: Nothern USA
Distribution: Kubuntu 11.10
Posts: 104

Rep: Reputation: 15
Setting display resolution from KDE


How do I get my screen resolution change to ''take''?

I have my new system up and running with Debian, kernel 2.6.24. Unfortunately it is totally unusable on my 17'' monitor at 1280 x 1024 resoultion. I go into the control center/ peripherals/ display, and change to 1024 x 768. When I click on apply, KDE restarts, but back in the 1280 resolution. If I reboot, it still doesn't change. I notice I don't get a prompt for the root password.
 
Old 04-01-2008, 09:18 AM   #2
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
First, we need to make sure that the right driver is installed. Please post the details on your video card and your version of this section of /etc/X11/xorg.conf:
Code:
Section "Device"
    Identifier "device1"
    VendorName "ATI Technologies Inc."
    BoardName "ATI Radeon"
    Driver "radeon"
    Option "DPMS"
    Option "XaaNoOffscreenPixmaps" "1"
#    Option "IgnoreEDID" "true"
EndSection
When you change resolution in the KDE utility, clicking "apply" is not re-starting KDE. It just blanks the screen while it attempts to re-configure.


Quote:
I notice I don't get a prompt for the root password.
How is this relevant?
 
Old 04-01-2008, 02:03 PM   #3
Labman
Member
 
Registered: Apr 2004
Location: Nothern USA
Distribution: Kubuntu 11.10
Posts: 104

Original Poster
Rep: Reputation: 15
OK, I su to root and put in /etc/X11/xorg.conf It comes back permission denied.

I am using the on board video on a PCChips AG13+ MB. It is a NVIDA MBC61 single chip.
 
Old 04-02-2008, 01:19 AM   #4
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Quote:
Originally Posted by Labman View Post
OK, I su to root and put in /etc/X11/xorg.conf It comes back permission denied.

I am using the on board video on a PCChips AG13+ MB. It is a NVIDA MBC61 single chip.
You can view the file using "more". To edit it, you will need an editor such as nano, kedit, kate, etc.

If you just type in the file name, then BASH thinks you are trying to run (execute) the file
 
Old 04-03-2008, 02:50 PM   #5
Labman
Member
 
Registered: Apr 2004
Location: Nothern USA
Distribution: Kubuntu 11.10
Posts: 104

Original Poster
Rep: Reputation: 15
OK

Section "Device"
Identifier "Generic Video Card"
Driver "vesa"
BusID "PCI:0:13:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-64
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

As I said before, I am using the on board video on a PCChips AG13+ MB. It is a NVIDA MBC61 single chip.

I have Kate and have been using it some for text editing.
 
Old 04-03-2008, 10:08 PM   #6
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
OK--you will need either the "nv" or "nvidia" driver. At least the first one should be available using the package manager.

Once the driver is installed, then you just need to change "vesa" to the appropriate name. Also, check your monitor specs for the Horizontal Sync (28-64 seems too low.)
 
Old 04-04-2008, 12:23 AM   #7
Labman
Member
 
Registered: Apr 2004
Location: Nothern USA
Distribution: Kubuntu 11.10
Posts: 104

Original Poster
Rep: Reputation: 15
Thanks for getting back with me. I am still struggling, nothing is working. There is more to this than finding a link at nvidia.com and giving it to apt get. I guess that would work, if the link was there. Nvidia doesn't list a link to what I need. They said all the needed drivers are in the latest kernels. The kernel I am using is a 32 bit one downloaded last Saturday from Debian. It is getting late, I will let everything go until tomorrow.
 
Old 04-04-2008, 07:06 AM   #8
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
You are not going to install the nvidia driver by linking apt-get to the Nvidia site.

If a suitable driver is in your repositories, then you can get it using apt-get (or Synaptic).

If you want the "nvidia" proprietary driver, you'll get that from the Nvidia site. They have an excellent install script that automates everything.
 
Old 04-04-2008, 07:24 AM   #9
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
After you have your video driver installed, kde has a great program called krandrtray that allows you to right click on a tray icon and change the resolution on the fly.
 
Old 04-04-2008, 10:15 AM   #10
General Failure
Member
 
Registered: Jan 2007
Location: Germany
Distribution: Slackware 13.37
Posts: 387

Rep: Reputation: 35
The easiest solution to your problem would be to change the line
Code:
Modes "1280x1024" "1024x768" "800x600" "640x480"
to
Code:
Modes "1024x768" "800x600" "640x480"
You don't even need to install the NVidia driver if you don't want to. (I would )

Last edited by General Failure; 04-04-2008 at 10:16 AM.
 
Old 04-04-2008, 01:27 PM   #11
Labman
Member
 
Registered: Apr 2004
Location: Nothern USA
Distribution: Kubuntu 11.10
Posts: 104

Original Poster
Rep: Reputation: 15
Downloading the driver from NIVIDA doesn't seem to be an option. As I said, they don't give a link, they just say all the drivers are already in the kernel. So it looked like General Failure's suggestion might be easy enough for me to be able to do it. ''The easiest solution to your problem would be to change the line....''

I su to root, and open /etc/X11/xorg.conf in Kate, and delete the 1280 mode. I then go to file and save.

''The document could not be saved, as it was not possible to write to file:///etc/X11/xorg.conf.
Check that you have write access to this file or that enough disk space is available.''
 
Old 04-04-2008, 01:47 PM   #12
Fred Caro
Member
 
Registered: May 2007
Posts: 999

Rep: Reputation: 166Reputation: 166
I have a similar problem and cannot fix it. Trying to reset 1024 to 800x600 but it seems to take on the standard fixed when loaded. Maybe this is a fault in Debian 4?
 
Old 04-04-2008, 05:21 PM   #13
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
According to this:
http://www.tigerdirect.com/applicati...OTC-GOOGLEBASE
the video is Geoforce 6100

For that you want this:
http://www.nvidia.com/object/linux_d...32_169.12.html
 
Old 04-04-2008, 11:03 PM   #14
Labman
Member
 
Registered: Apr 2004
Location: Nothern USA
Distribution: Kubuntu 11.10
Posts: 104

Original Poster
Rep: Reputation: 15
Maybe we are getting somewhere now. I was sure I saw it was the N force chip on the Nvidia site last night. I don't quite trust vendors like Tiger Direct. The power supply described as having a ball bearing fan On the ClubIT website turned out to have sleeve bearings. I hunted up the PCChips website and it confirms the Geforce chip.

A bug means bad code to me. I think this could be operater error, or bad data. Somehow when I downloaded the kernel, I didn't get the right driver. With Fred having the same problem, I wonder if the problem is what is loaded on the Debian site.

Well I am downloading the file at the link you gave me.
 
Old 04-04-2008, 11:42 PM   #15
Labman
Member
 
Registered: Apr 2004
Location: Nothern USA
Distribution: Kubuntu 11.10
Posts: 104

Original Poster
Rep: Reputation: 15
OK, I downloaded it to my desktop.

dick@xantha:~$ su root
Password:
xantha:/home/dick# sh NVIDIA-Linux-x86-169.12-pkg1.run
sh: NVIDIA-Linux-x86-169.12-pkg1.run: No such file or directory

Do I need to have it somewhere besides the desktop?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Display resolution per user (xinerama, KDE, Debian) johnsfine Linux - Newbie 4 03-02-2008 07:38 AM
Problem setting display resolution / desktop size Robhogg SUSE / openSUSE 2 02-23-2006 09:16 PM
Setting up display resolution on HP zv 5000 laptop J--Lew Linux - Newbie 2 10-13-2005 09:36 PM
Dual head display problem and setting resolution Navyblue Linux - Newbie 4 08-01-2005 11:18 AM
Setting the highest display resolution artemis Fedora 3 06-16-2004 03:32 AM


All times are GMT -5. The time now is 12:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration