LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-28-2002, 11:32 PM   #1
freezinbutt
Member
 
Registered: Mar 2002
Location: Fairbanks, Alaska
Distribution: Ubuntu 9.04
Posts: 55

Rep: Reputation: 15
Setting a default browser


Does anyone know how to set a default browser in Mandrake 8.2 using KDE. I would like Konquorer to be the default. When I used Evolution to get mail and someone sends me a hyperlink, it opens up in Mozilla. I like Mozilla but would still like to know how to change this.

Thanks,
freezinbutt
 
Old 03-29-2002, 12:14 AM   #2
aaronsols
Member
 
Registered: Feb 2002
Location: INDIA
Distribution: Red Hat
Posts: 30

Rep: Reputation: 15
hi freeze

I hope this procedure helps

1.start control center
2.expand file browsing
3.clik on file associations
4. on the right side of tha pane u see a set of file types
5. expand text
6. choose html
7. on the right, in the "Application preference order" choose your browser,move konqueror to the top , if it is not listed clik add to be displayed in the list re-order it,

in all probabilites Konqueror is present by deafult, apply the changes

Thats it...
 
Old 03-29-2002, 12:37 AM   #3
freezinbutt
Member
 
Registered: Mar 2002
Location: Fairbanks, Alaska
Distribution: Ubuntu 9.04
Posts: 55

Original Poster
Rep: Reputation: 15
Tried it. No luck.

Thanks for the reply Aaron.

I did exactly as you said. Konqueror was already at the top of the list so I hit apply anyway (just to make sure). I went back to Evolution and clicked on an email hyperlink but it still opened up Mozilla. I think it must be one of the settings in Evolution, but for the life of me I can't find it. I've poked around in the help files for Evolution but I can't find anything there either. I'm convinced that it is something really simple. I'm famous for that. If it is right in front of me, I won't see it. If you make it hard, I can usually figure it out.

Any other ideas would be appreciated.
freezinbutt
 
Old 03-29-2002, 08:50 PM   #4
Sixpax
Member
 
Registered: Mar 2002
Distribution: Mandrake 8.1
Posts: 386

Rep: Reputation: 30
What do you get when you type "echo $BROWSER" ??
 
Old 03-29-2002, 09:11 PM   #5
freezinbutt
Member
 
Registered: Mar 2002
Location: Fairbanks, Alaska
Distribution: Ubuntu 9.04
Posts: 55

Original Poster
Rep: Reputation: 15
It says:

kfmclient openProfile webbrowsing

freezinbutt
 
Old 03-29-2002, 09:39 PM   #6
Sixpax
Member
 
Registered: Mar 2002
Distribution: Mandrake 8.1
Posts: 386

Rep: Reputation: 30
What do you get when you run "grep BROWSER /etc/X11/Xsession" ?
 
Old 03-29-2002, 10:07 PM   #7
freezinbutt
Member
 
Registered: Mar 2002
Location: Fairbanks, Alaska
Distribution: Ubuntu 9.04
Posts: 55

Original Poster
Rep: Reputation: 15
I get this:

if [ -z "BROWSER" ] ; then
BROWSER=`which mozilla`
if [ -z "$BROWSER" ] || [ ! -e "$BROWSER" ] ; then
BROWSER=
if [ -z "$BROWSER" ] ; then
BROWSER=`which netscape`
if [ -z "$BROWSER" ] || [ ! -e "$BROWSER" ] ; then
BROWSER=
if [ -z "$BROWSER" ] ; then
BROWSER=`which lynx`
if [ -z "$BROWSER" ] || [ ! -e "$BROWSER" ] ; then
BROWSER=
BROWSER="xvt -e lynx"
export BROWSER
export HELP_BROWSER="$BROWSER"
if [ -x "$BROWSER" -a -f /usr/doc/HTML/index.html ]; then
$BROWSER /usr/share/doc/HTML/index.html &


It's all Greek to me, but that's what it says.
freezinbutt
 
Old 03-29-2002, 10:48 PM   #8
Sixpax
Member
 
Registered: Mar 2002
Distribution: Mandrake 8.1
Posts: 386

Rep: Reputation: 30
Hmm... I may be barking up the wrong tree here. Have you tried going into konqueror and seeing if there's a setting to make it the default browser?

If not, just for grins, edit /etc/X11/Xsession and add a line that says:

BROWSER=`which konqueror`

above the first line that reads: if [ -z "BROWSER" ] ; then

don't worry about all the other mess.
 
Old 03-29-2002, 10:59 PM   #9
freezinbutt
Member
 
Registered: Mar 2002
Location: Fairbanks, Alaska
Distribution: Ubuntu 9.04
Posts: 55

Original Poster
Rep: Reputation: 15
If there is something in Konqueror to set it as default, I sure can't find it. I have also looked for a setting in Evolution but no luck. I will try to edit the file as you said and I'll see if that works. I'll let you know. Thanks a lot.

freezinbutt
 
Old 03-29-2002, 11:18 PM   #10
Sixpax
Member
 
Registered: Mar 2002
Distribution: Mandrake 8.1
Posts: 386

Rep: Reputation: 30
a quick way to tell if Evolution is using your $BROWSER variable is to run "$BROWSER http://www.google.com" from the command line and see if you get the same one as when you click on the links.
 
Old 03-29-2002, 11:30 PM   #11
freezinbutt
Member
 
Registered: Mar 2002
Location: Fairbanks, Alaska
Distribution: Ubuntu 9.04
Posts: 55

Original Poster
Rep: Reputation: 15
When I did that, it opened up the Google site in Konquorer, not Mozilla.

If I need to edit the file we were talking about earlier, could you give me some instructions on how to do that. I thought I could do it on my own, but I'm getting nowhere. I've got my nose in one of my books now, trying to figure it out. I'm so new to Linux that all of this is a bit overwhelming. I have a long way to go with learning the command line and editing files.

Thanks,
freezinbutt
 
Old 03-30-2002, 12:31 AM   #12
Sixpax
Member
 
Registered: Mar 2002
Distribution: Mandrake 8.1
Posts: 386

Rep: Reputation: 30
If konqueror came up when you typed that, then there's no point in editing the file I showed you. I guess I was barking up the wrong tree

I'll look a bit deeper to see if I can find out why you are getting mozilla when you click on a link.
 
Old 03-30-2002, 12:33 AM   #13
freezinbutt
Member
 
Registered: Mar 2002
Location: Fairbanks, Alaska
Distribution: Ubuntu 9.04
Posts: 55

Original Poster
Rep: Reputation: 15
Well, I've been clicking around and trying different things for over an hour now. I'm getting nothing here. I will have to wait until you guys come up with something. I tried the Evolution web site again, but I can't find anything.

freezinbutt
 
Old 03-30-2002, 01:06 AM   #14
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Try checking the options in the gnome control center, do "gnomecc" to start it up in kde, if it takes over your background just restart the X server.
 
Old 03-30-2002, 01:17 AM   #15
freezinbutt
Member
 
Registered: Mar 2002
Location: Fairbanks, Alaska
Distribution: Ubuntu 9.04
Posts: 55

Original Poster
Rep: Reputation: 15
That's it!!!

Thanks Aussie. That did the trick. Now when I click on a link, it opens up in Konqueror.

Thanks to everybody for all your help. You guys are great.

freezinbutt
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
setting a default browser imagineaxion Mandriva 12 01-07-2005 12:16 AM
Setting default browser (and other defaults?) ToothlessRebel Linux - Newbie 2 07-22-2004 06:20 PM
setting default browser? tombomb300 Linux - Software 1 10-19-2003 07:14 PM
Setting Mozilla as Default Browser Witch-King Linux - Software 21 06-10-2003 11:44 PM
Default browser setting... Chijtska Linux - Networking 0 01-31-2002 07:38 PM


All times are GMT -5. The time now is 06:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration