LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-27-2007, 04:51 AM   #1
harisankar98
LQ Newbie
 
Registered: Dec 2007
Posts: 5

Rep: Reputation: 0
setgid:operation not permitted .. pls help me..


Hey..
I was so foolish to do this... My friend gave me his hard disk to partition it.. I did that and plugged it into ma system for copying some files...
After mounting a drive, I tried changing the permissions of that drive using "chmod 777 -R /media/1 " ( that drive mounted at /media/1)

But seeing it was taking a long time, I exited the console and shut down the system..

Now, I am not able to 'su'... it gives the setgid error..
I cant login as root...
I checked the content of /var/log/auth.log

It says at one point ,

Dec 26 15:26:48 debian su[2946]: Successful su for root by hari
Dec 26 15:26:48 debian su[2946]: + pts/5 hari:root
Dec 26 15:26:48 debian su[2946]: bad group ID `0' for user `root': Operation not
permitted



What should I do now????????
 
Old 12-27-2007, 05:09 AM   #2
deepumnit
Member
 
Registered: Dec 2006
Location: NOIDA, India
Distribution: Debian, SUSE, Fedora
Posts: 334
Blog Entries: 1

Rep: Reputation: 31
Dude, before mounting the HDD, were you root? I mean, did you mount the HDD as root? The permissions would have been st accordingly. How many files did the HDD have? When you use <chmod> on a directory or on an entire drive, it takes some time. Again, this depends on the number of files that are on your HDD. You should not have stopped the process. Anyway, this is not a matter of concern. BTW, I thing you were trying to do some operation which is not permitted for users other than root.
One more thing, you cannot login as root on Debian, as it does not allow it. But this can be overcome by logging in via the terminal by removing the temporary file "/tmp/.X0-lock" - something like that. You can also do this: Goto Desktop->Administration->Users and Groups and then change the permissions for users regarding the mounting etc.
 
Old 12-27-2007, 05:58 AM   #3
oskar
Senior Member
 
Registered: Feb 2006
Location: Austria
Distribution: Ubuntu 12.10
Posts: 1,142

Rep: Reputation: 49
I don't quite get it... so you mounted it and copied some files to the drive, so you already had access. Why did you need to chmod it?
Did you copy with root? If you do that you should use cp -p to preserve ownership.

Also, you can interrupt a process by pressing ctrl-c in the console... no need to shut down.
 
Old 12-27-2007, 08:56 AM   #4
harisankar98
LQ Newbie
 
Registered: Dec 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Hey....
I did something and got ma 'su' back.. but some problems are persisting..

What I did is.. I used the debian rescue disk.. rescue mode... then typed 'su'.. became root..
Then i did 'chown root:root /usr/bin/sudo'
then.. 'chmod 4755 /usr/bin/sudo'
then.. 'chmod 4755 /bin/su'

i dono anything abt chown.. i copy-pasted it from some blog...

Then.. I booted back to Debian... now I can use 'SU'..

But still I cannot Login as root either from KDM or from console...

it says login:root
login incorrect

????????

and I am not able to mount CDROM drive in NORMAL USER MODE... If i run konqueror as superuser.. then I can mount it...

Here is ma fstab

# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/sda5 / ext3 defaults,errors=remount-ro 0 1
/dev/sda7 /mnt/Music vfat defaults 0 0
/dev/sda8 /mnt/Soft vfat defaults 0 0
/dev/sda1 /mnt/Win vfat defaults 0 0
/dev/sda6 none swap sw 0 0
/dev/hdb /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
/dev/sda9 /mnt/New ntfs-3g rw,user,auto 0 0
 
Old 12-27-2007, 08:59 AM   #5
harisankar98
LQ Newbie
 
Registered: Dec 2007
Posts: 5

Original Poster
Rep: Reputation: 0
And Deepumnit.. earlier I was able to login into debian as root...

I dont have gnome installed... I got only KDE....
 
Old 12-27-2007, 09:02 AM   #6
harisankar98
LQ Newbie
 
Registered: Dec 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Oskar. thx for that ctrl+c..

I was not able to copy after mounting as normal user.. then used chmod using 'su'.. there was a big folder already on the drive which i copied using windows xp( me using dual boot).. so got tired of chmod and did tht foolishnes...

Anyway.. after that I formatted that partition.. its permissions are hence not a concern for me..
 
Old 12-27-2007, 11:45 PM   #7
harisankar98
LQ Newbie
 
Registered: Dec 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Hey..No one to help me on the 'mount' issue?? and the root login problem??

Deepu.. I tried deleting the 'lock' file.. still the problem persists...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"setgid:Operation not permitted" after shadow install proRandom Linux From Scratch 3 10-21-2010 11:48 PM
setgid: operation not permitted Johnburrell Linux From Scratch 10 03-07-2010 06:03 AM
Operation not permitted jakkals Linux - General 3 09-26-2005 08:30 PM
operation not permitted jamaso Slackware 2 05-08-2004 06:55 AM
Operation not permitted FrozenShadow23 Linux - Newbie 6 10-05-2003 06:13 PM


All times are GMT -5. The time now is 04:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration