LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-07-2008, 03:07 PM   #1
Henry777
LQ Newbie
 
Registered: Oct 2007
Posts: 4
Blog Entries: 1

Rep: Reputation: 0
Set up Red Hat Linux Fedora Core 4 fine, initially but. . .


Good Day all my Linux Guru friends

I am relatively new to Linux. I have installed Redhat Linux Fedora Core 4, as a server, linked on a network, with Windows machines as clients. Now that was not really because I wanted to, but because I had to, due to the fact that I need to do it as one final subject for my University studies. Not that that fact is not allowing me to like the O.S. However, now for the problem.

I have set up the O.S., working wonderfully, earlier. I had no problem watsoever. Then I didn't use the server for a while and whalla!!! no ping to my ADSL router, only pinging the Network Card, i.e. 127.0.0.1. I have changed network cables, in case the cable might have been the problem, but the problem still persists.

The only change that I can think of is, the fact that I have enabled port forwarding on the ADSL Router. How can I go about getting at least my server communicating with my ADSL Router again. without having to reset my ADSL Router to factory settings again? Previously I have changed from a static IP address, to automatically obtaining an IP address through DHCP and everything worked fine. Now neither works. Any suggestions please?

Greetings,
Yours faithfully
 
Old 07-07-2008, 04:04 PM   #2
j-ray
Senior Member
 
Registered: Jan 2002
Location: germany
Distribution: ubuntu
Posts: 1,532

Rep: Reputation: 132Reputation: 132
depending on the desktop you are using there are different tools available to set the default gateway=ip of your router. Probably this is using a different netmask...but you may know the ip of the router...
You can edit /etc/resolv.conf manually to enter a line like
nameserver 192.168.2.111
(at best with the right address;-])

hope this helps, good luck, j.

Last edited by j-ray; 07-07-2008 at 04:08 PM.
 
Old 07-07-2008, 04:13 PM   #3
kenoshi
Member
 
Registered: Sep 2007
Location: SF Bay Area, CA
Distribution: CentOS, SLES 10+, RHEL 3+, Debian Sarge
Posts: 159

Rep: Reputation: 32
Did you try pinging to/from other machines on your internal network?

Is eth0 properly listed when you run ifconfig from shell?

If its on DHCP, try running:

dhclient -r

Or:

service network restart

Or

ifconfig eth0 down
ifconfig eth0 up

Hope this helps.
 
Old 07-08-2008, 03:39 PM   #4
Henry777
LQ Newbie
 
Registered: Oct 2007
Posts: 4
Blog Entries: 1

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by j-ray View Post
depending on the desktop you are using there are different tools available to set the default gateway=ip of your router. Probably this is using a different netmask...but you may know the ip of the router...
You can edit /etc/resolv.conf manually to enter a line like
nameserver 192.168.2.111
(at best with the right address;-])

hope this helps, good luck, j.
Hi J-Ray,
Thanks, I'll try that. The desktop I'm running is KDE. When I run ifconfig, it only lists the loopback address, for eth0. Oh yes, I have also exchanged Monitors in the mean time. The fact that I have turned IP forwarding "on" on the router should those two changes make a difference?

Regards,
Henry777

Last edited by Henry777; 07-08-2008 at 03:43 PM.
 
Old 07-08-2008, 03:40 PM   #5
Henry777
LQ Newbie
 
Registered: Oct 2007
Posts: 4
Blog Entries: 1

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by kenoshi View Post
Did you try pinging to/from other machines on your internal network?

Is eth0 properly listed when you run ifconfig from shell?

If its on DHCP, try running:

dhclient -r

Or:

service network restart

Or

ifconfig eth0 down
ifconfig eth0 up

Hope this helps.
Hi Kenoshi,
No, I can't ping the server from the other machines. They respectively can ping the router, yes.

Regards
Henry777
 
Old 07-08-2008, 03:47 PM   #6
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally Posted by Henry777 View Post
I have installed Redhat Linux Fedora Core 4
Firstly, it's just called Fedora Core. Secondly, Fedora Core 4 is no longer supported and you'd be better off installing the newest version.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Red Hat Linux Fedora Core 4 Henry777 Linux - Software 1 10-24-2007 01:16 PM
LXer: Red Hat to Buy JBoss for About $350 Million Initially LXer Syndicated Linux News 0 04-10-2006 12:03 PM
Red Hat Linux Fedora Core 2 Installation ROXCIE Fedora - Installation 3 09-21-2005 03:58 PM
How do I establish a modem connection using Red Hat Linux Fedora Core 1? jlowe799 Fedora 1 07-28-2004 05:31 AM


All times are GMT -5. The time now is 08:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration