LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-02-2008, 06:22 PM   #1
foolio1990
LQ Newbie
 
Registered: Sep 2008
Distribution: Slackware 12.1, Ubuntu 8.04
Posts: 19

Rep: Reputation: 0
Set up my network, configured firefox for my proxy, still no internet browsing!


Hi, new to the forums here. I have a problem that is probably really simple to fix, but I can't seem to figure it out! I've done the things that I think have been necessary, I will list them:

1. I ran through netconfig and got that all set up.
2. I went in to FireFox and set up my manual proxy settings (we have to do that for our network, lots of computers)
3. I am able to ping other computers and the gateway on my network, so I don't think it is a hardware problem, or a network communication problem

So assuming I did those things correctly, what else could possibly be the problem? Thanks in advance.
 
Old 09-02-2008, 06:28 PM   #2
elprawn
Member
 
Registered: Feb 2005
Distribution: Gentoo 2008
Posts: 138

Rep: Reputation: 15
Did you set your default gateway?

e.g.

route add default gw 192.168.2.1 eth0
 
Old 09-02-2008, 06:35 PM   #3
henry_shadowjet
Member
 
Registered: Oct 2006
Posts: 55

Rep: Reputation: 15
hi there,

I'm no expert either, but as above, if you have already set the gateway correctly, then try tracert-ing your request.

As root, issue the following command (for example):
tracert www.google.com.au

From there you may be able tell if the computer is requesting through the correct path.

Another possibility, I think, could be the DNS. You should be able to do it by editing /etc/resolv.conf (at least in Fedora series that's what it is).

Good luck!
 
Old 09-02-2008, 06:36 PM   #4
foolio1990
LQ Newbie
 
Registered: Sep 2008
Distribution: Slackware 12.1, Ubuntu 8.04
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by elprawn View Post
Did you set your default gateway?

e.g.

route add default gw 192.168.2.1 eth0
Ummm.... I don't think I did, didn't think I had to. Don't know how. Can you tell me how to do that? Thanks.
 
Old 09-02-2008, 06:50 PM   #5
elprawn
Member
 
Registered: Feb 2005
Distribution: Gentoo 2008
Posts: 138

Rep: Reputation: 15
route add default gw 192.168.2.1 eth0

Replace the ip address with the ip address of your default gateway, which is typically x.y.z.1, where x, y and z are the first 3 parts of your LAN IP.
 
Old 09-02-2008, 06:54 PM   #6
foolio1990
LQ Newbie
 
Registered: Sep 2008
Distribution: Slackware 12.1, Ubuntu 8.04
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by elprawn View Post
route add default gw 192.168.2.1 eth0

Replace the ip address with the ip address of your default gateway, which is typically x.y.z.1, where x, y and z are the first 3 parts of your LAN IP.
I'm gonna try all of this advice tomorrow. Thanks Everyone!
 
Old 09-02-2008, 07:51 PM   #7
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,108
Blog Entries: 3

Rep: Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402
Hi,

If you ran 'netconfig' and provided a gateway IP then your kernel route table should be setup. Post the output of 'route -n' and your '/etc/rc.d/rc.inet1.conf'.

By chance did you ping outside your LAN? Name or IP?

I like to check my systems by;

Code:
~#ping 64.233.187.99      #googles IP
~#ping google.com
That way you are checking that your DNS is setup properly. Check your '/etc/resolv.conf' for the DNS that your ISP provides. I like to add a third level DNS;

Code:
sample '/etc/resolv.conf';

search 192.168.1.1  

nameserver 207.179.200.2
nameserver 207.179.200.25
nameserver 207.179.200.10
nameserver 4.2.2.1         #verizon third level DNS
nameserver 4.2.2.2
nameserver 4.2.2.3
nameserver 4.2.2.4
 
Old 09-02-2008, 08:37 PM   #8
foolio1990
LQ Newbie
 
Registered: Sep 2008
Distribution: Slackware 12.1, Ubuntu 8.04
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by onebuck View Post
Hi,

If you ran 'netconfig' and provided a gateway IP then your kernel route table should be setup. Post the output of 'route -n' and your '/etc/rc.d/rc.inet1.conf'.

By chance did you ping outside your LAN? Name or IP?

I like to check my systems by;

Code:
~#ping 64.233.187.99      #googles IP
~#ping google.com
That way you are checking that your DNS is setup properly. Check your '/etc/resolv.conf' for the DNS that your ISP provides. I like to add a third level DNS;

Code:
sample '/etc/resolv.conf';

search 192.168.1.1  

nameserver 207.179.200.2
nameserver 207.179.200.25
nameserver 207.179.200.10
nameserver 4.2.2.1         #verizon third level DNS
nameserver 4.2.2.2
nameserver 4.2.2.3
nameserver 4.2.2.4
I pinged my gateway, shouldn't that mean that if I can get to that, it would forward me to the internet (the gateway is set up correctly for sure)
 
Old 09-02-2008, 09:02 PM   #9
henry_shadowjet
Member
 
Registered: Oct 2006
Posts: 55

Rep: Reputation: 15
hey again,

Well, we can't be sure about that. But the previous post was indeed very informative and helpful, you should read into it carefully.

First try to ping Google's IP, if you get a response, next try to ping www.google.com.au

If you get both responses, then your internet should be virtually working.

I'm expecting you'll be stuck somewhere, but then again, nothing stops me from hoping for a miracle :P
 
Old 09-03-2008, 01:11 PM   #10
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,108
Blog Entries: 3

Rep: Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402Reputation: 1402
Hi,

If you can ping the gateway IP OK then try ping outside the gateway as I suggested. You can use the google IP (64.233.167.99) if that works then 'ping google.com'. If that works then your OK. If not then your DNS is not setup properly (/etc/resolv.conf). I posted a sample before.
 
Old 09-03-2008, 03:24 PM   #11
foolio1990
LQ Newbie
 
Registered: Sep 2008
Distribution: Slackware 12.1, Ubuntu 8.04
Posts: 19

Original Poster
Rep: Reputation: 0
I found out the problem, it was my nameserver! Thanks for all the suggestions leading me up to reconfiguring my network.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
IPCop - 1 network cannot surf internet unless proxy is enabled, other network can Micro420 Linux - Networking 0 08-25-2007 10:47 PM
Proxy server for Windows to Linux ->broadband Internet using two network cards teluguswan Linux - Networking 5 05-08-2007 09:16 AM
How to set the network proxy allelopath Linux - Desktop 1 01-09-2007 10:35 AM
How to set up Linux as a proxy server for internet access? Korshun Linux - Networking 1 04-04-2002 04:17 AM
how to set my licq, i connect to internet through a proxy server. dindindang Linux - General 3 11-29-2001 06:01 PM


All times are GMT -5. The time now is 11:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration