LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 01-04-2012, 03:22 PM   #1
nub
LQ Newbie
 
Registered: Jan 2012
Posts: 2

Rep: Reputation: Disabled
Set up a multiboot Linux / Windows with UEFI


Hello!

Since I've decided to give a trial to Linux I'm struggling to set up my Thinkpad W520 with UEFI/BIOS firmware both which I'd like to have multibooting with Win7 (via UEFI) as well as Slack64 v13.37.
I'd installed Win7 first and then booted and installed Slackware from DVDiso. However, installation always freezes when attempting to install the LILO boot loader. I've tried it with different options: superblock of root partition and MBR, both standard suggestions.
Yet, I'm new with Slackware and therefore I'm not sure if I've done everything properly. It'd have multiboot for I need to switch between both OS and I rather prefer to have it with UEFI, too, if possible.
Does anyone have experience with this issue, or any idea of a solution of my intent?
I'd be happy to have your advices. Thank you in advance!

nub
 
Old 01-04-2012, 03:40 PM   #2
dudeman41465
Member
 
Registered: Jun 2005
Location: Kentucky
Distribution: Ubuntu
Posts: 794

Rep: Reputation: 56
I've never used Slackware, but I haven't seen Lilo used in a couple of years, so if you have the option you may want to go with Grub. If the installer for Windows is failing, try booting from the CD and installing. Most modern Linux distros give you the option of resizing your Windows partition without losing your data.
 
Old 01-04-2012, 04:46 PM   #3
nub
LQ Newbie
 
Registered: Jan 2012
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thank you for your quick reply! Maybe I've not expressed myself fairly.
I already have Win7 running and it's doing fine. Only when trying to install Slackware (using a bootable DVD), the setup hangs up every time I attempt to configure the boot loader - which is LILO in this case. I've searched for Grub or Grub2 on the install dvd but I haven't found it; it might not be included with this distro. My hdd is divided into 6 primary partitions - sda1, fat16: 100 MB for the UEFI boot partition of Win7 (automatically set up during Win installation); sda2, btrfs: 25 GB for root; sda3, ntfs: 50 GB for Win7 system partition; swap, linux-swap; 12 GB; 2 other partitions are for data storage.
I hope I could clarify the problem. Thanks for your remarks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: UEFI and Windows 8: is this bad news for GNU/Linux? LXer Syndicated Linux News 0 11-03-2011 08:20 AM
Multiboot - installed Linux over Windows - now Linux won't boot - error 17 rrrssssss Linux - General 1 04-12-2008 08:06 AM
Trying to get a multiboot of Windows 98, XP, and Fedora Linux. sloik2000 Linux - Software 4 08-13-2004 09:58 AM
Solaris, Linux and Windows 2000 Multiboot on P4? ghaurisankar Linux - Software 1 08-04-2003 10:51 PM
can not multiboot linux with Windows XP fuzzylogix Linux - Newbie 2 02-27-2002 10:18 AM


All times are GMT -5. The time now is 10:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration