LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-05-2010, 08:59 PM   #1
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Rep: Reputation: 30
set timezone for nagios in ubuntu 9.10


so as the title says.

i saw this in nagios.cfg:

Code:
# TIMEZONE OFFSET
# This option is used to override the default timezone that this
# instance of Nagios runs in.  If not specified, Nagios will use
# the system configured timezone.
#
# NOTE: In order to display the correct timezone in the CGIs, you
# will also need to alter the Apache directives for the CGI path 
# to include your timezone.  Example:
#
#   <Directory "/usr/local/nagios/sbin/">
#      SetEnv TZ "Australia/Brisbane"
#      ...
#   </Directory>

#use_timezone=US/Mountain
#use_timezone=Australia/Brisbane
how to change it to Singapore timezone?

Last edited by Xanios; 08-05-2010 at 09:00 PM.
 
Old 08-06-2010, 02:57 AM   #2
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Quote:
Originally Posted by Xanios View Post
so as the title says.

i saw this in nagios.cfg:

Code:
# TIMEZONE OFFSET
# This option is used to override the default timezone that this
# instance of Nagios runs in.  If not specified, Nagios will use
# the system configured timezone.
#
# NOTE: In order to display the correct timezone in the CGIs, you
# will also need to alter the Apache directives for the CGI path 
# to include your timezone.  Example:
#
#   <Directory "/usr/local/nagios/sbin/">
#      SetEnv TZ "Australia/Brisbane"
#      ...
#   </Directory>

#use_timezone=US/Mountain
#use_timezone=Australia/Brisbane
how to change it to Singapore timezone?
Hi,

If your system timezone is set to your location (Singapore?) then Nagios will use that timezone. This option is only used if you have servers in different timezones as far as I know.

Kind regards,

Eric
 
Old 08-06-2010, 03:11 AM   #3
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
Hi,

i re-set the timezone for my ubuntu 9.10 to Singapore timing but still the time and date in nagios browser is not of Singapore.

Code:
sudo dpkg-reconfigure tzdata
 
Old 08-06-2010, 03:19 AM   #4
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

Have you restarted Nagios?

Kind regards,

Eric
 
Old 08-06-2010, 03:37 AM   #5
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
Hi,

Ya, it works now.

Thank you.


By the way, may i know how to use the above timezone offset ? Just curious.
 
Old 08-06-2010, 03:39 AM   #6
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

I've never used the timezone offset in Nagios for our servers since they're all in the same timezone. I know it exists and its function but never configured it.

If you consider your problem/question solved then please mark it as such using the Thread Tools.

Kind regards,

Eric
 
Old 08-06-2010, 03:44 AM   #7
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
Oh okay.

Marked it as solved already
 
Old 08-06-2010, 03:51 AM   #8
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

Fantastic, thanks.

Kind regards,

Eric
 
Old 06-20-2012, 04:18 AM   #9
lzecca
LQ Newbie
 
Registered: Jun 2012
Posts: 1

Rep: Reputation: Disabled
Even if i did the same operations, my nagios didn't change the mail Date/time Macros output (LONGDATETIME).
I solved this huge issue uncommenting the follow directive in the nagios.cfg:
time_change_threshold=90

Hope to be useful to someone that go crazy,
Bye, Luca
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
nagios in ubuntu 9.10 Xanios Linux - Newbie 12 07-26-2010 08:25 PM
LXer: Ubuntu 10.04: Check IMAP with Nagios LXer Syndicated Linux News 0 05-05-2010 08:30 AM
LXer: How to install Nagios in ubuntu 9.x and 10.04 LXer Syndicated Linux News 0 04-16-2010 02:40 AM
(re)set timezone mcisco Linux - Newbie 2 03-13-2009 08:56 AM
LXer: Install Nagios 3 on Ubuntu 8.10 LXer Syndicated Linux News 0 11-27-2008 07:30 AM


All times are GMT -5. The time now is 04:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration