LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-13-2003, 03:59 AM   #1
fireman949
Member
 
Registered: Dec 2003
Location: Walls
Distribution: Slackware 10.1;CentOS 4
Posts: 51

Rep: Reputation: 15
Set resolution too high, can't even login on RH9


Well, everything was going great, I was learning the better parts of using linux and I come to this great item called "Display" I figured, ok, I can get some more screen realestate on my 17" flat panel by setting my resolution higher. As soon as I logged out of RH9 to reset it to my new chosen resolution of 1920x1440 I see an "out of frequency" message on my gateway FP. So I try to login as quick as I can and reset the resolution before the timer (OSD) reaches -0- but I was too late. Now I can't even get in to fix anything. I remember that before I cut out, I enabled telnet ( though I haven't been able to telnet in from my w2kserver box), and ftp is enabled though I haven't set anything up (other than default install).
I'm hoping there is a way to bypass the GUI login or get to the shell without going through the GUI. Any help?

If I can get to the shell without the GUI, where do I go to change my default resolution.

I am running RH9.

Thanks in advance for the help.

Should have stayed with 1280x1024

-note to self, quit playing when your head starts hitting the keyboard due to lack of sleep.

-fireman

Last edited by fireman949; 12-13-2003 at 04:02 AM.
 
Old 12-13-2003, 04:23 AM   #2
MartinN
Member
 
Registered: Nov 2003
Location: Ronneby, Sweden
Posts: 555

Rep: Reputation: 30
Hi fireman!

No worries. This can be fixed. There is a way that this can be fixed by adding commands to the boot-loader. But then we need to know what boot-loader you are using. What does the first Linux screen say? Lilo or Grub?

Or we can fix it by using the rescue mode. Do you have a Linux rescue floppy or your installation CD available?

Regards
Martin
 
Old 12-13-2003, 04:33 AM   #3
fireman949
Member
 
Registered: Dec 2003
Location: Walls
Distribution: Slackware 10.1;CentOS 4
Posts: 51

Original Poster
Rep: Reputation: 15
sorry, it's late ... er.. early...
I am using GRUB as a bootloader,
and if I remember correctly I did make a boot disk and it's sitting on my desk.
 
Old 12-13-2003, 04:55 AM   #4
MartinN
Member
 
Registered: Nov 2003
Location: Ronneby, Sweden
Posts: 555

Rep: Reputation: 30
One thing just came to my mind. If you boot to the point where your screen shuts down. Then press <CTRL>-<ALT>-F2. Do you get a to a text login then?

If you don't, boot with the rescue floppy. When you get to the prompt, type linux init 3 and boot. You might get a Kudzu screen (the new hardware detection program). Just ignore that. Now you should get a text login, right?

When you've got a text login. List the files in /etc/X11. If you are lucky, there is a backup there that works. This command lists the relevant files
Code:
ls -l /etc/X11/XF*
What files do you see? The file that's at fault is XF86Config. Is there a .bak (or similar) file there?

Regards
Martin
 
Old 12-13-2003, 05:14 AM   #5
fireman949
Member
 
Registered: Dec 2003
Location: Walls
Distribution: Slackware 10.1;CentOS 4
Posts: 51

Original Poster
Rep: Reputation: 15
followed instructions however, [CTRL] + [ALT] + [F2] does nothing at the messed up screen, and when I load the boot disk with linux init 3, I get to a text login, but I get this error:
usb-uhci.c:interrupt staus 3, frame # $frame

and it repeats itself where $frame=a different # each time.

I have a M$ Wireless Desktop USB Keyboard/mouse connected thru an IOGear KVM. I have had minor issues with it in Linux, but nothing major and I switch often. I will plug a regular ps2 in and try it in the mean time....
 
Old 12-13-2003, 05:26 AM   #6
fireman949
Member
 
Registered: Dec 2003
Location: Walls
Distribution: Slackware 10.1;CentOS 4
Posts: 51

Original Poster
Rep: Reputation: 15
**update**
The USB keyboard was the issue. I was able to login after I connected a PS2 type keyboard. I moved XF86Config to XF86Config.bak and replaced it with XF86Config.backup. Rebooted without boot disk and was able to login via GUI. Thanks again for the help. Everything appears to be working correctly considering I'm posing this message from within RH.


definately a n00b

be sure to check out my home hosted website at www.wallsfiredept.org it's not Linux/Apache yet but that is the goal.

-fireman
 
Old 12-13-2003, 05:30 AM   #7
MartinN
Member
 
Registered: Nov 2003
Location: Ronneby, Sweden
Posts: 555

Rep: Reputation: 30
I have no idea about that problem. It seems your keyboard could be to blame, so if a PS/2 keyboard gets you to login, then do as follows:

o Log in as root

o List the files as described above. Make sure that you have an XF86Config file there. (It could possibly be XF86Config-4).

o Move away the broken file to a new name:
Code:
mv /etc/X11/XF86Config /etc/X11/XF86Config_fireman
o Now, make a new file with the RedHat config tool:
Code:
redhat-config-xfree86
o Make sure that you've got a new XF86Config file by listing the files again.

o Reboot (remove the floppy )

Good luck!
Martin
 
Old 12-13-2003, 03:32 PM   #8
fireman949
Member
 
Registered: Dec 2003
Location: Walls
Distribution: Slackware 10.1;CentOS 4
Posts: 51

Original Poster
Rep: Reputation: 15
Martin,
Thanks for your help, it seems that renaming the "broken" XF86Config and putting the XF86Config.backup in its place worked.

Would you still suggest that I run redhat-config-xfree86 or am I good to go? Everything appears to run just fine.

Again, thanks for helping a n00b!

-fireman
 
Old 12-13-2003, 05:18 PM   #9
MartinN
Member
 
Registered: Nov 2003
Location: Ronneby, Sweden
Posts: 555

Rep: Reputation: 30
You posted while I was typing my post

You don't need to run redhat-config-xfree86. With that tool, you could have started over and made yourself a new XF86Config. But now that you had a backup file, you don't need to.

Glad to hear that everything worked out fine for you. Oh, and -- make a copy of that working config file and keep it in another directory.

Regards
Martin
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
high resolution webcam ahz10 Linux - Hardware 6 05-24-2005 05:55 PM
Set the wrong resolution for my monitor and need to get back to old settings in RH9 gbaiocchi Linux - Newbie 2 09-30-2004 09:44 PM
Can't get high resolution in Slackware Algernon Linux - Newbie 7 08-06-2004 03:24 PM
High Resolution Timers swinchen Programming 2 07-22-2004 11:34 AM
High resolution on booting spank Linux - Newbie 4 08-26-2003 04:35 AM


All times are GMT -5. The time now is 04:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration