LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-10-2006, 06:22 AM   #1
anjanesh
Member
 
Registered: Sep 2004
Location: Navi Mumbai
Distribution: Ubuntu 12.04 64-bit
Posts: 230

Rep: Reputation: 30
service: command not found


I did service httpd status to check if I need to install Apache or not. I got this :
Code:
username@server [/]# service httpd status
-bash: service: command not found
username@server [/]#
How can there be no service on FC2 ? Im on SSH to a virtual dedicated server.
 
Old 05-10-2006, 06:51 AM   #2
vs_optimist
LQ Newbie
 
Registered: Mar 2006
Location: Ukraine
Distribution: FC5
Posts: 27

Rep: Reputation: 16
Try

Code:
username@server [/]# /sbin/service httpd status

Last edited by vs_optimist; 05-10-2006 at 06:53 AM.
 
Old 05-10-2006, 06:53 AM   #3
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Simple you used 'su' and not 'su -'....... please read 'man su' without the single quotemarks for the details.

When you use 'su' you inherit the users pathing, using 'su -' gives you (root) root's pathing. Try; /sbin/service httpd status
 
Old 05-23-2006, 11:37 AM   #4
anjanesh
Member
 
Registered: Sep 2004
Location: Navi Mumbai
Distribution: Ubuntu 12.04 64-bit
Posts: 230

Original Poster
Rep: Reputation: 30
Thanks - it worked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Restart services - 'service' command not found davee Linux - Newbie 9 03-16-2013 01:34 AM
service: command not found aap Linux - Newbie 8 01-06-2006 09:15 PM
-bash: service: command not found Labyrinth Slackware 1 05-12-2004 08:13 AM
Mailman - service not found pk21 Linux - General 3 09-27-2003 01:31 PM
telnet service not found tarballedtux Linux - Networking 1 12-31-2001 12:40 AM


All times are GMT -5. The time now is 02:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration