LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-27-2006, 06:13 PM   #1
destiny200
LQ Newbie
 
Registered: Nov 2005
Location: Minneapolis
Distribution: SUSE 10.0
Posts: 12

Rep: Reputation: 0
Server router modem internet connection


Looking for help in setting up my server as a router to provide internet connection to two other networked computors.
Am running SUSE 10.0 KDE desktop

Present setup
server = dhcp, and nfs one nic card and one internal modem. Nic internal and modem external to firewall.
Main and Laptop are both set up as dhcp clients with default gateway set to 10.8.8.6 and firewall off.

server:~ # route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.8.8.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
server:~ #

modem not connected
server:~ # ifconfig
eth0 Link encap:Ethernet HWaddr 00:04:75:9B:40:6C
inet addr:10.8.8.6 Bcast:10.8.8.255 Mask:255.255.255.0
inet6 addr: fe80::204:75ff:fe9b:406c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:371 errors:0 dropped:0 overruns:0 frame:0
TX packets:243 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:34457 (33.6 Kb) TX bytes:30881 (30.1 Kb)
Interrupt:11 Base address:0xc400

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:192 errors:0 dropped:0 overruns:0 frame:0
TX packets:192 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:15695 (15.3 Kb) TX bytes:15695 (15.3 Kb)

modem connected
server:~ # ifconfig
eth0 Link encap:Ethernet HWaddr 00:04:75:9B:40:6C
inet addr:10.8.8.6 Bcast:10.8.8.255 Mask:255.255.255.0
inet6 addr: fe80::204:75ff:fe9b:406c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:374 errors:0 dropped:0 overruns:0 frame:0
TX packets:260 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:34874 (34.0 Kb) TX bytes:32792 (32.0 Kb)
Interrupt:11 Base address:0xc400

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:192 errors:0 dropped:0 overruns:0 frame:0
TX packets:192 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:15695 (15.3 Kb) TX bytes:15695 (15.3 Kb)

modem0 Link encap:Point-to-Point Protocol
inet addr:208.160.33.123 P-t-P:216.17.87.116 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:3 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:66 (66.0 b) TX bytes:87 (87.0 b)

I have tried for a while to get this running with not much luck.
Thanks
Steven
 
Old 04-27-2006, 06:19 PM   #2
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
Have you tried using guidedog to help you set up the NAT rules? The basics of it are you want to route packets from eth0 to ppp0 (or whatever it says the connection is named).
 
Old 05-01-2006, 11:47 PM   #3
destiny200
LQ Newbie
 
Registered: Nov 2005
Location: Minneapolis
Distribution: SUSE 10.0
Posts: 12

Original Poster
Rep: Reputation: 0
Cool

Found the problem. In the firewall the FW_MASQ_DEV has to be set to modem0, the default setting of $FW_DEV_EXT does not work for the modem even though it is external to the firewall.
Steven
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
direct connection w/ a router/modem? microsoft/linux Linux - Networking 14 04-27-2006 01:52 AM
Strange internet connection problem modem vs router jamesgf Mandriva 13 02-11-2006 09:10 AM
no internet connection (cable, router) OpossumPetya Suse/Novell 5 01-02-2006 01:59 PM
Router - Internet connection Sun_Tsu Mandriva 2 11-29-2004 03:41 AM
Nic card -> cable internet modem no internet connection zeshan_b Mandriva 21 09-26-2004 11:48 AM


All times are GMT -5. The time now is 05:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration