LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-20-2009, 05:23 AM   #1
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,461
Blog Entries: 6

Rep: Reputation: 51
Server refused to allocate pty ??


I looked lots of LQ post regarding the error above but dint get it make system to work. In one of RHEL AS update 6 machine, Developer mistakenly deleted /etc/fstab entry. I did the entry manually by remounting when system was not coming up.Now I can see putty work but now it shows Errror:
Code:
Server refused to allocate pty
I checked with /etc/fstab entry for /dev/pts but that too dint work.
I can see only one pts open when i do finger command.
Restarted sshd and network but no Fix.
Anyone who gonna help me out?
 
Old 03-20-2009, 09:38 AM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,808

Rep: Reputation: 604Reputation: 604Reputation: 604Reputation: 604Reputation: 604Reputation: 604
Is /proc mounted? Is /sys?

Try:
Code:
/sbin/MAKEDEV pty
/sbin/MAKEDEV tty
(btw that was really easy to find in Google)
 
Old 03-20-2009, 10:24 AM   #3
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,461
Blog Entries: 6

Original Poster
Rep: Reputation: 51
Hey..I got it fixed this way:
Code:
#chmod 755 /dev/pts
#chown root:root /dev/pts
# mount -t devpts -o uid=0,gid=5,mode=620 devpts /dev/pts
#mount –a
Thanks anyway for the concern.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Server refused to allocate pty gizza23 Linux - General 1 05-16-2008 03:52 PM
Cannot SSH into SW10.2, (stock) kernel 2.6.13 - cannot allocate PTY Lachek Slackware 2 12-14-2005 10:42 AM
Server refused to allocate pty singying304 Linux - Networking 2 11-10-2005 12:52 PM
Server refused to allocate pty. stderr is not a tty - where are you? gaslq Linux - General 5 08-09-2004 05:40 AM
sshd, server refused to allocate pty restless Linux - Software 1 06-20-2004 07:47 AM


All times are GMT -5. The time now is 09:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration