LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-25-2003, 08:41 PM   #1
jrdioko
Member
 
Registered: Oct 2002
Distribution: Debian 6.0.2 (squeeze)
Posts: 944

Rep: Reputation: 30
Question Server assigned nameserver addresses


Hello.

I decided to create a new post with this question since the old question is buried on the second page of another thread. Rather than explaining my whole situation so far, I will jump straight to the point.

I am currently using Internet Explorer in Windows (until I can get Linux set up to successfully get online... at this point it will connect to my ISP but not send or receive any data after it is connected). In Explorer, if I go to Tools -> Internet Options -> Connections -> Settings... -> Properties -> Networking -> TCP/IP Settings I get the screen where my nameserver IPs are set up. There is a radio button marked "Server assigned IP addresses" which is selected, and I never had to type in any specific IPs for my ISPs nameserver. On pppsetup in Linux, there is a screen that asks for this specific IP. I am wondering if there is any way to let the server dynamically assign this IP, as it is doing under Internet Explorer. I'm not 100% sure that this is the cause of my problem but, either way, it is something that needs to be fixed. I appreciate your help.

-JMagi
 
Old 08-26-2003, 04:05 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,539

Rep: Reputation: 149Reputation: 149
Yes, it si possible. What you need to do is edit /etc/ppp/options and add 'usepeerdns' somewhere (as a separate line). Here's a full description of what does usepeerdns do (from 'man ppp'):
Quote:
usepeerdns
Ask the peer for up to 2 DNS server addresses. The
addresses supplied by the peer (if any) are passed
to the /etc/ppp/ip-up script in the environment
variables DNS1 and DNS2. In addition, pppd will
create an /etc/ppp/resolv.conf file containing one
or two nameserver lines with the address(es) sup_
plied by the peer.


 
Old 08-26-2003, 06:53 PM   #3
jrdioko
Member
 
Registered: Oct 2002
Distribution: Debian 6.0.2 (squeeze)
Posts: 944

Original Poster
Rep: Reputation: 30
I just typed up a reply and tried to submit it but I guess it didn't go through. Let's try again...

I tried adding that line to my /etc/ppp/options file but once again, I dialed up and went into Mozilla and it sat there for about 30 seconds and then gave me an error message. I thought maybe it was the old entry that was causing the problem so I deleted the nameserver line from my /etc/resolve.conf. This time, when I went into Mozilla, it gave me an error immediately that it could not find the page. Either way, no matter what I do with those files, it lets me dial up and connect successfully to my ISP, but after that I can't send or receive any data as far as I can tell. Mozilla won't let me browse pages and gaim won't connect. What is going on here? Any ideas are appreciated.

Thanks,
JMagi
 
Old 08-26-2003, 07:11 PM   #4
m0rl0ck
Member
 
Registered: Nov 2002
Distribution: A totally 133t distro :)
Posts: 358

Rep: Reputation: 31
See if you can use nslookup to resolve a name from a server you know works.
Try this:
nslookup
Note: nslookup is deprecated and may be removed from future releases.
Consider using the `dig' or `host' programs instead. Run nslookup with
the `-sil[ent]' option to prevent this message from appearing.
> server 66.181.100.36
Default server: 66.181.100.36
Address: 66.181.100.36#53
> cnet.com
Server: 66.181.100.36
Address: 66.181.100.36#53

Non-authoritative answer:
Name: cnet.com
Address: 206.16.0.148

That is, type nslookup at a prompt, hit enter, then type " server 66.181.100.36" hit enter, then type "cnet.com" and hit enter.
What do you get?
 
Old 08-26-2003, 08:25 PM   #5
jrdioko
Member
 
Registered: Oct 2002
Distribution: Debian 6.0.2 (squeeze)
Posts: 944

Original Poster
Rep: Reputation: 30
Thank you for your prompt response. I did exactly what you did and got the exact same output. What next?

Now do I need to put that nameserver line back in my resolve.conf file or does it not need to be there with the usepeerdns line in my options file. Now as both root and my normal user Mozilla immediately gives you the error that it could not find www.google.com as soon as it opens and gaim tells you it could not log on as soon as the program starts. Its like it sees that the nameserver isn't there and doesn't bother trying. Let me know what to try next.

Thanks,
JMagi
 
Old 10-03-2003, 04:15 AM   #6
maxheadroom
LQ Newbie
 
Registered: Oct 2003
Location: Texas
Distribution: Slackware 9.1
Posts: 6

Rep: Reputation: 0
same issue in 9.1 as well, and in Vector Linux 4(slack derived)

I had the same issue. It didn't happen under 8.1 but when I went to 9.0 and then 9.1 I couldn't get dynamic DNS working. I read in like a Debian devel mailing list something about kppp not using ip-up or /etc/resolv.conf to set up it's dynamic dns and that's why kppp works. For some reason ip-up doesn't set the dns in /etc/resolv.conf. At any rate, I figured a work around.

Like Mara said, you have to add usepeerdns to your /etc/ppp/options file. I added it to /etc/ppp/options.demand as well. I put it in right after ipdefault for both(don't think it matters, just giving you all details in case it doesn't work for you).

type ppp-go as root

This will get 2 DNS entries from the ISP and store them in /etc/ppp/resolv.conf - this is just setting up the file

type ppp-stop
then cd /etc
rm resolv.conf
ln -s /etc/ppp/resolve.conf

then type ppp-go and all should work again



maxheadroom
 
Old 10-03-2003, 06:10 PM   #7
jrdioko
Member
 
Registered: Oct 2002
Distribution: Debian 6.0.2 (squeeze)
Posts: 944

Original Poster
Rep: Reputation: 30
Thank you, thank you, thank you! The command was "ln -s /etc/ppp/resolv.conf" without the 'e', but I am posting this message from Linux... finally!

Now I have to decide if I am willing to take the plunge and switch over to Linux completely. Decisions... decisions...

Thanks again, I appreciate your help,
JMagi
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DHCP Server MAC Address found, IP address not assigned wmburke Linux - Wireless Networking 17 11-17-2004 11:33 AM
bind 2 ip addresses to the server txm123 Linux - Newbie 2 11-08-2004 01:31 PM
UDP server with socket listening on all IP addresses XTF Programming 0 06-04-2004 04:19 PM
DHCP server delivers addresses in reverse order sagif Linux - Networking 3 02-14-2004 01:47 PM
Assigning IP addresses to game server processes jader9920 Linux - Networking 3 12-28-2003 03:32 PM


All times are GMT -5. The time now is 11:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration