LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-17-2010, 01:23 AM   #1
vishwaadiga
LQ Newbie
 
Registered: Dec 2009
Posts: 20

Rep: Reputation: 0
Server


I have installed RHEL 4.6.
But X server is not running.
Wen i executed xclock
Error: Can't open display: hostnmae:0.0
 
Old 02-17-2010, 01:34 AM   #2
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Rep: Reputation: 55
Hi vishwaadiga,

Pls give us more info.
How you are accessing your RHEL 4.6 ? Through Putty, vnc ?

If you are accessing thro putty, you can't run xclock. If you are accessing thro VNC, yes u can.

Confirm weather ur X-server is up
Code:
ps -e | grep Xorg
If X-server is not up and running try
Code:
# startx
Also you can try setting display variable
Code:
export DISPLAY=0:0.

Last edited by vinaytp; 02-17-2010 at 01:35 AM.
 
Old 02-17-2010, 03:37 AM   #3
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
When you say X server is not running, how do you expect to run X application?
 
Old 02-17-2010, 07:12 PM   #4
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,329

Rep: Reputation: 2364Reputation: 2364Reputation: 2364Reputation: 2364Reputation: 2364Reputation: 2364Reputation: 2364Reputation: 2364Reputation: 2364Reputation: 2364Reputation: 2364
Also, why 4.6? The latest 4.x is 4.8 and the latest latest is 5.4
 
Old 02-17-2010, 08:41 PM   #5
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 18,611

Rep: Reputation: 4064Reputation: 4064Reputation: 4064Reputation: 4064Reputation: 4064Reputation: 4064Reputation: 4064Reputation: 4064Reputation: 4064Reputation: 4064Reputation: 4064
Quote:
Originally Posted by vishwaadiga View Post
I have installed RHEL 4.6.
But X server is not running.
Wen i executed xclock
Error: Can't open display: hostnmae:0.0
If X isn't running, you will obviously not be able to run X apps. But you don't say whether you're running this on the console, or on a remote workstation.

The setting of the DISPLAY variable has been covered on here numerous times. If you're running it on a remote workstation, you'll have to have a working X setup on it first, able to run remote sessions. Again, been covered on here many times...do a search for it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to monitor web server, FTP server, Mail server and database server vodka33us Programming 1 06-16-2008 04:20 AM
best distrubition for nas server and p2p download server and web server geosko Linux - Distributions 8 10-13-2006 09:20 AM
How the DNS-server is connected to work of a web-server and a mail-server? ukrainet Linux - Newbie 2 01-10-2005 09:18 PM
can we configure a Linux server with mail server,file server and web server kumarx Linux - Newbie 5 09-09-2004 06:21 AM


All times are GMT -5. The time now is 07:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration