LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-01-2010, 02:36 PM   #1
l8perez
LQ Newbie
 
Registered: Dec 2010
Posts: 2

Rep: Reputation: 0
serial port configuration problem


Hi:

I have a minilinux that I being working on, the problem now is that the serial ports doesn’t seem to work (I have 4 serial ports).They don’t write or read.

I run the command setserial –g /dev/ttySx and it says that his IRQ are 3 or 4 (3 for ttyS0 and ttyS2 , 4 for ttyS1 and ttyS4)…but when I run the command: dmesg | grep ttyS the IRQ’s are 0 for ALL my serial ports… could be this the reason why my serial ports aren’t working right??? And if it is how can I solve the problem???

Hope someone could help me.

Greetings
 
Old 12-02-2010, 12:18 PM   #2
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: root
Distribution: Slackware & BSD
Posts: 1,617

Rep: Reputation: 442Reputation: 442Reputation: 442Reputation: 442Reputation: 442
Hi,

First we must know how things are doing right the hardware level. Please post here the output of following command:

Code:
--# /sbin/lspci -v

Last edited by malekmustaq; 12-02-2010 at 12:22 PM.
 
Old 12-10-2010, 08:21 AM   #3
l8perez
LQ Newbie
 
Registered: Dec 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Well I alredy solve the problem, but now another arise... how can I set the baud rate of my serial port??? Because when I set it to a 1200 the jumper setting changes and I need to stay with the previous configuration of the jumper.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] serial port configuration hda7 Linux - Software 4 10-01-2009 10:39 AM
Serial port configuration jlopes Linux - General 0 01-18-2007 07:02 AM
timedia 4 port serial port i/o card configuration binu_edl Linux - Hardware 0 03-09-2006 10:39 AM
serial port configuration zak_zeem Linux - Networking 4 09-09-2005 08:06 AM
serial port configuration AndyCanfield Linux - General 1 08-15-2003 05:23 AM


All times are GMT -5. The time now is 05:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration