LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-30-2003, 04:57 AM   #1
sjuerges
LQ Newbie
 
Registered: Nov 2003
Posts: 2

Rep: Reputation: 0
Sendmail Problem on SuSe 8.1


Hi folks,

and good morning from me.


I got the following problem, and after hours of reading manuals im finally desperate enough to ask for help ...

I have got a SuSe 8.1 Server with static ip.

I can send mails when im logged in via ssh, using pine.
When i try to send mails using smtp login, i get a "Relaying denied" error.

I got all the domain names that i want him to send email from in Sendmail CW and CG variables and i just cant sort out the problem.

Can any of you guys help ... ?

Thnx in advance
Sebastian
 
Old 11-30-2003, 04:39 PM   #2
Jinkzer
LQ Newbie
 
Registered: Jun 2003
Location: Stockholm Sweden
Distribution: Gentoo, Slackaware, Flux, KDE
Posts: 20

Rep: Reputation: 0
I don't use SUSE but I had a lot of problems with sendmail when I was setting it up on a slackwarebox. I did documentation about everything so this might help you too.

First, check in your /etc/mail/sendmail.cf file for the following entry.

Kaccess hash -T /etc/mail/access

What you need to find here is the path and the filename.

Edit the /etc/mail/access and add the following:

your.ip.net RELAY

ex.

192.168.40 RELAY

Then, create the hash

makemap hash /etc/mail/access < /etc/mail/access

Restart sendmail and try.
(/usr/sbin/sendmail -bd -q1h)

This only allow you to relay emails from your local network, if you want to relay emails from Internet I recommend that you take a look at "pop before smtp", there is some script out there, I havn't tested it.

Last edited by Jinkzer; 11-30-2003 at 04:40 PM.
 
Old 12-01-2003, 12:08 AM   #3
sjuerges
LQ Newbie
 
Registered: Nov 2003
Posts: 2

Original Poster
Rep: Reputation: 0
Wel after another day of reading and fidling i finally found the problem ...

edit linux.mc and edit the TRUSTED_AUTH_MECHS value ... now smtp auth works and everything is fine.

THNX @ Jinkzer for trying to help me, much appreciated.
I already did that (local mails working fine)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sendmail problem in Suse 9.2 delamatrix Suse/Novell 3 08-02-2005 04:10 PM
sendmail on Suse 8 schirayu Linux - Software 1 06-07-2005 03:15 AM
SuSe 9.1 Pro/Sendmail/Setup/Problem DataLore Linux - Software 0 08-10-2004 03:48 AM
problem processing sendmail.mc to sendmail.cf ...help... lucastic Linux - Networking 1 09-21-2003 10:08 AM
suse 8.1 postfix or sendmail adix Linux - General 0 08-25-2003 05:04 AM


All times are GMT -5. The time now is 09:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration