LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-26-2004, 10:11 AM   #1
sp!d3rm@n
LQ Newbie
 
Registered: Jul 2004
Distribution: Fedora C1, Redhat 9
Posts: 15

Rep: Reputation: 0
Sendmail on Fedora Core 1


I'm a linux n00b, or I wouldn't be posting in this board and I'd probably already know the answer to this question but here goes...

I have recently installed Fedora Core 1 on an intel box and sendmail has been configured by default. I've made some changes to my sendmail.mc file and merged with the sendmail.cf using the "m4 /etc/mail/sendmail.mc > /etc/mail/sendmail.cf" command. Restarted sendmail but mail does not leave the box?

I've tried the telnet port 25 and get the following error...
telnet: connect to address xxx.xxx.xxx.xxx: Connection refused
telnet: Unable to connect to remote host: Connection refused

Tried nmap...
nmap -sS -p 20-2550 xxx.xxx.xxx.xxx
(The 2526 ports scanned but not shown below are in state: closed)
PORT STATE SERVICE
21/tcp open ftp
22/tcp open ssh
80/tcp open http
111/tcp open rpcbind
443/tcp open https

And the smtp port doesn't seem to be open? Any thoughts as to why my sendmail isn't working? NOTE: IPCHAINS and all other firewall software is disabled from startup.

Thanks to all who have read this
 
Old 07-26-2004, 11:08 AM   #2
lildrummerboy
LQ Newbie
 
Registered: Jun 2004
Distribution: Fedora Core 1
Posts: 21

Rep: Reputation: 15
have you checked your mail logs? mail log, is located in /var/log/maillog or if you have gui linux then go to system tools -> system logs -> maillog(once you open system logs) I am a newb myself running sendmail on FC1, do you have anything in your ~/mailqueue? type mailq in terminal to find out...If you are trying to send from remote box, like some other place on your network you must add to your /etc/mail/access file...Do you have anything special in your sendmail.mc file? if you send from remote machines you also must change line in sendmail.mc from DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl, also you don't have to do "m4 /etc/mail/sendmail.mc > /etc/mail/sendmail.cf" if you restart sendmail via "service sendmail restart" it will recompile sendmail.cf for you anyways. Anyways I would love to help you out being that I know I had tons of trouble getting sendmail to work how I wanted it to, and could not have done it myself w/o lots of help from others. I think we just need a bit more information about your problem though.
 
Old 07-26-2004, 12:03 PM   #3
sp!d3rm@n
LQ Newbie
 
Registered: Jul 2004
Distribution: Fedora C1, Redhat 9
Posts: 15

Original Poster
Rep: Reputation: 0
DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl is included in my sendmail.mc file. I'm trying to relay all mail through my ISP's mail server.

I have the mail server setup like this in the sendmail.mc:
define(`SMART_HOST',`isp.mailserver.com')dnl

mailq creates the following result:
/var/spool/mqueue is empty
Total requests: 0


/etc/mail/access reads:
# by default we allow relaying from localhost...
localhost.localdomain RELAY
localhost RELAY
127.0.0.1 RELAY


Oh... and the logs read:
Jul 26 11:46:41 localhost sendmail[5731]: i6QFkff8005731: from=apache, size=504, class=0, nrcpts=1, msgid=<200407261546.i6QFkff8005731@localhost.localdomain>, relay=apache@
Jul 26 11:46:41 localhost sendmail[5733]: i6QFkfxl005733: from=<apache@localhost.localdomain>, size=743, class=0, nrcpts=1, msgid=<200407261546.i6QFkff8005731@localhost.loc
Jul 26 11:46:41 localhost sendmail[5731]: i6QFkff8005731: to=someguy@hotmail.com, ctladdr=apache (48/48), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30504, re
Jul 26 11:46:41 localhost sendmail[5735]: i6QFkfxl005733: to=<someguy@hotmail.com>, ctladdr=<apache@localhost.localdomain> (48/48), delay=00:00:00, xdelay=00:00:00, m
Jul 26 11:46:41 localhost sendmail[5735]: i6QFkfxl005733: i6QFkfxl005735: DSN: Data format error
Jul 26 11:46:42 localhost sendmail[5735]: i6QFkfxl005735: to=root, delay=00:00:01, xdelay=00:00:00, mailer=local, pri=31767, dsn=2.0.0, stat=Sent


Does this mean it's sending stuff to root? How do I access roots mailbox with mutt to verify?

Funny thing is this worked with Redhat 9? Does RH9 open up everything by default? Thank you very much for the direction, glad to hear I'm not the only one with sendmail problems Any additional thoughts?
 
Old 07-26-2004, 01:12 PM   #4
lildrummerboy
LQ Newbie
 
Registered: Jun 2004
Distribution: Fedora Core 1
Posts: 21

Rep: Reputation: 15
First if you have

DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl

you need to comment it out...

dnl # DAEMON_OPTIONS(`Port=smtp,Addr=127.0.0.1, Name=MTA')dnl

and add line



DAEMON_OPTIONS(`Port=smtp, Name=MTA')dnl

of course if you notice this line only takes out 127.0.0.1, so you could erase but I dont like to erase in case I want to ever go back to default configuration without searching online for it. anways...
that is why port isn't open, then if you run that same nmap from origanal post your port should be open...



as far as it being sent to root, It appears to be the case according to your log file the last line, so what you can do is check directly in /var/mail/root, or type mail in terminal and you can see if your message is in there, obviosly both these require you to be logged on as root.

it also looks like your trying to send email from apache, some web page you have set up? well if so you might, have to add apache to /etc/mail/trusted-users not positive on that though. and as far as fetching your mail with mutt I can't help you I use dovecot myself, because its simplicity. If you have mutt configured correctly and running I think you should have to just put your options in to evolution or you favorite mail client.

I think your problem though is not with FC1 but the version of sendmail, sendmail has tightened up on security to help users keep there mail servers from the clutches of spammers. Which I must say is a good thing once you get it running, but a pain in the neck if you are like me (a newb) trying to figure out how to correctly configure sendmail so it works. heh.

Last edited by lildrummerboy; 07-26-2004 at 01:14 PM.
 
Old 07-26-2004, 02:25 PM   #5
sp!d3rm@n
LQ Newbie
 
Registered: Jul 2004
Distribution: Fedora C1, Redhat 9
Posts: 15

Original Poster
Rep: Reputation: 0
FEATURE(masquerade_envelope)dnl
MASQUERADE_AS(`mydomain.com')dnl

Seemed to be the problems?

I also made a change to /etc/mail/trusted-users uncommenting the only line there. Thanks for all the technical/moral support, I think I have a better handle on Sendmail and it's configuration. nmap also shows the port as open now. Thanks a lot. hopefully this helps people trying to make PHP/Apache and Sendmail work together in the future
 
Old 07-28-2004, 08:15 PM   #6
cipix
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Rep: Reputation: 0
smtp 25 does not exist

I do a nmap localhost and I find out that ...

(The 1647 ports scanned but not shown below are in state: closed)
PORT STATE SERVICE
21/tcp open ftp
22/tcp open ssh
111/tcp open rpcbind
139/tcp open netbios-ssn
143/tcp open imap
199/tcp open smux
445/tcp open microsoft-ds
783/tcp open hp-alarm-mgr
993/tcp open imaps
1024/tcp open kdm
1025/tcp open NFS-or-IIS
3128/tcp open squid-http

port 25 is closed

I have fedora core 2
and
DAEMON_OPTIONS(`Port=smtp,Addr=192.168.0.10, Name=MTA')dnl
in my sendmail.mc

(that is a computer that connects from local network to the 192.168.0.1 mailserver)

anybody got any other ideeas why no smtpd is listening to 25 ?
thanx
 
Old 07-28-2004, 08:39 PM   #7
Nytehawk
LQ Newbie
 
Registered: Mar 2004
Location: Northern Virginia
Distribution: Fedora Core 2
Posts: 29

Rep: Reputation: 15
Try:
Code:
netstat -vat
to see if smtp is listening.

I had some problems with sendmail myself, here's what was discussed:

http://www.linuxquestions.org/questi...hreadid=164808

Hope something here helps.
 
Old 07-28-2004, 08:44 PM   #8
cipix
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Rep: Reputation: 0
smtp is not listening on 25

no, it seems that smtp is not even there ...

I don't get it, it's not that somethiing is blocking any port, it's that smtpd is not there...

the topic u gave me is about pop3 ,... it may help at a certain time, now im trying to set up smtp

any ideeas ?
 
Old 07-28-2004, 09:16 PM   #9
cipix
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Rep: Reputation: 0
shoot me :)

well, I actually set it up

inet_address should be set to all in main.cf, it's that simple
 
Old 07-29-2004, 11:33 AM   #10
lildrummerboy
LQ Newbie
 
Registered: Jun 2004
Distribution: Fedora Core 1
Posts: 21

Rep: Reputation: 15
you don't need smtpd, if you are using sendmail it does smtp if I am not mistaken, what you should do is change this

DAEMON_OPTIONS(`Port=smtp,Addr=192.168.0.10, Name=MTA')dnl
to this...
DAEMON_OPTIONS(`Port=smtp, Name=MTA')dnl

and then if you only want 192.168.0.10 to be able to send out mail or whatever reason that is there you can add them to ~/mail/access

if you are using FC2 I do believe that would be /etc/mail/access (thats what it is in 1) anyways just give this a try and see what comes up. I am a newb myself but I do think this should work for you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
switching from Sendmail to Postfix on Fedora Core 2 d3funct Linux - Software 1 04-07-2005 01:35 PM
dovecot , sendmail and fedora core 2 ScooterB Linux - Software 6 01-05-2005 12:38 PM
Fedora core release 2 Sendmail Configuration harish_neo Linux - Networking 4 10-20-2004 12:38 AM
Cannot send email out with Sendmail on Fedora Core 2 smaier Linux - Software 8 07-29-2004 03:19 PM
Sendmail on Fedora Core 2? carlosinfl Fedora 0 07-26-2004 11:35 PM


All times are GMT -5. The time now is 04:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration