LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-24-2009, 11:03 PM   #1
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,461
Blog Entries: 6

Rep: Reputation: 51
Sendmail not pumping efficiently??


I have setup a sendmail server and Client on the same RHEL Machine which should pump the mail at a certain speed from server to the Client. The RHEL MAchine is running on blade server.
Code:
cat /proc/cpuinfo | grep "processor" | wc -l
6
RAM = 16 GB



I tested the application in a simple RHEL MAchine (not on blades) and it was pumping mails at the rate of 100 mails on 4 sec.But the Systen which is on Blade ) is pumping very slowly at the rate of 100 mails per 1 min(:|}.
Can anyone help me with any settings to fix this.
My free -m says:

Code:
[root@bl07dl380g5 ~]# free -m
             total       used       free     shared    buffers     cached
Mem:          7972       6089       1883          0         81       5714
-/+ buffers/cache:        293       7679
Swap:         7103          0       7103
[root@bl07dl380g5 ~]#
Code:
[root@bcsia41 ~]# vmstat 1 4
procs -----------memory---------- ---swap-- -----io---- --system-- ----cpu----
 r  b   swpd   free   buff  cache   si   so    bi    bo   in    cs us sy id wa
 0  0      0 5025792 181988 9022220    0    0     1    32   39     8  0  0 100  0
 0  0      0 5025792 181988 9022220    0    0     0    48 1015  1487  0  0 100  0
 0  0      0 5025792 181988 9022220    0    0     0     0 1011  1525  0  0 100  0
 0  0      0 5025792 181992 9022216    0    0     0    36 1011  1495  0  0 100  0

Last edited by your_shadow03; 02-25-2009 at 04:20 AM.
 
Old 02-24-2009, 11:23 PM   #2
your_shadow03
Senior Member
 
Registered: Jun 2008
Location: Germany
Distribution: Slackware
Posts: 1,461
Blog Entries: 6

Original Poster
Rep: Reputation: 51
Can anyone explain me this:
Code:
[root@basic ~]# ps -auxf | grep -i sendmail
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.3/FAQ
root     22870  0.0  0.0 51076  688 pts/1    S+   09:17   0:00          \_ grep -i sendmail
root     14294  0.0  0.0 35012 2452 ?        Ss   Feb19   0:00 sendmail: accepting connections
smmsp    14303  0.0  0.0 27804 1896 ?        Ss   Feb19   0:00 sendmail: Queue runner@00:01:00 for /var/spool/clientmqueue
[root@bcsia41 ~]#
Code:
[root@basic ~]# cat /proc/14294/status
Name:   sendmail
State:  S (sleeping)
SleepAVG:       88%
Tgid:   14294
Pid:    14294
PPid:   1
TracerPid:      0
Uid:    0       0       0       0
Gid:    0       51      51      51
FDSize: 64
Groups: 51
VmSize:    35012 kB
VmLck:         0 kB
VmRSS:      2452 kB
VmData:     1388 kB
VmStk:       204 kB
VmExe:       717 kB
VmLib:      5795 kB
StaBrk: 552acf1000 kB
Brk:    552ad75000 kB
StaStk: 7fbffffd40 kB
Threads:        1
SigPnd: 0000000000000000
ShdPnd: 0000000000000000
SigBlk: 0000000000000000
SigIgn: 0000000000001006
SigCgt: 0000000180016201
CapInh: 0000000000000000
CapPrm: 00000000fffffeff
CapEff: 00000000fffffeff
[root@bcsia41 ~]#
What I can see everything fine but what could be possible reason of it behaving so ??

Last edited by your_shadow03; 02-25-2009 at 04:19 AM.
 
Old 02-25-2009, 10:59 AM   #3
mesiol
Member
 
Registered: Nov 2008
Location: Lower Saxony, Germany
Distribution: CentOS, RHEL, Solaris 10, AIX, HP-UX
Posts: 731

Rep: Reputation: 137Reputation: 137
Hi,

take a look at the queue specific parameters on sendmail.mc.

The most limiting factor from my experience is disk IO. Take a look at the systems IO behavior when delivering mail using iostat or sar.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Google is pumping $5.6 million into open source this summer LXer Syndicated Linux News 0 04-24-2008 02:30 AM
Updating Slackware More Efficiently Woodsman Slackware 12 12-22-2007 08:18 PM
Using filesystem efficiently ce124 Linux - Newbie 3 12-29-2006 10:38 PM
Multi Processor - How to utilize it efficiently? bence8810 Linux - General 6 10-15-2006 04:12 PM
How to use slapt-get efficiently? MX_Unforgiven Slackware 3 03-04-2006 03:38 PM


All times are GMT -5. The time now is 10:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration