LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-16-2008, 07:25 AM   #1
Linux_champ
LQ Newbie
 
Registered: Dec 2008
Posts: 3

Rep: Reputation: 0
sendmail in linux.


Hi All,

i am using mail command to send email but it is not working properly.can any1 help me please?

command --> mail -s "test" id@domain.com </u/mail.txt

in mail.txt i have written "this is a test email"

Now following is what i get in /var/log/maillog

Dec 16 22:01:56 test sendmail[17526]: mBGH1urM017526: from=root, size=43, class=0, nrcpts=1, msgid=<200812161701.mBGH1urM017526@test.domain.com>, relay=root@localhost
Dec 16 22:01:57 test sendmail[17527]: mBGH1uOq017527: from=<root@test.domain.com>, size=343, class=0, nrcpts=1, msgid=<200812161701.mBGH1urM017526@test.domain.com>, proto=ESMTP, daemon=MTA, relay=test.domain.com [127.0.0.1]
Dec 16 22:01:57 test sendmail[17526]: mBGH1urM017526: to=id@domain.com, ctladdr=root (0/0), delay=00:00:01, xdelay=00:00:01, mailer=relay, pri=30043, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (mBGH1uOq017527 Message accepted for delivery)
Dec 16 22:01:59 test sendmail[17529]: STARTTLS=client, relay=mx1.emailsrvr.com., version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Dec 16 22:02:00 test sendmail[17529]: mBGH1uOq017527: to=<id@domain.com>, delay=00:00:03, xdelay=00:00:03, mailer=esmtp, pri=120343, relay=mx1.emailsrvr.com. [66.216.118.81], dsn=5.1.8, stat=Service unavailable
Dec 16 22:02:00 test sendmail[17529]: mBGH1uOq017527: mBGH20Oq017529: DSN: Service unavailable
Dec 16 22:02:00 test sendmail[17529]: mBGH20Oq017529: to=<root@test.domain.com>, delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=31568, relay=test.domain.com. [192.168.0.86], dsn=4.0.0, stat=Deferred: Connection refused by test.domain.com.


i am unable to understand that y Service is unavailable. Sendmail service is up and running.

how can i fix this issue? where i am doing wrong...

Thanks,

Champ.
 
Old 12-18-2008, 12:10 AM   #2
shanecraddock@gmail.com
LQ Newbie
 
Registered: Dec 2008
Posts: 10

Rep: Reputation: 0
check your /etc/resolv.conf file and make sure it has proper name servers defined, then restart networking and sendmail
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sendmail config questions + Sendmail not reflecting changes to access db wbuik Linux - Networking 2 03-26-2009 06:02 AM
Sendmail ignores aliases with sendmail daemon stopped phavn Solaris / OpenSolaris 1 12-01-2008 03:50 PM
sendmail is not working & on $prompt the cmd sendmail hangs Pavan mahoorker Linux - Software 1 04-04-2006 04:57 PM
Sendmail - RunAsUser=sendmail:mail/What files to i have to change ForumKid Linux - Security 45 01-18-2002 12:47 PM


All times are GMT -5. The time now is 05:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration