LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 08-02-2009, 12:24 PM   #1
doru
Member
 
Registered: Sep 2008
Distribution: Ubuntu 8.04 LTS Server
Posts: 84

Rep: Reputation: 16
sendmail does not hear from yahoo, gmail


I installed Fedora 11, text mode, Mail Server group included, and I tried to exchange e-mails with my accounts at yahoo.com and gmail.com. It does not work.

I am using mailx as a Mail User Agent (MUA) and sendmail as a Mail Transfer Agent (MTA), with default settings.

I can see, with tcpdump, tcp packets going to ...yahoo.com:smtp and google.com:smtp, but there is no response.

iptables: I tried iptables and tcpdump, and I believe that tcpdump listens outside iptables, that is, it sees packets after they leave and before they enter. Anyway, there are some iptables logs which show nothing.

Plese give me any idea, because I am stuck. I even read somewhere that it is possible that my ISP stops smtp connections, but I believe that this is not the case.

Thank you for your help.

Last edited by doru; 08-02-2009 at 12:29 PM. Reason: improve English
 
Old 08-02-2009, 12:41 PM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Slackware 14.0
Posts: 8,464

Rep: Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877
Any pointers in the logfiles ?
/var/log/...
Try to disable the firewall.
 
Old 08-02-2009, 12:56 PM   #3
doru
Member
 
Registered: Sep 2008
Distribution: Ubuntu 8.04 LTS Server
Posts: 84

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by repo View Post
Any pointers in the logfiles ?
/var/log/...
Try to disable the firewall.
/var/log/maillog says "Connection timed out".

My address is: root@localhost.localdomain, but still, yahoo should establish smtp connection.

I am reluctant to disable iptables, for security reasons. I hope I can verify other issues before I try this. On one hand, I believe that tcpdump sees outside iptables, so it should see any response. On the other hand, iptables is fairly complicated, maybe it does not identify smtp connections.
 
Old 08-02-2009, 01:10 PM   #4
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Slackware 14.0
Posts: 8,464

Rep: Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877
What is the output from
Code:
telnet smtp.google.com 25
 
Old 08-02-2009, 01:18 PM   #5
doru
Member
 
Registered: Sep 2008
Distribution: Ubuntu 8.04 LTS Server
Posts: 84

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by repo View Post
What is the output from
Code:
telnet smtp.google.com 25
I tried both mailx and telnet smtp.google.com 25, both with and without iptables active, and there is nothing but a deadly silence. telnet says:
Trying 74.125.45.25...
and there it dies. I hope 20s should be enough, to wait without iptables, for telnet?

Thanks for your help.
 
Old 08-02-2009, 01:21 PM   #6
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Slackware 14.0
Posts: 8,464

Rep: Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877
Seems to me port 25 outgoing is blocked.
Did you asked you provider ?
 
Old 08-02-2009, 01:27 PM   #7
doru
Member
 
Registered: Sep 2008
Distribution: Ubuntu 8.04 LTS Server
Posts: 84

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by repo View Post
Seems to me port 25 outgoing is blocked.
Did you asked you provider ?
I did not, but I will try. My provider is not very talkative. But now, if you say there are no other obvious reasons for this, I will give it a try.

Why would they do something foolish like this?
 
Old 08-02-2009, 01:31 PM   #8
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Slackware 14.0
Posts: 8,464

Rep: Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877
Most providers block port 25 outgoing, except for their own smtp server,(for the dynamic IP's)
Also, most smtp servers don't accept connections from a dynamic IP

Quote:
Why would they do something foolish like this?
To prevent infected machines to sent SPAM
 
Old 08-02-2009, 01:35 PM   #9
doru
Member
 
Registered: Sep 2008
Distribution: Ubuntu 8.04 LTS Server
Posts: 84

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by repo View Post
Most providers block port 25 outgoing, except for their own smtp server,(for the dynamic IP's)
Also, most smtp servers don't accept connections from a dynamic IP


To prevent infected machines to sent SPAM
My provider does not offer mail services.
My IP is static. Has been so for a number of years.
 
Old 08-02-2009, 01:36 PM   #10
EricTRA
Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 18 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290
Hello,

First of all Google Mail doesn't listen on port 25 but on port 465. So it's quite clear that you will not get a respons telnetting to port 25. So try telnetting to that port first.

I don't know about the port for smtp on yahoo but I'm sure you can find out.

I've got a Debian server on our LAN with postfix setup as a relay server and it sends everything nice and sweet over to our Google Mail for enterprises, which is the same as GMail for private use.

In the past I've worked with providers in various european countries and none of them ever blocked outgoing communication on ports in regards to mail, both incoming and outgoing.

Hope this helps you out somewhat.

Kind regards,

Eric
 
Old 08-02-2009, 01:40 PM   #11
okcomputer44
Member
 
Registered: Jun 2008
Location: /home/laz
Distribution: CentOS/Debian
Posts: 236

Rep: Reputation: 51
Quote:
Originally Posted by doru View Post
I did not, but I will try. My provider is not very talkative. But now, if you say there are no other obvious reasons for this, I will give it a try.

Why would they do something foolish like this?
Almost all provider do that now days. Because of the lovely virus/maleware infections on Windows clients.

You must configure the smart host under sendmail.mc to point to the ISP's smtp server.

The telnet wont work either because of that.
Only the secure smtp(465) allowed to send mail to outside world from local server.

Laz
 
Old 08-02-2009, 01:43 PM   #12
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Slackware 14.0
Posts: 8,464

Rep: Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877
Quote:
First of all Google Mail doesn't listen on port 25 but on port 465. So it's quite clear that you will not get a respons telnetting to port 25. So try telnetting to that port first.
Quote:
repo@cannabis:~$ telnet smtp.google.com 25
Trying 74.125.45.25...
Connected to smtp1.google.com.
Escape character is '^]'.
220 smtp.google.com ESMTP
quit
221 2.0.0 smtp.google.com closing connection
Connection closed by foreign host.
repo@cannabis:~$
And for gmail
Quote:
repo@cannabis:~$ telnet smtp.gmail.com 25
Trying 216.239.59.109...
Connected to gmail-smtp-msa.l.google.com.
Escape character is '^]'.
220 mx.google.com ESMTP q9sm19578323gve.17
quit
221 2.0.0 closing connection q9sm19578323gve.17
Connection closed by foreign host.
repo@cannabis:~$

Last edited by repo; 08-02-2009 at 01:49 PM.
 
Old 08-02-2009, 01:46 PM   #13
doru
Member
 
Registered: Sep 2008
Distribution: Ubuntu 8.04 LTS Server
Posts: 84

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by EricTRA View Post
Hello,

First of all Google Mail doesn't listen on port 25 but on port 465. So it's quite clear that you will not get a respons telnetting to port 25. So try telnetting to that port first.

In the past I've worked with providers in various european countries and none of them ever blocked outgoing communication on ports in regards to mail, both incoming and outgoing.

Hope this helps you out somewhat.

Kind regards,

Eric
Thanks.

Still no reply from:

telnet smtp.google.com 465

I am in Romania, so I'm not sure that my provider does not block ports...
 
Old 08-02-2009, 01:51 PM   #14
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Slackware 14.0
Posts: 8,464

Rep: Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877
Quote:
telnet smtp.google.com 465
Try
Code:
telnet smtp.gmail.com 465
 
Old 08-02-2009, 01:53 PM   #15
EricTRA
Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 18 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290
Hello,

Sorry for that, I got it from Google Settings for Email client. Since that was the only one I now after trying to configure smtp.gmail.com on port 25 in the past with resulting in errors on Outlook, Thunderbird, and so on, ... I assumed that port 25 would not be listening.

I'm sure however that my server at work is NOT connecting on port 25 to Gmail for enterprises.

Kind regards,

Eric
 
  


Reply

Tags
sendmail, smtp


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
syslog to email at @ yahoo or gmail serabut Linux - Software 2 12-13-2006 10:43 PM
Strange problem with Yahoo and Gmail Hitboxx Fedora 4 10-15-2006 07:11 PM
Mail server implementation of gmail,yahoo etc... naveenrajn Linux - General 0 01-10-2006 01:27 AM
yahoo marks Gmail messages as spam arunswarup General 8 11-04-2005 09:45 AM
How to hear conference call at Yahoo? mfeat Red Hat 2 01-20-2004 10:01 PM


All times are GMT -5. The time now is 03:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration