LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   sendmail does not hear from yahoo, gmail (http://www.linuxquestions.org/questions/linux-newbie-8/sendmail-does-not-hear-from-yahoo-gmail-744550/)

doru 08-02-2009 01:24 PM

sendmail does not hear from yahoo, gmail
 
I installed Fedora 11, text mode, Mail Server group included, and I tried to exchange e-mails with my accounts at yahoo.com and gmail.com. It does not work.

I am using mailx as a Mail User Agent (MUA) and sendmail as a Mail Transfer Agent (MTA), with default settings.

I can see, with tcpdump, tcp packets going to ...yahoo.com:smtp and google.com:smtp, but there is no response.

iptables: I tried iptables and tcpdump, and I believe that tcpdump listens outside iptables, that is, it sees packets after they leave and before they enter. Anyway, there are some iptables logs which show nothing.

Plese give me any idea, because I am stuck. I even read somewhere that it is possible that my ISP stops smtp connections, but I believe that this is not the case.

Thank you for your help.

repo 08-02-2009 01:41 PM

Any pointers in the logfiles ?
/var/log/...
Try to disable the firewall.

doru 08-02-2009 01:56 PM

Quote:

Originally Posted by repo (Post 3628579)
Any pointers in the logfiles ?
/var/log/...
Try to disable the firewall.

/var/log/maillog says "Connection timed out".

My address is: root@localhost.localdomain, but still, yahoo should establish smtp connection.

I am reluctant to disable iptables, for security reasons. I hope I can verify other issues before I try this. On one hand, I believe that tcpdump sees outside iptables, so it should see any response. On the other hand, iptables is fairly complicated, maybe it does not identify smtp connections.

repo 08-02-2009 02:10 PM

What is the output from
Code:

telnet smtp.google.com 25

doru 08-02-2009 02:18 PM

Quote:

Originally Posted by repo (Post 3628601)
What is the output from
Code:

telnet smtp.google.com 25

I tried both mailx and telnet smtp.google.com 25, both with and without iptables active, and there is nothing but a deadly silence. telnet says:
Trying 74.125.45.25...
and there it dies. I hope 20s should be enough, to wait without iptables, for telnet?

Thanks for your help.

repo 08-02-2009 02:21 PM

Seems to me port 25 outgoing is blocked.
Did you asked you provider ?

doru 08-02-2009 02:27 PM

Quote:

Originally Posted by repo (Post 3628616)
Seems to me port 25 outgoing is blocked.
Did you asked you provider ?

I did not, but I will try. My provider is not very talkative. But now, if you say there are no other obvious reasons for this, I will give it a try.

Why would they do something foolish like this?

repo 08-02-2009 02:31 PM

Most providers block port 25 outgoing, except for their own smtp server,(for the dynamic IP's)
Also, most smtp servers don't accept connections from a dynamic IP

Quote:

Why would they do something foolish like this?
To prevent infected machines to sent SPAM

doru 08-02-2009 02:35 PM

Quote:

Originally Posted by repo (Post 3628627)
Most providers block port 25 outgoing, except for their own smtp server,(for the dynamic IP's)
Also, most smtp servers don't accept connections from a dynamic IP


To prevent infected machines to sent SPAM

My provider does not offer mail services.
My IP is static. Has been so for a number of years.

EricTRA 08-02-2009 02:36 PM

Hello,

First of all Google Mail doesn't listen on port 25 but on port 465. So it's quite clear that you will not get a respons telnetting to port 25. So try telnetting to that port first.

I don't know about the port for smtp on yahoo but I'm sure you can find out.

I've got a Debian server on our LAN with postfix setup as a relay server and it sends everything nice and sweet over to our Google Mail for enterprises, which is the same as GMail for private use.

In the past I've worked with providers in various european countries and none of them ever blocked outgoing communication on ports in regards to mail, both incoming and outgoing.

Hope this helps you out somewhat.

Kind regards,

Eric

okcomputer44 08-02-2009 02:40 PM

Quote:

Originally Posted by doru (Post 3628622)
I did not, but I will try. My provider is not very talkative. But now, if you say there are no other obvious reasons for this, I will give it a try.

Why would they do something foolish like this?

Almost all provider do that now days. Because of the lovely virus/maleware infections on Windows clients.

You must configure the smart host under sendmail.mc to point to the ISP's smtp server.

The telnet wont work either because of that.
Only the secure smtp(465) allowed to send mail to outside world from local server.

Laz

repo 08-02-2009 02:43 PM

Quote:

First of all Google Mail doesn't listen on port 25 but on port 465. So it's quite clear that you will not get a respons telnetting to port 25. So try telnetting to that port first.
Quote:

repo@cannabis:~$ telnet smtp.google.com 25
Trying 74.125.45.25...
Connected to smtp1.google.com.
Escape character is '^]'.
220 smtp.google.com ESMTP
quit
221 2.0.0 smtp.google.com closing connection
Connection closed by foreign host.
repo@cannabis:~$
And for gmail
Quote:

repo@cannabis:~$ telnet smtp.gmail.com 25
Trying 216.239.59.109...
Connected to gmail-smtp-msa.l.google.com.
Escape character is '^]'.
220 mx.google.com ESMTP q9sm19578323gve.17
quit
221 2.0.0 closing connection q9sm19578323gve.17
Connection closed by foreign host.
repo@cannabis:~$

doru 08-02-2009 02:46 PM

Quote:

Originally Posted by EricTRA (Post 3628634)
Hello,

First of all Google Mail doesn't listen on port 25 but on port 465. So it's quite clear that you will not get a respons telnetting to port 25. So try telnetting to that port first.

In the past I've worked with providers in various european countries and none of them ever blocked outgoing communication on ports in regards to mail, both incoming and outgoing.

Hope this helps you out somewhat.

Kind regards,

Eric

Thanks.

Still no reply from:

telnet smtp.google.com 465

I am in Romania, so I'm not sure that my provider does not block ports...

repo 08-02-2009 02:51 PM

Quote:

telnet smtp.google.com 465
Try
Code:

telnet smtp.gmail.com 465

EricTRA 08-02-2009 02:53 PM

Hello,

Sorry for that, I got it from Google Settings for Email client. Since that was the only one I now after trying to configure smtp.gmail.com on port 25 in the past with resulting in errors on Outlook, Thunderbird, and so on, ... I assumed that port 25 would not be listening.

I'm sure however that my server at work is NOT connecting on port 25 to Gmail for enterprises.

Kind regards,

Eric


All times are GMT -5. The time now is 09:15 PM.