LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-16-2008, 11:51 PM   #1
jagdishpsp
LQ Newbie
 
Registered: Oct 2008
Posts: 12

Rep: Reputation: 0
sendmai prorblem


Hi,

I am getting below sendmail problem. Please suggest.

this error is from maillog
"daemon MTA: problem creating SMTP socket"
"NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Cannot assign requested address'

this is from sendmail status
"sendmail dead but subsys locked"


Jagdish
 
Old 10-16-2008, 11:57 PM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Have you seen:
http://www.linuxquestions.org/questi...address-84218/

Remember to also quote the command which produced the error.
 
Old 10-17-2008, 12:01 AM   #3
jagdishpsp
LQ Newbie
 
Registered: Oct 2008
Posts: 12

Original Poster
Rep: Reputation: 0
[root@rtinternal subsys]#tail -f /var/log/maillog

Oct 17 10:30:52 rtinternal sendmail[5792]: daemon MTA: problem creating SMTP socket
Oct 17 10:30:57 rtinternal sendmail[5792]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA: cannot bind: Cannot assign requested address

[root@rtinternal subsys]# service sendmail status
sendmail dead but subsys locked
 
Old 10-17-2008, 02:20 AM   #4
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Delete the lock file in /var/lock/subsys.
Retry, then check the log.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sendmai can send mails but unable to receive mails satimis Linux - Server 2 02-15-2007 09:22 AM
Sendmai with STARTTLS with self-signed certificete veeraalin Linux - Security 0 12-01-2005 10:53 PM
General questions about fresh Slack install and Sendmai ubers0ldat Linux - Software 6 01-22-2005 03:41 PM


All times are GMT -5. The time now is 07:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration