LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   SELinux Error :( Fedora 10 - help (http://www.linuxquestions.org/questions/linux-newbie-8/selinux-error-fedora-10-help-729991/)

manuleka 06-01-2009 07:31 PM

SELinux Error :( Fedora 10 - help
 
Code:

[manu@fedacrylic ~]$ system-config-selinux
/usr/share/system-config-selinux/system-config-selinux.py:72: Warning: IA__g_object_get_valist: object class `GnomeProgram' has no property named `default-icon'
  xml = gtk.glade.XML ("/usr/share/system-config-selinux/system-config-selinux.glade", domain=PROGNAME)
Traceback (most recent call last):
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 188, in <module>
    app = childWindow()
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 91, in __init__
    self.add_page(portsPage.portsPage(xml))
  File "/usr/share/system-config-selinux/portsPage.py", line 69, in __init__
    self.load()
  File "/usr/share/system-config-selinux/portsPage.py", line 136, in load
    self.store.set_value(iter, PROTOCOL_COL, k[2])
IndexError: tuple index out of range

i recently updated my system.. installed cedega for a trial...

unSpawn 06-02-2009 12:01 PM

Not a SELinux but a Python error. See if https://bugzilla.redhat.com/show_bug.cgi?id=502557 gets you going.

manuleka 06-02-2009 05:49 PM

Quote:

Originally Posted by unSpawn (Post 3560510)
Not a SELinux but a Python error. See if https://bugzilla.redhat.com/show_bug.cgi?id=502557 gets you going.

thanks, i've looked into that... i have tried installing policycoreutils-2.0.57-22.fc10.rpm but with no luck...

i get this error:
Code:

policycoreutils = 2.0.57-21.fc10 is needed by package policycoreutils-gui-2.0.57-21.fc10.i386
does that mean that i have to download policycoreutils-gui-2.0.57-22.fc10 as well? i've done quite abit of searching with no luck :(

chrism01 06-02-2009 06:03 PM

If you use yum instead of rpm,it should handle the dependencies automatically (or just use the Add/Remove SW gui)

manuleka 06-02-2009 06:49 PM

Quote:

Originally Posted by chrism01 (Post 3560888)
If you use yum instead of rpm,it should handle the dependencies automatically (or just use the Add/Remove SW gui)

yum says latest version is installed... i even looked into uninstalling 21 and install 22 myself but a whole bunch of programs (dependencies) will have to be removed together with it...

this sux becuase i can't access selinux management to do some access configs for my network shares...

unSpawn 06-02-2009 07:06 PM

policycoreutils-2.0.57-22.fc10 was released 02/06, maybe needs a few hours to propagate through repo's?

manuleka 06-02-2009 07:09 PM

Quote:

Originally Posted by unSpawn (Post 3560939)
policycoreutils-2.0.57-22.fc10 was released 02/06, maybe needs a few hours to propagate through repo's?

oh ok! i hope it will be available soon (as i'm on 03/06 already)... really need this error fixed... thanks


All times are GMT -5. The time now is 04:13 AM.