LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-05-2002, 01:41 PM   #1
abounidal
LQ Newbie
 
Registered: Nov 2002
Posts: 2

Rep: Reputation: 0
second HD problem


Hello,

I recently purchased a 40 gb harddisk, and i installed it - due to lack of space- to the CDROM cable. This should give no problem. The new harddisk is secondary master.

In fstab i entered

/dev/hdc1 /data msdos user,auto,rw

since it is going to function as a network drive for windows machines. When i try to mount the drive the system says
"mount: wrong fs type, bad option, bad superblock on /dev/hdc1,
or too many mounted file systems"

I tried to fdisk the new drive to linux format and enter it in fstab as a ext2 type, but the problem remains...

Has anyone an idea what causes this...
 
Old 11-05-2002, 01:57 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Well if you formatted it first for windows, did you format it as msdos or FAT ?? If so try changing your fstab to read like this also changing the permissions and see what happens:

/dev/hdc1 /data vfat defaults 0 0

You can also try the same thing with the Linux format. Now when you say fdisk, are you actually formatting the drive or just specifying what type it is in fdisk ?? You have to use mk2fs the drive before it will actually use that type of filesystem. Same concept goes for the Windows format your trying, you actually have to be formatting it, not just specifying the type it is.
 
Old 11-05-2002, 01:57 PM   #3
vladkrack
Member
 
Registered: Oct 2002
Location: Curitiba - Brazil
Distribution: Conectiva
Posts: 334

Rep: Reputation: 30
Hi,

The mount error you got is because your system can't recognize the fylesystem type you that you passed.

To mount windows filesystems I use the "vfat" option, unless the disk is formated using "ntfs" ...

Probably the error in the ext2 happened because yours partition was not formated in this filesystem type ...

If you will use your disk to export to windows machines, you probably you have to use "samba", so the filesystem type of your disk don't affect the usability...

I hope that help's ...
 
Old 11-06-2002, 04:13 AM   #4
abounidal
LQ Newbie
 
Registered: Nov 2002
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks everyone!

the problem was solved by typing echo "/dev/hdc1 /data ext2 defaults 0 0" >>fs
tab

in both fstab and mtab, selecting LINUX NATIVE as filesystem and running the mk2fs (already did those last two steps)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
perl problem? apache problem? cgi problem? WorldBuilder Linux - Software 1 09-17-2003 08:45 PM


All times are GMT -5. The time now is 02:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration